ID: 16043
Comment by: martinn at portant dot com
Reported By: tokimeki at pchome dot com dot tw
Status: Closed
Bug Type: Session related
Operating System: Windows XP
PHP Version: 4.1.2
New Comment:

The error still exists with PHP 4.3.3 on Win2000, Apache 1.3.24,
running as a module.


Previous Comments:
------------------------------------------------------------------------

[2003-06-10 21:52:48] php at rjs3 dot com

I thought I was having this problem when I discovered that my cookie
domain in php.ini was set. I host multiple virtual domains, and when I
was trying use sessions on a different domain they would always fail.
I have since changed the cookie domain to blank so it defaults to the
server which issues the cookie. Just something else to check for
anyone still having problems.

------------------------------------------------------------------------

[2003-04-19 10:41:29] no at bulk-e-mail-marketing dot com

WOW, I have been working on this problem for days, I am running php
4.0.6 on suse linux7.3 and had the same problem. This IS what fixxed
me.

// $HTTP_SESSION_VARS bugfix
while(list($key , $value) = each($HTTP_SESSION_VARS)){
session_register($key);
$$key = $value;
}

which was listed on this page by bluefoot project. THXS guys :-)

------------------------------------------------------------------------

[2003-04-01 18:53:47] madstarr at bellsouth dot net

Noticed that most of these emails related to the $_Session not
maintaining the variable value occurred in 2002. Has this been
resolved? I saw mentioned it was resolved with 4.2.0. I am running
4.2.2 on an NT 5.0 system, and experiencing the same problem trying to
process form data from 3 forms. I combined the forms into 1, got rid of
the $_SESSION and just used $_POST, works perfectly. What's the deal,
is it fixed?

------------------------------------------------------------------------

[2003-02-21 17:20:39] twjohnso at hotmail dot com

I too am having the same issue... here is my info...
PHP Version: 4.3.1 (Windows Binary)
OS Version: Win2K Pro, SP2
Webserver: IIS
MySQL version: 4.0.10 gamma (win32)

PHP Settings...
file_uploads = On/Off (someone said this helped for them, didnt seem
to
make a difference for me)
register_globals = On/Off (someone said this helped for them, didnt
seem
to make a difference for me)
session support = enabled

Regards,
Tj

------------------------------------------------------------------------

[2003-01-24 13:14:48] sbeam at rtint dot net

ok I will ask Redhat to send the aspirin and cake

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
[url]http://bugs.php.net/16043[/url]

--
Edit this bug report at [url]http://bugs.php.net/?id=16043&edit=1[/url]