Professional Web Applications Themes

#16263 [Com]: session.start() create new empty session file and not resume existing session - PHP Bugs

ID: 16263 Comment by: pat at burnttech dot com Reported By: kur at natur dot cuni dot cz Status: No Feedback Bug Type: Session related Operating System: ANY PHP Version: 4.3.0-dev New Comment: Same Problem 4.3.3 IIS Win2k Server Previous Comments: ------------------------------------------------------------------------ [2003-06-12 13:04:24] steveh at brendata dot co dot uk I'm seeing the same issue on 4.3.2 on NT4 and IIS. I get a new session each time I log in, I've dumped the cookie array $_COOKIE and I see an extra cookie created each time with the name of the file in the sessiondata directory. But I thought ...

  1. #1

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: pat at burnttech dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Same Problem 4.3.3 IIS Win2k Server


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-06-12 13:04:24] steveh at brendata dot co dot uk

    I'm seeing the same issue on 4.3.2 on NT4 and IIS.

    I get a new session each time I log in, I've dumped the cookie array
    $_COOKIE and I see an extra cookie created each time with the name of
    the file in the sessiondata directory.

    But I thought that there should be a cookie called PHPSESSID or
    whatever your session name is called?

    I don't see this cookie, is this the underlying issue?

    Judging by the number of entries here, I think some effort needs to go
    into sorting this issue, it's been open and closed more times than.....

    ------------------------------------------------------------------------

    [2003-03-25 08:26:07] RockyTheSuperDog at hotmail dot com

    Same prob with Apache 2 on win2000 with PHP 4.2.3 to 4.3.1 Tried
    messing with the Apache service login user permissions on php session
    data folder but no luck. Changed to IIS 5 and gave read/write
    permissions on the session data folder to IUSR_HOSTNAME and sessions
    started working again. Hope this info leads somebody to the right
    answer.

    ------------------------------------------------------------------------

    [2003-03-24 16:09:12] roland at lichti dot de

    Sorry for this rant, but I'm really ed off: the session handling
    problem is reported several times and every time closed as "bogus" or
    "no feedback". I really think that the programming team has no clue
    where to look at and should reimplement the whole code related to
    session handling. It's going on now for at least 1 year and there is no
    solution in sight :-(((

    ------------------------------------------------------------------------

    [2003-03-10 02:39:09] kasei999 at hotmail dot com

    Same here, after 3 non-sleeping days and nights I found this forum. I
    am using win XP with php 4.3.1 + apache 1.3.27 now switching to IIS 5,
    the problem still exists. Would anyone please try to help?

    ------------------------------------------------------------------------

    [2003-03-04 11:58:25] zorman at pina dot info

    same problems over here ...
    i'm experiencing this problem only when I redirect the page using
    header after the authentication is done ...

    it works fine on my linux computer (php 4.3.0) but fails on win2k with
    the same distribution ... very annoying ...

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    pat at burnttech dot com Guest

  2. #2

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: william dot li dot 1983 at gmail dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-07-18 22:20:35] cmi at colcenter dot org

    May be same problem ..

    4.2.3 version, WinXP

    Only IE 5 and IE 5.5 After login, any link on the page to a file with
    session_start() sets new (empty) session, and therefore am returned to
    login page.

    IE 6, Opera and Firefox all work correctly.

    Adding
    php_flag session.use_trans_sid on
    to my htaccess fixes it, but would rather not do that.

    ------------------------------------------------------------------------

    [2006-05-20 21:19:24] tony at tuxick dot net

    same problem on 5.1.2 and 5.1.4.
    php.ini shows ;default_cht = "iso-8859-1", suggesting
    it's default.
    enabling fixed the problem.

    ------------------------------------------------------------------------

    [2006-05-10 00:40:56] jeroen at haan dot net

    Changing the character set from utf-8 to the old iso-8859-1 helped. Now
    a session cookie is succesfully stored on the client and thereby the
    sessid and thus one file on the server maintained.

    However I do not understand this behavior.

    ------------------------------------------------------------------------

    [2006-04-26 07:00:18] sunmt at usa dot com

    I expereinced the same problem in PHP 5.0.5
    Reading\Writing to session works in the same page but the server loses
    the session when going between different pages or reloading the page.
    Please help me..

    ------------------------------------------------------------------------

    [2006-02-16 21:16:24] optikey at gmail dot com

    Same problem with 5.0.5 running on Debian x86_64...

    Only I.E. does this 2 cookies thing and scroolled my code...

    Digging the net, i found that those bugs started only in the browsers
    that executes windows update automatically...

    So i find that the day that the problems started matches the day of the
    release of one Microsoft Bugfix that affects I.E.
    14/feb/2006

    Only the updated browsers behave incorrectly....

    Might we need to blame M$....


    Any workarounds???
    Am i right???

    MS did not return the bug report...

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    william dot li dot 1983 at gmail dot com Guest

  3. #3

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: tobias dot hug at alpinenet dot ch
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-15 18:58:29] william dot li dot 1983 at gmail dot com

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.

    ------------------------------------------------------------------------

    [2006-07-18 22:20:35] cmi at colcenter dot org

    May be same problem ..

    4.2.3 version, WinXP

    Only IE 5 and IE 5.5 After login, any link on the page to a file with
    session_start() sets new (empty) session, and therefore am returned to
    login page.

    IE 6, Opera and Firefox all work correctly.

    Adding
    php_flag session.use_trans_sid on
    to my htaccess fixes it, but would rather not do that.

    ------------------------------------------------------------------------

    [2006-05-20 21:19:24] tony at tuxick dot net

    same problem on 5.1.2 and 5.1.4.
    php.ini shows ;default_cht = "iso-8859-1", suggesting
    it's default.
    enabling fixed the problem.

    ------------------------------------------------------------------------

    [2006-05-10 00:40:56] jeroen at haan dot net

    Changing the character set from utf-8 to the old iso-8859-1 helped. Now
    a session cookie is succesfully stored on the client and thereby the
    sessid and thus one file on the server maintained.

    However I do not understand this behavior.

    ------------------------------------------------------------------------

    [2006-04-26 07:00:18] sunmt at usa dot com

    I expereinced the same problem in PHP 5.0.5
    Reading\Writing to session works in the same page but the server loses
    the session when going between different pages or reloading the page.
    Please help me..

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    tobias dot hug at alpinenet dot ch Guest

  4. #4

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: jclewley at netprospex dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    [2006-11-15 18:58:29] william dot li dot 1983 at gmail dot com

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.

    ------------------------------------------------------------------------

    [2006-07-18 22:20:35] cmi at colcenter dot org

    May be same problem ..

    4.2.3 version, WinXP

    Only IE 5 and IE 5.5 After login, any link on the page to a file with
    session_start() sets new (empty) session, and therefore am returned to
    login page.

    IE 6, Opera and Firefox all work correctly.

    Adding
    php_flag session.use_trans_sid on
    to my htaccess fixes it, but would rather not do that.

    ------------------------------------------------------------------------

    [2006-05-20 21:19:24] tony at tuxick dot net

    same problem on 5.1.2 and 5.1.4.
    php.ini shows ;default_cht = "iso-8859-1", suggesting
    it's default.
    enabling fixed the problem.

    ------------------------------------------------------------------------

    [2006-05-10 00:40:56] jeroen at haan dot net

    Changing the character set from utf-8 to the old iso-8859-1 helped. Now
    a session cookie is succesfully stored on the client and thereby the
    sessid and thus one file on the server maintained.

    However I do not understand this behavior.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    jclewley at netprospex dot com Guest

  5. #5

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: failmore at yahoo dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    [2006-11-15 18:58:29] william dot li dot 1983 at gmail dot com

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.

    ------------------------------------------------------------------------

    [2006-07-18 22:20:35] cmi at colcenter dot org

    May be same problem ..

    4.2.3 version, WinXP

    Only IE 5 and IE 5.5 After login, any link on the page to a file with
    session_start() sets new (empty) session, and therefore am returned to
    login page.

    IE 6, Opera and Firefox all work correctly.

    Adding
    php_flag session.use_trans_sid on
    to my htaccess fixes it, but would rather not do that.

    ------------------------------------------------------------------------

    [2006-05-20 21:19:24] tony at tuxick dot net

    same problem on 5.1.2 and 5.1.4.
    php.ini shows ;default_cht = "iso-8859-1", suggesting
    it's default.
    enabling fixed the problem.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    failmore at yahoo dot com Guest

  6. #6

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: michaellai2006 at yahoo dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    [2006-11-15 18:58:29] william dot li dot 1983 at gmail dot com

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.

    ------------------------------------------------------------------------

    [2006-07-18 22:20:35] cmi at colcenter dot org

    May be same problem ..

    4.2.3 version, WinXP

    Only IE 5 and IE 5.5 After login, any link on the page to a file with
    session_start() sets new (empty) session, and therefore am returned to
    login page.

    IE 6, Opera and Firefox all work correctly.

    Adding
    php_flag session.use_trans_sid on
    to my htaccess fixes it, but would rather not do that.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    michaellai2006 at yahoo dot com Guest

  7. #7

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: barts at time dot net dot my
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    [2006-11-15 18:58:29] william dot li dot 1983 at gmail dot com

    I got the same problem. Callin session.start() create a new
    session id and a corresponding file and session data are not
    maintained between pages.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    barts at time dot net dot my Guest

  8. #8

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: osa_57 at mail dot ru
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    sessions dont work
    Win2000, Apache 2, PHP 4.4.4, IE5
    help me please!


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    osa_57 at mail dot ru Guest

  9. #9

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: par at tor dot se
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    [2006-11-16 18:24:33] tobias dot hug at alpinenet dot ch

    I've got the same problem with php 5.1.6.
    session data is not maintained between pages.

    If I add default_cht = "iso-8859-1"; in php.ini, everything works.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    par at tor dot se Guest

  10. #10

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: morten at vianett dot no
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-18 19:20:45] par at tor dot se

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.

    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    [2006-11-22 11:13:38] jclewley at netprospex dot com

    Try setting cookie_domain in php.ini to a period (.) followed by your
    domain. For example, ".google.com". The default typically tells PHP
    to use [url]www.google.com[/url] which will cause problems if the user types
    google.com.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    morten at vianett dot no Guest

  11. #11

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: general at itpsg dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-07 09:35:10] morten at vianett dot no

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..

    ------------------------------------------------------------------------

    [2007-01-18 19:20:45] par at tor dot se

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.

    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    [2006-12-02 04:51:44] failmore at yahoo dot com

    Similar problem happend to me. The following is my configuration:
    Apache 2.2.3,
    PHP 5.1.16
    I tried three different browsers, IE, FireFox, Maxthon
    same error happens.
    I host the website on my local machine, Win XP Home, therefore, I try
    to access the site using [url]http://localhost/testsite[/url]

    add default_cht = "iso-8859-1"; in php.ini, did not work
    set setting cookie_domain=localhost did not work
    set session.use_trans_sid on did not work.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    general at itpsg dot com Guest

  12. #12

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: e at sloven dot net
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    I have same problem and I have tried all suggested solutions. Problem
    still remains.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-16 20:29:24] general at itpsg dot com

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!

    ------------------------------------------------------------------------

    [2007-02-07 09:35:10] morten at vianett dot no

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..

    ------------------------------------------------------------------------

    [2007-01-18 19:20:45] par at tor dot se

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.

    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    [2006-12-02 05:00:24] michaellai2006 at yahoo dot com

    Same thing for 5.1.16
    I tried other people's suggestion, did not work for me neither.

    Please give a workaround.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    e at sloven dot net Guest

  13. #13

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: george at edynamo dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    same problem here - FC4, PHP 5.0.2 - session files are empty.
    possible solution ( sometimes works ) - use session_register insted of
    $_SESSION to set a new value to the session


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-19 15:11:11] e at sloven dot net

    I have same problem and I have tried all suggested solutions. Problem
    still remains.

    ------------------------------------------------------------------------

    [2007-02-16 20:29:24] general at itpsg dot com

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!

    ------------------------------------------------------------------------

    [2007-02-07 09:35:10] morten at vianett dot no

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..

    ------------------------------------------------------------------------

    [2007-01-18 19:20:45] par at tor dot se

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.

    ------------------------------------------------------------------------

    [2006-12-24 13:18:44] barts at time dot net dot my

    PHP 5.1.4
    Windows NT SERVER 5.1 build 2600

    Possible workarounds installed as mentioned in the thread.

    I also noticed that the session cookie is not updated
    when another pages is loaded that contains session_start();
    This causes the session always to expire after its lifetime,
    where I expect the session to expire after the last session_start +
    lifetime.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    george at edynamo dot com Guest

  14. #14

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: bagginsbh at hotmail dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Generally occurs during peak server loads. Intermittently, a new
    session is created at session_start() call even though the cookie id
    has not changed. Old session file remains with associated data. New
    session wipes out all key value pairs resulting in lost data.

    PHP Version: 4.3.9
    Server: Apache 2.0
    OS: wsprolinux
    kernel: 2.6.9-42


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-20 16:03:58] george at edynamo dot com

    same problem here - FC4, PHP 5.0.2 - session files are empty.
    possible solution ( sometimes works ) - use session_register insted of
    $_SESSION to set a new value to the session

    ------------------------------------------------------------------------

    [2007-02-19 15:11:11] e at sloven dot net

    I have same problem and I have tried all suggested solutions. Problem
    still remains.

    ------------------------------------------------------------------------

    [2007-02-16 20:29:24] general at itpsg dot com

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!

    ------------------------------------------------------------------------

    [2007-02-07 09:35:10] morten at vianett dot no

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..

    ------------------------------------------------------------------------

    [2007-01-18 19:20:45] par at tor dot se

    Try to change this:

    session.save_path = "0;c:\program files\php\tmp"

    don't forget to use the 0; before the path.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/16263[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=16263&edit=1[/url]
    bagginsbh at hotmail dot com Guest

  15. #15

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: akk7788 at yahoo dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    Has a workaround been posted for this yet? I'm having a similar
    problem.

    THanks


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-03-13 06:53:07] bagginsbh at hotmail dot com

    Generally occurs during peak server loads. Intermittently, a new
    session is created at session_start() call even though the cookie id
    has not changed. Old session file remains with associated data. New
    session wipes out all key value pairs resulting in lost data.

    PHP Version: 4.3.9
    Server: Apache 2.0
    OS: wsprolinux
    kernel: 2.6.9-42

    ------------------------------------------------------------------------

    [2007-02-20 16:03:58] george at edynamo dot com

    same problem here - FC4, PHP 5.0.2 - session files are empty.
    possible solution ( sometimes works ) - use session_register insted of
    $_SESSION to set a new value to the session

    ------------------------------------------------------------------------

    [2007-02-19 15:11:11] e at sloven dot net

    I have same problem and I have tried all suggested solutions. Problem
    still remains.

    ------------------------------------------------------------------------

    [2007-02-16 20:29:24] general at itpsg dot com

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!

    ------------------------------------------------------------------------

    [2007-02-07 09:35:10] morten at vianett dot no

    Same problem using v5.2.0

    I get empty sess_ files in /tmp

    I have had this problem many times before. It seems that it works if
    its installed on a sunny day..

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/16263

    --
    Edit this bug report at http://bugs.php.net/?id=16263&edit=1
    akk7788 Guest

  16. #16

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: bagginsbh at hotmail dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    The only work around I have found is on the first call to start a
    session in your application capture that session id. Then pass it in the
    url or as a form parameter. After the session_start() call on your next
    page, reset the session id to the passed in session id. Also may
    consider archiving all session files such that can be pd at a later
    time to extract the key-value pairs.

    This bug has been a major, major problem in my clients environment.
    This has been the first time I have run into it. It also has nothing to
    do with the time of the session as I have had the lost session occur in
    less than 2 minutes after session start.

    If not executing a session destroy, which will delete the session file
    from the temp location, then look at the old session files and recover
    the `lost` parameters.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-03-15 05:21:59] akk7788 at yahoo dot com

    Has a workaround been posted for this yet? I'm having a similar
    problem.

    THanks

    ------------------------------------------------------------------------

    [2007-03-13 06:53:07] bagginsbh at hotmail dot com

    Generally occurs during peak server loads. Intermittently, a new
    session is created at session_start() call even though the cookie id has
    not changed. Old session file remains with associated data. New session
    wipes out all key value pairs resulting in lost data.

    PHP Version: 4.3.9
    Server: Apache 2.0
    OS: wsprolinux
    kernel: 2.6.9-42

    ------------------------------------------------------------------------

    [2007-02-20 16:03:58] george at edynamo dot com

    same problem here - FC4, PHP 5.0.2 - session files are empty.
    possible solution ( sometimes works ) - use session_register insted of
    $_SESSION to set a new value to the session

    ------------------------------------------------------------------------

    [2007-02-19 15:11:11] e at sloven dot net

    I have same problem and I have tried all suggested solutions. Problem
    still remains.

    ------------------------------------------------------------------------

    [2007-02-16 20:29:24] general at itpsg dot com

    I am having the same problem. I have tried all the suggestions here.
    One system is fedora core 4 the other is fedora core 5. Updating the
    packages does not help. Setting cht does not help. Adding 0; to
    the save_path does not help. The save path has the appropriate
    permissions. The session file is created but always empty. Using
    session_write_close has no effect. We developed the application, fully
    tested, went to deploy and now this is ing everything up...ouch!

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/16263

    --
    Edit this bug report at http://bugs.php.net/?id=16263&edit=1
    bagginsbh Guest

  17. #17

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: chunyanjk at 163 dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    [url=http://www.haoting.com]music[/url]
    <a href=http://www.haoting.com>music</a>


    Previous Comments:
    ------------------------------------------------------------------------

    [2008-06-26 10:50:29] karst at spectraweb dot nl

    I have apache/php configured to run as another user then "apache". I
    tried to install php-xml and yum updated php, setting the owner of the
    directory where the sessions are stored to "apache", NOT MY USER!

    This worked for me:

    to check if this was the problem I did a chmod 777 to session directory
    - and: it worked again

    I changed the owner of the session directory to my apache user,
    chmodded session directory to the initial 770 - and yay: it worked.

    ------------------------------------------------------------------------

    [2008-06-02 12:45:16] shashibanzal at hotmail dot com

    While running a programme as a login for librarian, if the name of
    programme is changed in the URL, it switches to the pgm entered now and
    the borrower can perform all functions of librarian. This is not
    correct. Session start has been used.

    ------------------------------------------------------------------------

    [2008-05-25 21:59:47] gsimanton at gmail dot com

    I found this on the php.net session page, and it worked for me:

    <b> johnlonely at gmail dot com<b>
    12-Oct-2005 02:32
    Everytime I upgrade PHP to a new version, I used to recompile the
    php.ini file. Everytime I create a website, I always kept the php.ini
    file so that in the future I would be able to retrieve some Unique
    properties of the php version I used. So the last php version I've seen
    where session is sticking is version 4.2. I've been trying for two days
    with no luck searching the manual and forum, when I tried something :

    If you guys always fill the
    session.cookie_path = /
    to somewhere you the cookies should go, then leave the fuss. You'll
    save two days! Leave it be!

    [Session]
    session.cookie_path = /

    Happy sticking sessions.

    ------------------------------------------------------------------------

    [2008-05-20 11:27:30] moi at discardmail dot com

    I have the same problem on:
    Windows XP,
    Apache 1.3
    PHP 5.2

    But only in IE6. I have set all security setting s in IE6 to lowest and
    the script

    <?
    session_start();
    print session_id();
    ?>

    still generates new session on every page load. The same script, the
    same server and FF2 or IE7 work right.

    Any ideas?

    ------------------------------------------------------------------------

    [2008-05-14 11:12:52] pmioni at hce dot it

    I had the same problem with Vista and EasyPHP. $_SESSION has problems
    when you give it numbers as indexes.
    So, for example, if you're trying to register the results of a
    mysql_fetch_row or mysql_fetch_array (which contain numeric indexes) the
    thing fails, because $_SESSION does not accept the indexes - the file
    will be empty and nothing is saved in session

    Try to save the results of mysql_fetch_assoc instead.

    (Obviously, session permissions , path etc. must be correctly set).

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/16263

    --
    Edit this bug report at http://bugs.php.net/?id=16263&edit=1

    chunyanjk Guest

  18. #18

    Default #16263 [Com]: session.start() create new empty session file and not resume existing session

    ID: 16263
    Comment by: robin dot chauhan at gmail dot com
    Reported By: kur at natur dot cuni dot cz
    Status: No Feedback
    Bug Type: Session related
    Operating System: ANY
    PHP Version: 4.3.0-dev
    New Comment:

    As noted on http://www.kirupa.com/forum/showthread.php?t=288773

    "After 10 hours of searching over 2 days, I figured it out. The UTF-8
    encoding was placing invisible characters before my <?php tag, thus
    throwing an error (which I couldn't see because my server host's debug
    doesn't show). Switching to ANSI removed those characters and thus the
    session_start() functioned properly this time, giving me a consistent
    session ID. Thanks to those who helped."


    Previous Comments:
    ------------------------------------------------------------------------

    [2008-06-26 10:50:29] karst at spectraweb dot nl

    I have apache/php configured to run as another user then "apache". I
    tried to install php-xml and yum updated php, setting the owner of the
    directory where the sessions are stored to "apache", NOT MY USER!

    This worked for me:

    to check if this was the problem I did a chmod 777 to session directory
    - and: it worked again

    I changed the owner of the session directory to my apache user,
    chmodded session directory to the initial 770 - and yay: it worked.

    ------------------------------------------------------------------------

    [2008-06-02 12:45:16] shashibanzal at hotmail dot com

    While running a programme as a login for librarian, if the name of
    programme is changed in the URL, it switches to the pgm entered now and
    the borrower can perform all functions of librarian. This is not
    correct. Session start has been used.

    ------------------------------------------------------------------------

    [2008-05-25 21:59:47] gsimanton at gmail dot com

    I found this on the php.net session page, and it worked for me:

    <b> johnlonely at gmail dot com<b>
    12-Oct-2005 02:32
    Everytime I upgrade PHP to a new version, I used to recompile the
    php.ini file. Everytime I create a website, I always kept the php.ini
    file so that in the future I would be able to retrieve some Unique
    properties of the php version I used. So the last php version I've seen
    where session is sticking is version 4.2. I've been trying for two days
    with no luck searching the manual and forum, when I tried something :

    If you guys always fill the
    session.cookie_path = /
    to somewhere you the cookies should go, then leave the fuss. You'll
    save two days! Leave it be!

    [Session]
    session.cookie_path = /

    Happy sticking sessions.

    ------------------------------------------------------------------------

    [2008-05-20 11:27:30] moi at discardmail dot com

    I have the same problem on:
    Windows XP,
    Apache 1.3
    PHP 5.2

    But only in IE6. I have set all security setting s in IE6 to lowest and
    the script

    <?
    session_start();
    print session_id();
    ?>

    still generates new session on every page load. The same script, the
    same server and FF2 or IE7 work right.

    Any ideas?

    ------------------------------------------------------------------------

    [2008-05-14 11:12:52] pmioni at hce dot it

    I had the same problem with Vista and EasyPHP. $_SESSION has problems
    when you give it numbers as indexes.
    So, for example, if you're trying to register the results of a
    mysql_fetch_row or mysql_fetch_array (which contain numeric indexes) the
    thing fails, because $_SESSION does not accept the indexes - the file
    will be empty and nothing is saved in session

    Try to save the results of mysql_fetch_assoc instead.

    (Obviously, session permissions , path etc. must be correctly set).

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/16263

    --
    Edit this bug report at http://bugs.php.net/?id=16263&edit=1

    robin Guest

Similar Threads

  1. #39144 [NEW]: curl session non-existing file:// corrupts php session
    By troelskn at gmail dot com in forum PHP Bugs
    Replies: 9
    Last Post: October 15th, 10:42 AM
  2. #25574 [Bgs]: empty session.save_path = problem (session.use_only_cookies = 1)
    By markus dot welsch at suk dot de in forum PHP Development
    Replies: 0
    Last Post: September 18th, 06:13 AM
  3. Replies: 0
    Last Post: September 17th, 10:36 PM
  4. #25574 [Opn]: empty session.save_path = problem (session.use_only_cookies = 1)
    By markus dot welsch at suk dot de in forum PHP Development
    Replies: 0
    Last Post: September 17th, 02:19 PM
  5. #25574 [NEW]: empty session.save_path = problem (session.use_only_cookies = 1)
    By markus dot welsch at suk dot de in forum PHP Development
    Replies: 0
    Last Post: September 17th, 02:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139