Professional Web Applications Themes

192.168.0.254 - Linux Setup, Configuration & Administration

when i checked the system log i found this line "pppd[1000] : not replacing existing default route to eth0[192.168.0.254]" i realy need someone to tell me why should i change the default route to 192.168.0.254? and how do i change it? and change to what? thanks...

  1. #1

    Default 192.168.0.254

    when i checked the system log i found this line
    "pppd[1000] : not replacing existing default route to
    eth0[192.168.0.254]"
    i realy need someone to tell me why should i change the default route
    to 192.168.0.254? and how do i change it? and change to what?
    thanks
    gamalt Guest

  2. #2

    Default Re: 192.168.0.254

    gamalt <com> wrote: 

    You should change it because I (and "it") tell you to. How are you
    going to route packets to the internet by default without a route through
    your pppd connection?

    You change it by not having a default route in the first place, thus
    letting pppd do its job. Or do it by hand with /sbin/route.

    You change it to what pppd will change it to. The address at the other
    end of your ptp connection. Simply

    route del default
    route add default dev ppp0

    or some variant should do the job. Man <various obvious things>.

    Peter
    P.T. Guest

  3. #3

    Default Re: 192.168.0.254

    On 12 Nov 2003 20:15:27 -0800, gamalt <com> wrote: 

    Normally you should have ONLY 1 default route, and it should be a remote
    IP that leads to the internet. If that default route out eth0 does not
    lead to the internet it should likely be removed, or changed to more
    specific local network routing. If it points to your own eth0 IP as
    gateway (loops back to you), it definitely needs to be removed
    permanently.

    If you have more than 1 path to the internet you either need to remove 1
    default route when using another, or if using more than 1 at the same
    time, you need to read the Adv-Routing HOWTO. But I suspect that you have
    a bogus eth0 default route that is unnecessary.

    --
    David Efflandt - All spam ignored http://www.de-srv.com/
    http://www.autox.chicago.il.us/ http://www.berniesfloral.net/
    http://cgi-help.virtualave.net/ http://hammer.prohosting.com/~cgi-wiz/
    David Guest

  4. #4

    Default Re: 192.168.0.254


    "gamalt" <com> wrote in message
    news:google.com... 

    The message says that is currently the default route ( most distributions
    will set a 'defaultroute' as a default. and the message says that the pppd
    is not going to replace it.

    I think you have to get your PPP configurator to deal with this default
    route issue,
    or manually put some options into /etc/ppp/options that tell it that its ok
    to replace the default route.


     

    pppd was trying to do something like
    route add default dev ppp0

    which means that the default route is to just blast the packets down the
    ppp0 line.

     


    Leon. Guest

  5. #5

    Default Re: 192.168.0.254

    On Thu, 27 Nov 2003 01:42:59 +1100,
    Leon. <net> wrote:

     
    >
    >The message says that is currently the default route ( most distributions
    >will set a 'defaultroute' as a default. and the message says that the pppd
    >is not going to replace it.
    >
    >I think you have to get your PPP configurator to deal with this default
    >route issue,
    >or manually put some options into /etc/ppp/options that tell it that its ok
    >to replace the default route.
    >[/ref]


    Actualy, the default route should be replaced by specific static routes
    going through the internal router. If there are no internal router
    then there should be no default route either, except the one that will
    be set up when ppp connects to the internet.

    For example if you have an internal network in the 10.0.0.0/8 network
    some of it behind a router called internal-router you make a static route
    like this.

    route add -net 10.0.0.0 netmask 255.0.0.0 gw internal-router

    Villy


    Villy Guest

  6. #6

    Default Re: 192.168.0.254

    Leon. wrote:
     
    >
    > The message says that is currently the default route ( most distributions
    > will set a 'defaultroute' as a default. and the message says that the pppd
    > is not going to replace it.
    >
    > I think you have to get your PPP configurator to deal with this default
    > route issue,
    > or manually put some options into /etc/ppp/options that tell it that its
    > ok to replace the default route.
    >
    >

    >
    > pppd was trying to do something like
    > route add default dev ppp0
    >
    > which means that the default route is to just blast the packets down the
    > ppp0 line.
    >
    > [/ref]

    Have you tried this - '/sbin/route del default'
    This gets rid of the default route (temporarily). To get rid of it
    permanently, you need to find what is setting it and stop it from doing so.
    I had a similar problem, and fixed it by commenting out the 'gateway' line
    in /etc/network/interfaces (by putting a '#' at the start of the line).

    Bartman
    Bartman Guest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139