ID: 19902
Comment by: mcflyzz at eazynew dot com
Reported By: juri at ria dot com
Status: Closed
Bug Type: Scripting Engine problem
Operating System: All Win
PHP Version: 4.2.3
New Comment:

How about the fix?????


Previous Comments:
------------------------------------------------------------------------

[2002-10-28 10:03:49] [email]iliaaphp.net[/email]

This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at [url]http://snaps.php.net/[/url].

In case this was a doentation problem, the fix will show up soon at
[url]http://www.php.net/manual/[/url].

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.

Thank you for the report, and for helping us make PHP better.

The broken browscap.ini is no longer being bundled with Windows
distributions of PHP. The doentation now links to a web site where a
working browscap.ini, which is frequently updated can be obtained.

------------------------------------------------------------------------

[2002-10-14 21:42:48] juri at ria dot com

Hello Iliaa

Thank you for acknowledging my initial "Suggestion". I do not recall
exactly when I first came across a bundled browscap.ini with "not valid
entries", but it must have been quite some time (php releases) ago.
Probably browscap.ini is a static item in the bundling process and thus
the invalid line 8206 got propagated with every (win) distribution.
There does not seem to be a reason, why future releases of PHP should
contain an uncorrected version of browscap.ini.

Thanks again.

Kind regards
Juri

------------------------------------------------------------------------

[2002-10-14 19:44:03] [email]iliaaphp.net[/email]

Actually after checking it seems the Windows distribution contains a
bundled browscap.ini file. My applogies. I'll look into why we are
bundling this file and what can be done to correct it.

------------------------------------------------------------------------

[2002-10-14 19:35:26] [email]iliaaphp.net[/email]

browscap.ini is NOT released by PHP, this file can be obtained from
various sources on the net none of which are related to the PHP
project. PHP merely has a generic ini pr that amongst other things
can p browscap.ini files. For whatever reason those files are not
always completely compatible or properly formatted. Thus they sometimes
cannot be pd completely by the PHP's pr. This means that the
incompatible lines should either be removed or altered.

------------------------------------------------------------------------

[2002-10-14 19:24:52] juri at ria dot com

Hello Iliaa

Why do you release a browscap.ini with invalid entries with every new
distribution of PHP?

Everybody using browscap.ini is forced to edit it, before he may use
it. bersom...

Kind regards
Juri

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
[url]http://bugs.php.net/19902[/url]

--
Edit this bug report at [url]http://bugs.php.net/?id=19902&edit=1[/url]