Professional Web Applications Themes

#20249 [Com]: Apache child segfaults when using OCILogon. - PHP Development

ID: 20249 Comment by: ratahamahata at php4 dot ru Reported By: bdabney at dallasnews dot com Status: No Feedback Bug Type: OCI8 related Operating System: Solaris 9 PHP Version: 4.2.3 New Comment: I've got the same bug with php-4.3.2-rc2 (gdb) bt #0 0x4071349a in snauca_check_adapter () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #1 0x40711dc1 in nau_viat () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #2 0x4070b101 in nau_gettab () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #3 0x40709801 in nau_ini () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #4 0x406ff37a in nainit () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #5 0x406ab745 in nsnainit () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #6 0x4069f672 in nsopen () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #7 0x406871b1 in nscall1 () from /opt/oracle/9.2/lib/libclntsh.so.9.0 #8 0x406865ce in ...

  1. #1

    Default #20249 [Com]: Apache child segfaults when using OCILogon.

    ID: 20249
    Comment by: ratahamahata at php4 dot ru
    Reported By: bdabney at dallasnews dot com
    Status: No Feedback
    Bug Type: OCI8 related
    Operating System: Solaris 9
    PHP Version: 4.2.3
    New Comment:

    I've got the same bug with php-4.3.2-rc2

    (gdb) bt
    #0 0x4071349a in snauca_check_adapter () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #1 0x40711dc1 in nau_viat () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #2 0x4070b101 in nau_gettab () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #3 0x40709801 in nau_ini () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #4 0x406ff37a in nainit () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #5 0x406ab745 in nsnainit () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #6 0x4069f672 in nsopen () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #7 0x406871b1 in nscall1 () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #8 0x406865ce in nscall () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #9 0x406bcc1c in niotns () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #10 0x4072a2e0 in nigcall () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #11 0x406c177a in osncon () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #12 0x404bd6fa in kpuadef () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #13 0x40577aa5 in upiini () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #14 0x40563fd9 in upiah0 () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #15 0x404bd2c5 in kpuatch () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0
    #16 0x4054ce43 in OCIServerAttach () from
    /opt/oracle/9.2/lib/libclntsh.so.9.0

    In my case this was due to ORACLE_HOME wasn't set.
    But I still doubt that php should segfault in such cases.
    Is it by intention?


    Previous Comments:
    ------------------------------------------------------------------------

    [2002-12-01 16:34:08] [email]sniperphp.net[/email]

    No feedback was provided. The bug is being suspended because
    we assume that you are no longer experiencing the problem.
    If this is not the case and you are able to provide the
    information that was requested earlier, please do so and
    change the status of the bug back to "Open". Thank you.



    ------------------------------------------------------------------------

    [2002-11-21 17:20:35] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-latest.zip[/url]



    ------------------------------------------------------------------------

    [2002-11-21 17:12:14] bdabney at dallasnews dot com

    This is still an issue.

    ------------------------------------------------------------------------

    [2002-11-21 17:10:20] [email]sniperphp.net[/email]

    No feedback was provided. The bug is being suspended because
    we assume that you are no longer experiencing the problem.
    If this is not the case and you are able to provide the
    information that was requested earlier, please do so and
    change the status of the bug back to "Open". Thank you.



    ------------------------------------------------------------------------

    [2002-11-07 19:12:07] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-latest.zip[/url]



    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/20249[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=20249&edit=1[/url]

    ratahamahata at php4 dot ru Guest

  2. #2

    Default #20249 [Com]: Apache child segfaults when using OCILogon.

    ID: 20249
    Comment by: gturner at newedgenetworks dot com
    Reported By: bdabney at dallasnews dot com
    Status: No Feedback
    Bug Type: OCI8 related
    Operating System: Solaris 9
    PHP Version: 4.2.3
    New Comment:

    I am having the same problem, including same backtrace, on Linux i386
    running Debian unstable.

    I grabbed the latest, php4-200308222130, and built with the following
    options:

    './configure' '--prefix=/usr' '--with-apxs=/usr/bin/apxs'
    '--with-config-file-path=/etc/php4/apache' '--enable-debug'
    '--with-layout=GNU' '--with-pear=/usr/share/php'
    '--with-pcre-regex=/usr' '--enable-sockets' '--with-expat-dir=/usr'
    '--with-zlib' '--with-kerberos=/usr' '--with-openssl=/usr'
    '--with-exec-dir=/usr/lib/php4/libexec' '--with-zlib-dir=/usr'
    '--with-oci8=/usr/local/oracle/9.2.0.3.0'


    Previous Comments:
    ------------------------------------------------------------------------

    [2002-12-01 16:34:08] [email]sniperphp.net[/email]

    No feedback was provided. The bug is being suspended because
    we assume that you are no longer experiencing the problem.
    If this is not the case and you are able to provide the
    information that was requested earlier, please do so and
    change the status of the bug back to "Open". Thank you.



    ------------------------------------------------------------------------

    [2002-11-21 17:20:35] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-latest.zip[/url]



    ------------------------------------------------------------------------

    [2002-11-21 17:12:14] bdabney at dallasnews dot com

    This is still an issue.

    ------------------------------------------------------------------------

    [2002-11-21 17:10:20] [email]sniperphp.net[/email]

    No feedback was provided. The bug is being suspended because
    we assume that you are no longer experiencing the problem.
    If this is not the case and you are able to provide the
    information that was requested earlier, please do so and
    change the status of the bug back to "Open". Thank you.



    ------------------------------------------------------------------------

    [2002-11-07 19:12:07] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-latest.zip[/url]



    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/20249[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=20249&edit=1[/url]

    gturner at newedgenetworks dot com Guest

Similar Threads

  1. #40232 [NEW]: Apache segfaults when using openssl_pkcs7_encrypt()
    By schotte at mayflower dot de in forum PHP Bugs
    Replies: 11
    Last Post: January 26th, 02:33 PM
  2. #37438 [Ana->Fbk]: PDO_MySQL segfaults Apache child
    By tony2001@php.net in forum PHP Bugs
    Replies: 0
    Last Post: September 23rd, 12:06 PM
  3. #37438 [Ana]: PDO_MySQL segfaults Apache child
    By john@php.net in forum PHP Bugs
    Replies: 0
    Last Post: September 22nd, 03:49 PM
  4. #37438 [Bgs->Ana]: PDO_MySQL segfaults Apache child
    By john@php.net in forum PHP Bugs
    Replies: 0
    Last Post: September 22nd, 03:49 PM
  5. #37438 [Bgs]: PDO_MySQL segfaults Apache child
    By john@php.net in forum PHP Bugs
    Replies: 0
    Last Post: September 22nd, 03:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139