ID: 21554
Comment by: webmaster at lacoccinelle dot net
Reported By: ljpersson at hotmail dot com
Status: No Feedback
Bug Type: GD related
Operating System: Linux
PHP Version: 4.3.0
New Comment:

Same thing for me :
PHP 4.3.3
GD 2.0.15
FreeType 2.1.5
Apache 1.3.28 (all compiled on the RedHat 7.3, no built-in)

Antialias works fine but the negative index for no anti-alias returns
ugly text.
Seems very strange, because the same application on a Debian box works
! Don't know what to do then.
I will try the non-bundled GD and let you know about it.


Previous Comments:
------------------------------------------------------------------------

[2003-02-20 07:39:24] ceeam at mail dot ru

Same thing happens in Windows version.

------------------------------------------------------------------------

[2003-01-27 22:39:46] [email]sniperphp.net[/email]

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.



------------------------------------------------------------------------

[2003-01-09 20:12:10] [email]iliaaphp.net[/email]

Try non-bundled gd 2.0.9 and see if you get the same results as the
ones
you've got with bundled GD library. I suspect that the behaviour of GD
between 2.0.1 and later versions had changed.

------------------------------------------------------------------------

[2003-01-09 14:50:30] ljpersson at hotmail dot com

Using imagettftext() it should be possible to turn off the antialiasing
by specifying a negative color index. However, this seems to be broken
in 4.3.0 with built-in GD.

Using negative color index just results in garbled characters.

PHP: 4.3.0
Freetype 1.3.1
GD 2.x (builtin version in PHP 4.3.0)

------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=21554&edit=1[/url]