ID: 22416
Updated by: [email]thetaphiphp.net[/email]
Reported By: jhalla at legion dot org
Status: Bogus
Bug Type: iPlanet related
Operating System: Solaris 8
PHP Version: 4.3.0
Assigned To: wez
New Comment:

Use the newest version of PHP (4.3.3 or greater). There this limit is
removed.
Your comment to 64bit is not acceptable for iPlanet users because
iPlanet is a 32 bit webserver which cannot run modules compiled in 64
bit.


Previous Comments:
------------------------------------------------------------------------

[2003-10-11 11:55:02] jmorris at sunflower dot com

While the 32-bit libc stdio is limited to 256, the 64-bit libc stdio is
not. Try compiling in 64-bit mode (gcc -m64). Test programs indicate
that the limit is removed in 64-bit programs, I have not yet built
apache and php in 64-bit mode.

[url]http://access1.sun.com/technotes/01406.html[/url]

------------------------------------------------------------------------

[2003-04-09 17:28:00] [email]wezphp.net[/email]

Let me reiterate the cause of the problem:
**Solaris libc stdio is broken**

This is not really a bug in PHP.

The only workaround for PHP < 5 is to link against an alternative stdio
library, such as the AT&T sfio,
although some people are reporting problems compiling that on their
Solaris systems.

PHP 5 will (and does) avoid stdio like the plague, so it does not fall
victim to this Solaris deficiency.

The changes required to make PHP 4.3.x do the same are too big to
introduce into the stable branch (they require some potentially
unstable changes to the Zend Engine).

This report is marked as bogus as it is a duplicate of another report
that we found more useful for bug-fixing purposes.


------------------------------------------------------------------------

[2003-04-09 16:51:51] [email]sniperphp.net[/email]

Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

,

------------------------------------------------------------------------

[2003-04-09 15:11:36] jhalla at legion dot org

<i>"No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you."</i>

Sniper, the bug isn't resolved... PHP 4.3x still does not run on
iPlanet/Solaris.

------------------------------------------------------------------------

[2003-04-09 15:09:58] fillmore at nrcan dot gcc dot a

We have been having these problems also.
I just installed php-4.3.2RC1.tar.gz to see if it helps,
and the site started failing again within a half hour.
I doubt that it's an open file limit in libc,
because the site had only 14 hits on .php URLs
before it started failing. Also, only two scripts were called, and
they don't open any files. Here's the code
in the most complicated of the two scripts:

<?
$x = 0;
while (list($key, $val) = each($ORFiles))
{
$x++;
echo '<font face="Arial, Helvetica, sans-serif">
<A HREF="../../html/tables/pdf/options/'.substr($val, 0, strpos($val,
"*")).'">'
..substr($val,strrpos($val,"*")+1).'</A></font>&nbsp;<img
SRC="../../gif/pdf.gif"
WIDTH="17" HEIGHT="17" ALT="pdf"><BR>';
}
?>

- Bob Fillmore

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
[url]http://bugs.php.net/22416[/url]

--
Edit this bug report at [url]http://bugs.php.net/?id=22416&edit=1[/url]