ID: 24282
User updated by: matzrek at shw-networks dot de
Reported By: matzrek at shw-networks dot de
Status: Open
Bug Type: Apache related
Operating System: Suse Linux 8.2 / Apache 1.3.27
PHP Version: 4.3.2
New Comment:

Sorry : the latest 4.3.3RC2(!) also seens to contain this bug!


Previous Comments:
------------------------------------------------------------------------

[2003-08-05 11:07:35] matzrek at shw-networks dot de

the latest RC3 also seens to contain this bug!

------------------------------------------------------------------------

[2003-08-04 04:44:49] fs at nessus dot at

I have the same problem with version 4.3.2 under redhat 7.2 and apache
1.3.27. but i could recognize that the last request on the webserver
what a request in the path /webs/web70, the path where the error
occours...

Warning: Unknown(): open_basedir restriction in effect.
File(/webs/web20/html/produkte/index.php) is not within the allowed
path(s): (/webs/web70/) in Unknown on line 0

Warning: Unknown(/webs/web20/html/produkte/index.php): failed to open
stream: Operation not permitted in Unknown on line 0

Warning: (null)(): Failed opening '/webs/web20/html/produkte/index.php'
for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line
0

my php.ini:

[PHP]

safe_mode = Off
safe_mode_gid = True
register_globals = On
expose_php = Off
magic_quotes_gpc = On
enable_dl = On
max_execution_time = 60
post_max_size = 15M
upload_max_size = 15M

and the vhost where the error occurs:

NameVirtualHost 80.252.42.2:80
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /webs/empty

<VirtualHost 80.252.42.2:80>
ServerName www.server.at
ServerAlias server1.at server2.at
DoentRoot /webs/web20/html
User web20
Group somegroup
ScriptAlias /cgi-bin/ /webs/web20/html/cgi-bin/
php_admin_value open_basedir /webs/web20/
php_admin_value upload_tmp_dir /webs/web20/phptmp/
</VirtualHost>

i hope i could help you to find this bug.

greetings,

Florian Schicker
www.nessus.at

------------------------------------------------------------------------

[2003-08-02 18:27:26] matzrek at shw-networks dot de

Setting an empty open Basedir doesnt help. The only Solution at the
moment is to activate teh safemode for the vhost.

------------------------------------------------------------------------

[2003-07-24 20:59:15] iliaaphp.net

If you set an empty open_basedir for virtual host 'a', does the problem
go away?

------------------------------------------------------------------------

[2003-06-24 13:01:21] matzrek at shw-networks dot de

the error happend at two different configurations :

a)
<VirtualHost 213.203.204.143>
ServerAdmin webmastershw-network.de
ServerName www.shw-network.de
ServerAlias shw-network.de
ServerAlias www.shw-networks.de
ServerAlias shw-networks.de
DoentRoot /home/shw-network.de/htdocs
ErrorLog /home/shw-network.de/log/error_log.log
CustomLog /home/shw-network.de/log/access_log.log combined
CustomLog /var/log/httpd/access_log.log combined
</VirtualHost>

an b )

<VirtualHost 213.203.204.143>
ServerAdmin webmastershw-komplett.de
DoentRoot /home/cusomerdomain.de/htdocs/admin
ServerName admin.cusomerdomain.de
ServerAlias www.cusomerdomain.de
ServerAlias cusomerdomain.de
ErrorLog /home/cusomerdomain.de/log/error_log.log
CustomLog /home/cusomerdomain.de/log/access_log.log combined
CustomLog /var/log/httpd/access_log.log combined
php_admin_flag safe_mode off
php_admin_value open_base_dir "/home/cusomerdomain.de"
php_admin_value safe_mode_exec_dir /bin
</VirtualHost>

if the error happens or not seems to depend on the apache process wich
handles the request.

The Apache uptime may also have some effect - it did not happen,
directly after an apache restart.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/24282

--
Edit this bug report at http://bugs.php.net/?id=24282&edit=1