ID: 24614
User updated by: deptotecnico at towebs dot com
Reported By: deptotecnico at towebs dot com
-Status: Bogus
+Status: Closed
Bug Type: CGI related
Operating System: Linux
PHP Version: 4.3.3RC1
New Comment:

sigh. what really fixed the problem was adding --enable-discard-path.


Previous Comments:
------------------------------------------------------------------------

[2003-07-12 08:17:55] [email]sniperphp.net[/email]

...

------------------------------------------------------------------------

[2003-07-12 03:22:05] deptotecnico at towebs dot com

after further investigation and debugging, setting doc_root in php.ini
fixed the issue. my apologies.

------------------------------------------------------------------------

[2003-07-12 00:44:39] deptotecnico at towebs dot com

of course, this should be read as:

.. looking around and I've seen several old reports for and a few new
ones, but no fixed whatsoever.

------------------------------------------------------------------------

[2003-07-11 19:10:01] deptotecnico at towebs dot com

Description:
------------

If I compile php as cgi (--enable-force-cgi-redirect is not used), I
always get 'No input file specified' while browsing any .php file.
I've tried with 4.3.1, 4.3.2 and 4.3.3RC1, with php.ini-recommended
as the init file.
php -v gives:

PHP 4.3.3RC1 (cgi) (built: Jul 11 2003 20:52:32)
Copyright (c) 1997-2003 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies

running the same code from console (path/to/php/cgi file.php) works
fine.
I've been looking around and I've seen several old reports for this
and a few ones, but no fixed whatsoever.
I've also checked the CVS repository, but doesn't seem like anything
has changed wrt in cgi_main.c.




Reproduce code:
---------------
<?
phpinfo ();
?>

Expected result:
----------------
phpinfo() output.

Actual result:
--------------
No input file specified.


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=24614&edit=1[/url]