Professional Web Applications Themes

#24614 [Csd->Bgs]: php as cgi always report 'No input file specified.' - PHP Development

ID: 24614 Updated by: [email]sniperphp.net[/email] Reported By: deptotecnico at towebs dot com -Status: Closed +Status: Bogus Bug Type: CGI related Operating System: Linux PHP Version: 4.3.3RC1 New Comment: ... Previous Comments: ------------------------------------------------------------------------ [2003-07-12 03:22:05] deptotecnico at towebs dot com after further investigation and debugging, setting doc_root in php.ini fixed the issue. my apologies. ------------------------------------------------------------------------ [2003-07-12 00:44:39] deptotecnico at towebs dot com of course, this should be read as: .. looking around and I've seen several old reports for and a few new ones, but no fixed whatsoever. ------------------------------------------------------------------------ [2003-07-11 19:10:01] deptotecnico at towebs dot com Description: ------------ If I compile ...

  1. #1

    Default #24614 [Csd->Bgs]: php as cgi always report 'No input file specified.'

    ID: 24614
    Updated by: [email]sniperphp.net[/email]
    Reported By: deptotecnico at towebs dot com
    -Status: Closed
    +Status: Bogus
    Bug Type: CGI related
    Operating System: Linux
    PHP Version: 4.3.3RC1
    New Comment:

    ...


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-07-12 03:22:05] deptotecnico at towebs dot com

    after further investigation and debugging, setting doc_root in php.ini
    fixed the issue. my apologies.

    ------------------------------------------------------------------------

    [2003-07-12 00:44:39] deptotecnico at towebs dot com

    of course, this should be read as:

    .. looking around and I've seen several old reports for and a few new
    ones, but no fixed whatsoever.

    ------------------------------------------------------------------------

    [2003-07-11 19:10:01] deptotecnico at towebs dot com

    Description:
    ------------

    If I compile php as cgi (--enable-force-cgi-redirect is not used), I
    always get 'No input file specified' while browsing any .php file.
    I've tried with 4.3.1, 4.3.2 and 4.3.3RC1, with php.ini-recommended
    as the init file.
    php -v gives:

    PHP 4.3.3RC1 (cgi) (built: Jul 11 2003 20:52:32)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies

    running the same code from console (path/to/php/cgi file.php) works
    fine.
    I've been looking around and I've seen several old reports for this
    and a few ones, but no fixed whatsoever.
    I've also checked the CVS repository, but doesn't seem like anything
    has changed wrt in cgi_main.c.




    Reproduce code:
    ---------------
    <?
    phpinfo ();
    ?>

    Expected result:
    ----------------
    phpinfo() output.

    Actual result:
    --------------
    No input file specified.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=24614&edit=1[/url]

    sniper@php.net Guest

  2. #2

    Default #24614 [Csd->Bgs]: php as cgi always report 'No input file specified.'

    ID: 24614
    Updated by: [email]sniperphp.net[/email]
    Reported By: deptotecnico at towebs dot com
    -Status: Closed
    +Status: Bogus
    Bug Type: CGI related
    Operating System: Linux
    PHP Version: 4.3.3RC1
    New Comment:

    Whatever, it's still user error. Please don't touch this anymore.



    Previous Comments:
    ------------------------------------------------------------------------

    [2003-07-12 11:34:10] deptotecnico at towebs dot com

    sigh. what really fixed the problem was adding --enable-discard-path.

    ------------------------------------------------------------------------

    [2003-07-12 08:17:55] [email]sniperphp.net[/email]

    ...

    ------------------------------------------------------------------------

    [2003-07-12 03:22:05] deptotecnico at towebs dot com

    after further investigation and debugging, setting doc_root in php.ini
    fixed the issue. my apologies.

    ------------------------------------------------------------------------

    [2003-07-12 00:44:39] deptotecnico at towebs dot com

    of course, this should be read as:

    .. looking around and I've seen several old reports for and a few new
    ones, but no fixed whatsoever.

    ------------------------------------------------------------------------

    [2003-07-11 19:10:01] deptotecnico at towebs dot com

    Description:
    ------------

    If I compile php as cgi (--enable-force-cgi-redirect is not used), I
    always get 'No input file specified' while browsing any .php file.
    I've tried with 4.3.1, 4.3.2 and 4.3.3RC1, with php.ini-recommended
    as the init file.
    php -v gives:

    PHP 4.3.3RC1 (cgi) (built: Jul 11 2003 20:52:32)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies

    running the same code from console (path/to/php/cgi file.php) works
    fine.
    I've been looking around and I've seen several old reports for this
    and a few ones, but no fixed whatsoever.
    I've also checked the CVS repository, but doesn't seem like anything
    has changed wrt in cgi_main.c.




    Reproduce code:
    ---------------
    <?
    phpinfo ();
    ?>

    Expected result:
    ----------------
    phpinfo() output.

    Actual result:
    --------------
    No input file specified.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=24614&edit=1[/url]

    sniper@php.net Guest

Similar Threads

  1. Replies: 2
    Last Post: October 16th, 08:29 AM
  2. #24614 [Bgs->Csd]: php as cgi always report 'No input file specified.'
    By deptotecnico at towebs dot com in forum PHP Development
    Replies: 0
    Last Post: July 12th, 04:34 PM
  3. #24614 [Opn->Csd]: php as cgi always report 'No input file specified.'
    By deptotecnico at towebs dot com in forum PHP Development
    Replies: 0
    Last Post: July 12th, 08:24 AM
  4. #24614 [Opn]: php as cgi always report 'No input file specified.'
    By deptotecnico at towebs dot com in forum PHP Development
    Replies: 0
    Last Post: July 12th, 05:45 AM
  5. #24614 [NEW]: php as cgi always report 'No input file specified.'
    By deptotecnico at towebs dot com in forum PHP Development
    Replies: 0
    Last Post: July 12th, 12:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139