ID: 24866
Updated by: [email]moriyoshiphp.net[/email]
Reported By: herouth at itouch dot co dot il
Status: Feedback
Bug Type: Reproducible crash
Operating System: Linux
PHP Version: 4.3.2
New Comment:

Is there any application other than PHP that crashes if LANG is set to
en_US? That doesn't look like a PHP bug and
probably a glibc bug.

If it really segfaults in main_arena() even outside gdb, one of
possible reasons is silent buffer overrun in the heap. Memory block
corruption often causes this kind of problem.



Previous Comments:
------------------------------------------------------------------------

[2003-08-05 11:14:10] [email]sniperphp.net[/email]

I can not reproduce this. I used this configure line:

'./configure' \
'--disable-all' \
'--disable-cgi' \
'--enable-debug' \
'--with-sybase-ct=/opt/sybase-11.9.2/'

Try the same, using latest stable CVS snapshot.


------------------------------------------------------------------------

[2003-08-04 10:13:08] herouth at itouch dot co dot il

No. Compiling with sybase and without imap has no effect. It still
crashes with LANG=en_US, and works with LANG=C.

------------------------------------------------------------------------

[2003-08-04 09:58:22] [email]sniperphp.net[/email]

And I guess it works also when you compile PHP with sybase, but without
imap?


------------------------------------------------------------------------

[2003-08-03 04:11:30] herouth at itouch dot co dot il

I think I pinpointed it.
I tried your configure/compile sequence and it eliminated the
problem.
I went on and re-compiled using my original configure line,
except the sybase-ct line. No problem.
I added the --with-sybase-ct line, and the crash reappeared.
As for my Linux, it's an old RedHat, kernel 2.2.16-3smp. glibc is,
I think, 2.1.3.

------------------------------------------------------------------------

[2003-07-31 13:39:44] [email]sniperphp.net[/email]

Does it crash with this:

# rm config.cache && ./configure --disable-all --disable-cgi
--enable-debug
# make clean && make
# unset LC_ALL
# export LANG=en_US
# sapi/cli/php -n -v

Don't set any CFLAGS/other compile related settings, PHP configure
knows better..
Which linux is this? glibc version?




------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
[url]http://bugs.php.net/24866[/url]

--
Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]