Professional Web Applications Themes

#24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values - PHP Development

ID: 24866 Updated by: [email]iliaaphp.net[/email] Reported By: herouth at itouch dot co dot il -Status: Open +Status: Feedback Bug Type: Reproducible crash Operating System: Linux PHP Version: 4.3.2 New Comment: Can you please generate a backtrace. I've tried your example and was unable to te the bug. Previous Comments: ------------------------------------------------------------------------ [2003-07-30 02:44:38] herouth at itouch dot co dot il Additional information - config parameters used when compiling this CLI PHP: './configure' \ '--prefix=/opt/php' \ '--with-sybase-ct=/opt/sybase-11.9.2/' \ '--with-imap' \ '--without-pear' \ '--without-mysql' \ '--enable-ftp' \ '--with-curl=/usr/local' \ '--with-dom=/usr/local' \ '--with-zlib-dir=/usr' \ '--with-iconv' \ '--enable-sockets' \ '--disable-cgi' \ "$" ------------------------------------------------------------------------ [2003-07-30 02:40:37] ...

  1. #1

    Default #24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values

    ID: 24866
    Updated by: [email]iliaaphp.net[/email]
    Reported By: herouth at itouch dot co dot il
    -Status: Open
    +Status: Feedback
    Bug Type: Reproducible crash
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    Can you please generate a backtrace. I've tried your example and was
    unable to te the bug.


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-07-30 02:44:38] herouth at itouch dot co dot il

    Additional information - config parameters used when compiling
    this CLI PHP:

    './configure' \
    '--prefix=/opt/php' \
    '--with-sybase-ct=/opt/sybase-11.9.2/' \
    '--with-imap' \
    '--without-pear' \
    '--without-mysql' \
    '--enable-ftp' \
    '--with-curl=/usr/local' \
    '--with-dom=/usr/local' \
    '--with-zlib-dir=/usr' \
    '--with-iconv' \
    '--enable-sockets' \
    '--disable-cgi' \
    "$"

    ------------------------------------------------------------------------

    [2003-07-30 02:40:37] herouth at itouch dot co dot il

    Tested with CVS snapshot. Same result.

    ------------------------------------------------------------------------

    [2003-07-30 01:58:07] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]

    ------------------------------------------------------------------------

    [2003-07-30 01:56:17] herouth at itouch dot co dot il

    Description:
    ------------
    PHP CLI crashes (segfault) when locale environment variables.
    For example:
    $ unset LC_ALL
    $ export LANG=en_US
    $ php -v
    Segmentation fault (core dumped)
    $ LANG=C
    $ php -v
    PHP 4.3.2 (cli) (built: Jul 6 2003 17:00:52)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    $



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]

    iliaa@php.net Guest

  2. #2

    Default #24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values

    ID: 24866
    Updated by: [email]iliaaphp.net[/email]
    Reported By: herouth at itouch dot co dot il
    -Status: Open
    +Status: Feedback
    Bug Type: Reproducible crash
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    To get the most debug information do the following:
    1) Compile php with --enable-debug
    2) export CFLAGS=-g3 (optional, but recommended)


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-07-31 04:42:14] herouth at itouch dot co dot il

    I'm not sure whether I'm using the right procedure to do a
    backtrace. Basically, I reconfigured php with CFLAGS=-O0 -g, did
    a make, then ran again, then ran gdb php core, and within gdb,
    did "backtrace". This is all I've got, and if I did it wrong, well,
    correct me.

    (gdb) backtrace
    #0 0x40445d88 in main_arena () from /lib/libc.so.6
    #1 0xb1914044 in ?? ()
    Cannot access memory at address 0x6840445d
    (gdb)

    ------------------------------------------------------------------------

    [2003-07-30 12:36:21] [email]iliaaphp.net[/email]

    Can you please generate a backtrace. I've tried your example and was
    unable to te the bug.

    ------------------------------------------------------------------------

    [2003-07-30 02:44:38] herouth at itouch dot co dot il

    Additional information - config parameters used when compiling
    this CLI PHP:

    './configure' \
    '--prefix=/opt/php' \
    '--with-sybase-ct=/opt/sybase-11.9.2/' \
    '--with-imap' \
    '--without-pear' \
    '--without-mysql' \
    '--enable-ftp' \
    '--with-curl=/usr/local' \
    '--with-dom=/usr/local' \
    '--with-zlib-dir=/usr' \
    '--with-iconv' \
    '--enable-sockets' \
    '--disable-cgi' \
    "$"

    ------------------------------------------------------------------------

    [2003-07-30 02:40:37] herouth at itouch dot co dot il

    Tested with CVS snapshot. Same result.

    ------------------------------------------------------------------------

    [2003-07-30 01:58:07] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/24866[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]

    iliaa@php.net Guest

  3. #3

    Default #24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values

    ID: 24866
    Updated by: [email]sniperphp.net[/email]
    Reported By: herouth at itouch dot co dot il
    -Status: Open
    +Status: Feedback
    Bug Type: Reproducible crash
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    Does it crash with this:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --enable-debug
    # make clean && make
    # unset LC_ALL
    # export LANG=en_US
    # sapi/cli/php -n -v

    Don't set any CFLAGS/other compile related settings, PHP configure
    knows better..
    Which linux is this? glibc version?





    Previous Comments:
    ------------------------------------------------------------------------

    [2003-07-31 07:58:42] herouth at itouch dot co dot il

    Tried --enable-debug and -g3, same result in gdb.
    Note that crash doesn't happen if running php within gdb.

    ------------------------------------------------------------------------

    [2003-07-31 07:21:39] [email]iliaaphp.net[/email]

    To get the most debug information do the following:
    1) Compile php with --enable-debug
    2) export CFLAGS=-g3 (optional, but recommended)

    ------------------------------------------------------------------------

    [2003-07-31 04:42:14] herouth at itouch dot co dot il

    I'm not sure whether I'm using the right procedure to do a
    backtrace. Basically, I reconfigured php with CFLAGS=-O0 -g, did
    a make, then ran again, then ran gdb php core, and within gdb,
    did "backtrace". This is all I've got, and if I did it wrong, well,
    correct me.

    (gdb) backtrace
    #0 0x40445d88 in main_arena () from /lib/libc.so.6
    #1 0xb1914044 in ?? ()
    Cannot access memory at address 0x6840445d
    (gdb)

    ------------------------------------------------------------------------

    [2003-07-30 12:36:21] [email]iliaaphp.net[/email]

    Can you please generate a backtrace. I've tried your example and was
    unable to te the bug.

    ------------------------------------------------------------------------

    [2003-07-30 02:44:38] herouth at itouch dot co dot il

    Additional information - config parameters used when compiling
    this CLI PHP:

    './configure' \
    '--prefix=/opt/php' \
    '--with-sybase-ct=/opt/sybase-11.9.2/' \
    '--with-imap' \
    '--without-pear' \
    '--without-mysql' \
    '--enable-ftp' \
    '--with-curl=/usr/local' \
    '--with-dom=/usr/local' \
    '--with-zlib-dir=/usr' \
    '--with-iconv' \
    '--enable-sockets' \
    '--disable-cgi' \
    "$"

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/24866[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]

    sniper@php.net Guest

  4. #4

    Default #24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values

    ID: 24866
    Updated by: [email]sniperphp.net[/email]
    Reported By: herouth at itouch dot co dot il
    -Status: Open
    +Status: Feedback
    Bug Type: Reproducible crash
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    And I guess it works also when you compile PHP with sybase, but without
    imap?



    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-03 04:11:30] herouth at itouch dot co dot il

    I think I pinpointed it.
    I tried your configure/compile sequence and it eliminated the
    problem.
    I went on and re-compiled using my original configure line,
    except the sybase-ct line. No problem.
    I added the --with-sybase-ct line, and the crash reappeared.
    As for my Linux, it's an old RedHat, kernel 2.2.16-3smp. glibc is,
    I think, 2.1.3.

    ------------------------------------------------------------------------

    [2003-07-31 13:39:44] [email]sniperphp.net[/email]

    Does it crash with this:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --enable-debug
    # make clean && make
    # unset LC_ALL
    # export LANG=en_US
    # sapi/cli/php -n -v

    Don't set any CFLAGS/other compile related settings, PHP configure
    knows better..
    Which linux is this? glibc version?




    ------------------------------------------------------------------------

    [2003-07-31 07:58:42] herouth at itouch dot co dot il

    Tried --enable-debug and -g3, same result in gdb.
    Note that crash doesn't happen if running php within gdb.

    ------------------------------------------------------------------------

    [2003-07-31 07:21:39] [email]iliaaphp.net[/email]

    To get the most debug information do the following:
    1) Compile php with --enable-debug
    2) export CFLAGS=-g3 (optional, but recommended)

    ------------------------------------------------------------------------

    [2003-07-31 04:42:14] herouth at itouch dot co dot il

    I'm not sure whether I'm using the right procedure to do a
    backtrace. Basically, I reconfigured php with CFLAGS=-O0 -g, did
    a make, then ran again, then ran gdb php core, and within gdb,
    did "backtrace". This is all I've got, and if I did it wrong, well,
    correct me.

    (gdb) backtrace
    #0 0x40445d88 in main_arena () from /lib/libc.so.6
    #1 0xb1914044 in ?? ()
    Cannot access memory at address 0x6840445d
    (gdb)

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/24866[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]

    sniper@php.net Guest

  5. #5

    Default #24866 [Opn->Fbk]: PHP CLI crashes when locale has certain values

    ID: 24866
    Updated by: [email]sniperphp.net[/email]
    Reported By: herouth at itouch dot co dot il
    -Status: Open
    +Status: Feedback
    Bug Type: Reproducible crash
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    I can not reproduce this. I used this configure line:

    './configure' \
    '--disable-all' \
    '--disable-cgi' \
    '--enable-debug' \
    '--with-sybase-ct=/opt/sybase-11.9.2/'

    Try the same, using latest stable CVS snapshot.



    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-04 10:13:08] herouth at itouch dot co dot il

    No. Compiling with sybase and without imap has no effect. It still
    crashes with LANG=en_US, and works with LANG=C.

    ------------------------------------------------------------------------

    [2003-08-04 09:58:22] [email]sniperphp.net[/email]

    And I guess it works also when you compile PHP with sybase, but without
    imap?


    ------------------------------------------------------------------------

    [2003-08-03 04:11:30] herouth at itouch dot co dot il

    I think I pinpointed it.
    I tried your configure/compile sequence and it eliminated the
    problem.
    I went on and re-compiled using my original configure line,
    except the sybase-ct line. No problem.
    I added the --with-sybase-ct line, and the crash reappeared.
    As for my Linux, it's an old RedHat, kernel 2.2.16-3smp. glibc is,
    I think, 2.1.3.

    ------------------------------------------------------------------------

    [2003-07-31 13:39:44] [email]sniperphp.net[/email]

    Does it crash with this:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --enable-debug
    # make clean && make
    # unset LC_ALL
    # export LANG=en_US
    # sapi/cli/php -n -v

    Don't set any CFLAGS/other compile related settings, PHP configure
    knows better..
    Which linux is this? glibc version?




    ------------------------------------------------------------------------

    [2003-07-31 07:58:42] herouth at itouch dot co dot il

    Tried --enable-debug and -g3, same result in gdb.
    Note that crash doesn't happen if running php within gdb.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/24866[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=24866&edit=1[/url]

    sniper@php.net Guest

Similar Threads

  1. LoadFile method: VBA crashes. Well, any othermethod crashes as well.
    By GSerg@adobeforums.com in forum Adobe Acrobat SDK
    Replies: 7
    Last Post: July 20th, 03:45 PM
  2. #24866 [Fbk->Bgs]: PHP CLI crashes when locale has certain values
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: August 5th, 11:30 PM
  3. #24866 [Fbk]: PHP CLI crashes when locale has certain values
    By moriyoshi@php.net in forum PHP Development
    Replies: 0
    Last Post: August 5th, 04:44 PM
  4. #24866 [Fbk->Opn]: PHP CLI crashes when locale has certain values
    By herouth at itouch dot co dot il in forum PHP Development
    Replies: 2
    Last Post: July 31st, 12:58 PM
  5. #24866 [Opn]: PHP CLI crashes when locale has certain values
    By herouth at itouch dot co dot il in forum PHP Development
    Replies: 0
    Last Post: July 30th, 07:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139