ID: 24867
Updated by: [email]sniperphp.net[/email]
Reported By: tomato at pisem dot net
-Status: Feedback
+Status: No Feedback
Bug Type: Sockets related
Operating System: FreeBSD-4.7-Stable
PHP Version: 4.3.2
New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.




Previous Comments:
------------------------------------------------------------------------

[2003-07-30 11:44:26] [email]sniperphp.net[/email]

Please try using this CVS snapshot:

[url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

For Windows:

[url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]

------------------------------------------------------------------------

[2003-07-30 06:06:07] tomato at pisem dot net

Description:
------------
I'm trying to do socket connection with group of servers and for the
server's that did not work function fsockopen() runs around 300-500 sec
even the timeout is 10 sec.
i heard the problem was that this timeout used only in connect
function, but not in gethostbyname
i read that you fixed this problem long time ago.. but my version is
PHP 4.3.2RC4 (cli) (built: Jun 19 2003 14:41:09)
and the problem is still exists





Reproduce code:
---------------
$fp = fsockopen($href,$port,$errno,$errstr,10);


Expected result:
----------------
connect or failed to connect after 10 seconds or less

Actual result:
--------------
Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: No
address associated with hostname in /.../script.php


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=24867&edit=1[/url]