From: peter at guts dot nl
Operating system: FreeBSD
PHP version: 4.3.2
PHP Bug Type: Compile Failure
Bug description: pfpro module requires -pthread on FreeBSD

Description:
------------
running configure --with-pfpro on FreeBSD reports 'need SDK 2 or 3'. The
SDK I downloaded was version 3. config.log showed linking errors regarding
pthread.

CFLAGS=pthread ./configure .... worked.

Reproduce code:
---------------
run ./configure --with-pfpro=/path/to/lib on FreeBSD

Expected result:
----------------
configure running without errors

Actual result:
--------------
configure reporting that SDK 2 or 3 is required.

--
Edit bug report at [url]http://bugs.php.net/?id=24983&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=24983&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=24983&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=24983&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=24983&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=24983&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=24983&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=24983&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=24983&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=24983&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=24983&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=24983&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=24983&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=24983&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=24983&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=24983&r=gnused[/url]