ID: 25098
Updated by: [email]derickphp.net[/email]
Reported By: jon at picresource dot com
-Status: Open
+Status: Feedback
-Bug Type: Output Control
+Bug Type: Session related
Operating System: Linux
PHP Version: 4.3.2
New Comment:

Ask them to put this in php.ini:
session.use_trans_sid = 0

or put this in a .htaccess (if that is allowed) and see if the problem
goes away. If it's not, you really need to urge them to upgrade to
4.3.2 (or 4.3.3 when it's out).

regards,
Derick


Previous Comments:
------------------------------------------------------------------------

[2003-08-15 10:18:38] jon at picresource dot com

Description:
------------
A few weeks ago my ISP upgraded the version of PHP on my hosted system
without my knowledge or consent. (New version 4.2.3) They informed me
of the change after the upgrade was complete.

Since this upgrade I have been experiancing a problem that I can only
describe as "web sites being rendered improperly".

I believe the problem is related to sessions or cookies. My site uses
a cookie to track the user's session, (ie, no phpmysessionid in URL) I
also store a user's ID in the cookie that I use to gather data that is
then stored in their session.

If an anonymous user (ie, no local cookie) surfs to the site the
problem does not show, if a regular user (ie. cookie saved in the past)
surfs to the site the problem occurs. If that user reloads the page
the problem is gone, if the user reloads after the session has expired
the problem occurs again (sometimes sooner).

The problem shows up as web page contents being placed on the page in
incorrect locations. Usually a block of text will be dropped at the
top of the page, also blocks of text (and html tags) will be moved from
one location to another. You can imagine how this causes problems on
my site. I have also noted that when the problem occures PHP is
inserting "phpmysessionid" into URLs within the page.

Nothing has changed but the version of PHP.

My ISP does not have a clue as to what is going on and is basicly
ignorning my attempts to get help. I have attempted to search for
bugs on this site but as I have a tough time describing the problem I
also have a tough time searching for it.

Any help?



------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25098&edit=1[/url]