Professional Web Applications Themes

#25172 [Fbk->Opn]: register_globals=on and $HTTP_HOST sometimes empty - PHP Development

ID: 25172 User updated by: php at lansco dot de -Reported By: php at lnetz dot de +Reported By: php at lansco dot de -Status: Feedback +Status: Open Bug Type: *General Issues Operating System: Linux PHP Version: 4.3.2 New Comment: With [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url] the error also occurs :( Previous Comments: ------------------------------------------------------------------------ [2003-08-20 17:31:39] [email]sniperphp.net[/email] Please try using this CVS snapshot: [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url] For Windows: [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url] ------------------------------------------------------------------------ [2003-08-20 05:03:43] php at lansco dot de Description: ------------ Sometimes $HTTP_HOST is empty while $_SERVER["HTTP_HOST"] contains the expected value. After a reload $HTTP_HOST mostly contains the expected value. This error also occurs with PHP-4.3.2 Reproduce code: ...

  1. #1

    Default #25172 [Fbk->Opn]: register_globals=on and $HTTP_HOST sometimes empty

    ID: 25172
    User updated by: php at lansco dot de
    -Reported By: php at lnetz dot de
    +Reported By: php at lansco dot de
    -Status: Feedback
    +Status: Open
    Bug Type: *General Issues
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    With [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url] the error also
    occurs :(


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-20 17:31:39] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]



    ------------------------------------------------------------------------

    [2003-08-20 05:03:43] php at lansco dot de

    Description:
    ------------
    Sometimes $HTTP_HOST is empty while $_SERVER["HTTP_HOST"] contains the
    expected value.

    After a reload $HTTP_HOST mostly contains the expected value.

    This error also occurs with PHP-4.3.2


    Reproduce code:
    ---------------
    print "1: ".$HTTP_HOST."\n";
    print "2: ".$_SERVER["HTTP_HOST"]."\n";


    Expected result:
    ----------------
    1: test.com
    2: test.com

    Actual result:
    --------------
    1:
    2: test.com


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=25172&edit=1[/url]

    php at lansco dot de Guest

  2. #2

    Default #25172 [Fbk->Opn]: register_globals=on and $HTTP_HOST sometimes empty

    ID: 25172
    User updated by: php at lansco dot de
    Reported By: php at lansco dot de
    -Status: Feedback
    +Status: Open
    Bug Type: *General Issues
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    variables_order = EGPCS
    gpc_order = GPC
    Apache Version = Apache/2.0.47 (Unix) mod_ssl/2.0.47 OpenSSL/0.9.6c
    DAV/2 PHP/4.3.3RC5-dev


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-21 08:18:11] [email]sniperphp.net[/email]

    What are your variables_order and gpc_order settings?
    (from phpinfo() output)
    Which webserver? Apache? What version?


    ------------------------------------------------------------------------

    [2003-08-21 03:21:41] php at lansco dot de

    With [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url] the error also
    occurs :(

    ------------------------------------------------------------------------

    [2003-08-20 17:31:39] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]



    ------------------------------------------------------------------------

    [2003-08-20 05:03:43] php at lansco dot de

    Description:
    ------------
    Sometimes $HTTP_HOST is empty while $_SERVER["HTTP_HOST"] contains the
    expected value.

    After a reload $HTTP_HOST mostly contains the expected value.

    This error also occurs with PHP-4.3.2


    Reproduce code:
    ---------------
    print "1: ".$HTTP_HOST."\n";
    print "2: ".$_SERVER["HTTP_HOST"]."\n";


    Expected result:
    ----------------
    1: test.com
    2: test.com

    Actual result:
    --------------
    1:
    2: test.com


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=25172&edit=1[/url]

    php at lansco dot de Guest

  3. #3

    Default #25172 [Fbk->Opn]: register_globals=on and $HTTP_HOST sometimes empty

    ID: 25172
    User updated by: php at lansco dot de
    Reported By: php at lansco dot de
    -Status: Feedback
    +Status: Open
    Bug Type: *General Issues
    Operating System: Linux
    PHP Version: 4.3.2
    New Comment:

    Apache-configure:
    "./configure" \
    "--prefix=/usr/local/apache2" \
    "--with-mpm=prefork" \
    "--enable-modules=deflate expires include info rewrite ssl unique_id
    usertrack log_config logio rewrite vhost_alias so ext_filter dav
    headers speling"

    PHP-configure:
    './configure' '--with-mysql=/usr/local/mysql' '--enable-ftp'
    '--with-gd' '--with-gd-dir=/usr/local' '--with-jpeg'
    '--with-jpeg-dir=/usr/local' '--with-apxs2=/usr/local/apache2/bin/apxs'
    '--with-gettext' '--with-mcrypt' '--with-imap' '--with-imap-ssl'
    '--with-ldap' '--with-zlib-dir=/usr/include' '--enable-xslt'
    '--with-xslt-sablot' '--enable-exif'


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-21 08:29:30] [email]sniperphp.net[/email]

    What was the configure line used to configure Apache?
    (And PHP too)


    ------------------------------------------------------------------------

    [2003-08-21 08:25:51] php at lansco dot de

    variables_order = EGPCS
    gpc_order = GPC
    Apache Version = Apache/2.0.47 (Unix) mod_ssl/2.0.47 OpenSSL/0.9.6c
    DAV/2 PHP/4.3.3RC5-dev

    ------------------------------------------------------------------------

    [2003-08-21 08:18:11] [email]sniperphp.net[/email]

    What are your variables_order and gpc_order settings?
    (from phpinfo() output)
    Which webserver? Apache? What version?


    ------------------------------------------------------------------------

    [2003-08-21 03:21:41] php at lansco dot de

    With [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url] the error also
    occurs :(

    ------------------------------------------------------------------------

    [2003-08-20 17:31:39] [email]sniperphp.net[/email]

    Please try using this CVS snapshot:

    [url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

    For Windows:

    [url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]



    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/25172[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=25172&edit=1[/url]

    php at lansco dot de Guest

  4. Moderated Post

    Default #25172 [Fbk->Opn]: register_globals=on and $HTTP_HOST sometimes empty

    Removed by Administrator
    php at lansco dot de Guest
    Moderated Post

Similar Threads

  1. #25172 [Bgs]: register_globals=on and $HTTP_HOST sometimes empty
    By sniper@php.net in forum PHP Development
    Replies: 2
    Last Post: January 28th, 07:29 PM
  2. #25171 [Com]: $HTTP_HOST and $SERVER["HTTP_HOST"] not always the same
    By bvdb at asa dot de in forum PHP Development
    Replies: 0
    Last Post: November 2nd, 12:53 PM
  3. Replies: 0
    Last Post: October 4th, 04:52 AM
  4. Replies: 5
    Last Post: August 26th, 03:23 AM
  5. #25172 [NEW]: register_globals=on and $HTTP_HOST sometimes empty
    By php at lnetz dot de in forum PHP Development
    Replies: 0
    Last Post: August 20th, 10:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139