From: [email]daveyphp.net[/email]
Operating system: WinXP Pro SP1
PHP version: 5CVS-2003-08-20 (dev)
PHP Bug Type: Reproducible crash
Bug description: CLI Crashes with entry point not found in php4ts.dll

Description:
------------
Running the CLI (with or without flags or input) always brings up the
error:

The procedure entry point _zend_hash_init could not be located in the
dynamic link library php4ts.dll.

- Davey

Reproduce code:
---------------
C:\web\test>c:\php5\cli\php.exe -v [enter]
[error]
C:\web\test>

Expected result:
----------------
C:\web\test>c:\php5\cli\php.exe -v [enter]
PHP 5.0.0b2-dev (cli) (built: Aug 20 2003 12:10:03)
Copyright (c) 1997-2003 The PHP Group
Zend Engine v2.0.0-dev, Copyright (c) 1998-2003 Zend Technologies

C:\web\test>

Actual result:
--------------
Error message pops up with error "The procedure entry point
_zend_hash_init could not be located in the dynamic link library
php4ts.dll."

--
Edit bug report at [url]http://bugs.php.net/?id=25176&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=25176&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=25176&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=25176&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=25176&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=25176&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=25176&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=25176&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=25176&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=25176&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=25176&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=25176&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=25176&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=25176&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=25176&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=25176&r=gnused[/url]