ID: 25357
Comment by: dj_canard at yahoo dot com
Reported By: pjsmith at microtech dot co dot gg
Status: Bogus
Bug Type: *Mail Related
Operating System: Windows 2003, IIS, ISAPI
PHP Version: 4.3.3
New Comment:

Got the same problem here... I try to send a simple text e-mail but
around character number 1020 a character is lost.
I installed 4.3.0 and the problem is gone.
I'm using Windows 2000 and IIS 5.0


Previous Comments:
------------------------------------------------------------------------

[2003-09-02 13:14:36] da_cookie at hotmail dot com

I'm getting a similar problem, although I'm not certain if this is it.
I send emails with 4 pdf file attachments. in PHP 4.3.2, it worked
great. but with 4.3.3, the files are a few bytes smaller than the
original and wont open.

------------------------------------------------------------------------

[2003-09-02 09:37:08] [email]sniperphp.net[/email]

Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #25333


------------------------------------------------------------------------

[2003-09-02 08:19:56] pjsmith at microtech dot co dot gg

Just to confirm I have re-installed php 4.3.2 and the problem has gone
away...

------------------------------------------------------------------------

[2003-09-02 06:32:13] pjsmith at microtech dot co dot gg

Description:
------------
If you try to mail a string such as

recur-bill:
notes:
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (MingW32)
Comment: For info see [url]http://www.gnupg.org[/url]

iQCVAwUBP1R7lxOu+5gqBlaxAQHHqgQAqPNOlWVQWak4SQ6XUy IBu3c+09EE08lH
MR8mlRGzxy6LZd8MFxmnVjSMyDQJMDWlNwfRFdIokKTI0zDV2I U74GAct9VyPF5D
gW+cGXh7xyLdDBrq5BvjRlZ4iLspdgm1WHyZACV/DNikYTiax+XjYG34rCiN20Bn
3fqcGVXaGFM=
=syYY
-----END PGP SIGNATURE-----

With a pgp signature, it seems to be missing 1 character of the first
line of the signature, breaking it. This worked flawslessly with
4.3.2. When we upgraded yesterday, this started happening. I've spent
several hours on this and it would appear that the mail() function is
at fault.

Reproduce code:
---------------
Mail a pgp signed sig such as in the desciption and check the sig
before and after sending. My messages are about 1,220 bytes in length
on average with the sig at the bottom

The code I'm usnig is
$apptext=fread($domapp,filesize("uk_apps\\$appname ".
"_modify.asc"));
fclose($domapp);
mail("$recipient", "MODIFY", "$apptext",
"From: <hostmastermicrotech.co.gg>\r\nMessage-Id: <" . time() .
"microtech.co.gg>\r\nReply-To:
<hostmastermicrotech.co.gg>\r\nX-Mailer: PHP/" . phpversion());


Expected result:
----------------
It to send the mail with the string as supplied.



------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25357&edit=1[/url]