ID: 25444
User updated by: ict at primus dot ca
Reported By: ict at primus dot ca
-Status: Bogus
+Status: Open
Bug Type: *Configuration Issues
Operating System: W2K
PHP Version: 4.3.3
New Comment:

Perhaps your just jumpy but:

I have to test that the php4isapi.dll will not load the local php.ini
when there is no C:\winnt\


Try Try again.


Previous Comments:
------------------------------------------------------------------------

[2003-09-09 09:40:22] [email]sniperphp.net[/email]

Remove the php.ini from C:\winnt

------------------------------------------------------------------------

[2003-09-08 23:34:12] ict at primus dot ca

Description:
------------
When using php4isapi.dll in IIS the php.ini path can't be specified.

Details:
OS Windows 2K
Version PHP 4.3.3 ( complied VC++ V6.0 )
WServer IIS 4.X
Running each .DLL in seperate memory space.

Now this may be more of an issue, for us big server people.



Reproduce code:
---------------
Problem Outline:
using: C:/client1/php4isapi.dll for /client1/web/index.php
using: C:/client2/php4isapi.dll for /client2/web/index.php
etc ...
They both use C:\winnt\php.ini

Expected result:
----------------
Should use:
using: C:/client1/php4isapi.dll for /client1/web/index.php
Useing C:/client1/php.ini
using: C:/client2/php4isapi.dll for /client2/web/index.php
Useing C:/client2/php.ini
etc...



Actual result:
--------------
Does use:
using: C:/client1/php4isapi.dll for /client1/web/index.php
Useing C:/winnt/php.ini
using: C:/client2/php4isapi.dll for /client2/web/index.php
Useing C:/winnt/php.ini
etc...


I've serched the net and your site, no luck in finding a way of running
serveral copy of the 'php.ini'. I run the sites now with NO .INI and it
works great!

With no security in place :(

Please take your time on this one. I might be a simple re-complile or a
complex solution. THX again!

From:
Deek Starr


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25444&edit=1[/url]