From: fmuller at cisco dot com
Operating system: redhat 7.3
PHP version: 4.3.3
PHP Bug Type: *Web Server problem
Bug description: posting arrays from a multiply selected select box not working properly

Description:
------------
Red Hat 7.3/Apache 2.0/PHP 4.3.3.

If I select multiple selections on a select box,
with an array name,
with a form method of post

I do not get the array of selected values I expect.

If one option is selected it works fine.
If I use a method of get it works fine.

Here is what phpinfo.php displays when I select 1 and 2:

_REQUEST["param"]

Array
(
[0] => 1
[1] => 2param[]=1
[2] => 2
)

_POST["param"]

Array
(
[0] => 1
[1] => 2param[]=1
[2] => 2
)

Reproduce code:
---------------
<html>
<body>
<form method=post action=phpinfo.php>
<select name="param[]" multiple size=6>
<option value=0>0</option>
<option value=1>1</option>
<option value=2>2</option>
<option value=3>3</option>
<option value=4>4</option>
<option value=5>5</option>
<option value=6>6</option>
</select>
<input type=submit>
</form>
</body>
</html>

------------------

phpinfo.php
<?
phpinfo();
?>

Expected result:
----------------
_REQUEST["param"]

Array
(
[0] => 1
[1] => 2
)

_POST["param"]

Array
(
[0] => 1
[1] => 2
)



--
Edit bug report at [url]http://bugs.php.net/?id=25474&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=25474&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=25474&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=25474&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=25474&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=25474&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=25474&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=25474&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=25474&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=25474&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=25474&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=25474&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=25474&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=25474&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=25474&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=25474&r=gnused[/url]