ID: 25493
Updated by: [email]sniperphp.net[/email]
Reported By: jfreier at manleygroup dot com
-Status: Closed
+Status: Bogus
Bug Type: IIS related
Operating System: Window 2000
PHP Version: 4.3.3
New Comment:

User error -> bogus.



Previous Comments:
------------------------------------------------------------------------

[2003-09-11 11:55:45] jfreier at manleygroup dot com

Well, i got it working after i reinstalled PHP, but there error i was
having i thought should have been reported i hope it help alittle.

------------------------------------------------------------------------

[2003-09-11 11:17:23] [email]magnusphp.net[/email]

Are you editing the correct php.ini-file ?
Check the output form phpinfo() to see what file you should
edit. If you edited the wrong file, please mark this bug as
"Bogus".

------------------------------------------------------------------------

[2003-09-11 10:00:59] jfreier at manleygroup dot com

Description:
------------
Please Help,
Im run IIS, and Apache on the same server. I have changed the
register_globalveriable = On, restrated my comp and sure enough it
worked for apachie, BUT, when i run the same script under IIS 5.0 i get
the same error.

Notice: Undefined variable:

~I thnk that the new version of PHP, php.ini is not setting right with
windows IIS

Reproduce code:
---------------
index.php
<html>
<head><title>TestForm</title></head>
<body>
<form action=index2.php method=post>
<input type=text name=a>
<input type=submit value=testit>
<input type="hidden" name="action" value="form_submitted">
</form>
</body>
</html>

index2.php
<html>
<head></head>
<body>
<?php
print $a;
?>
</body>
</html>


Expected result:
----------------
What ever you type in

Actual result:
--------------
Notice: Undefined variable: c:\ line 5


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25493&edit=1[/url]