From: tqnam at pmail dot vnn dot vn
Operating system: window 2000
PHP version: 4.3.3
PHP Bug Type: Informix related
Bug description: How to get Blob in informix

Description:
------------
I insert a blob value into table, but when i get blob value it is erro,
please help me get it.

Reproduce code:
---------------
// the code insert blob value
$query="insert into blobimage(pit_id,pit_image)
values(5,FILETOBLOB('".$pathfile."','server'))";
$stmt=ifx_query($query,$con);
if(!$stmt){print("errors");}
ifx_free_result($stmt);
ifx_close($con);

// The code I get blob value
$query="select pit_image from blobimage where pit_id=5";
ifx_blobinfile_mode(1);
$stmt=ifx_query($query,$con);
if(!$stmt){print("errors");}
$row=ifx_fetch_row($stmt);
$content=ifx_get_blob($row["pit_image"]);
ifx_free_result($stmt);
ifx_close($con);



--
Edit bug report at [url]http://bugs.php.net/?id=25510&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=25510&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=25510&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=25510&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=25510&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=25510&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=25510&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=25510&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=25510&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=25510&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=25510&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=25510&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=25510&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=25510&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=25510&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=25510&r=gnused[/url]