ID: 25645
Updated by: [email]sniperphp.net[/email]
Reported By: makull at freemail dot nl
-Status: Open
+Status: Feedback
Bug Type: IIS related
Operating System: Windows 2000
PHP Version: 4.3.3
New Comment:

Are you using ISAPI module or CGI binary version of PHP?

What is "cgi.fix_pathinfo" set to in php.ini (if you use PHP CGI
binary)

Did you update your php.ini with the new php.ini-dist from the PHP
4.3.3 distribution?



Previous Comments:
------------------------------------------------------------------------

[2003-09-24 11:24:13] makull at freemail dot nl

Description:
------------
If you use any PHP version above 4.2.3, including a PHP file from
within a SSI file using '#exec cgi' or '#include virtual' will fail and
either result in the raw source code of the PHP script or in machine
code.

If you go back to PHP 4.2.3 using '#exec cgi' to include a PHP file
works perfectly.

This is on a Windows 2000 server using IIS 5 and all the latest service
packs and patches.

Reproduce code:
---------------
Lines from the SSI file (.shtml) :

<!--#exec cgi="test.php"-->
<!--#virtual include="test.php"-->


Expected result:
----------------
Expected result : The output of the PHP script in HTML (the output is
correct when you run it directly).

Actual result:
--------------
Actual result : Either the source code from the PHP script (virtual
include) or machine code (exec cgi).


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25645&edit=1[/url]