ID: 25809
Updated by: [email]sniperphp.net[/email]
Reported By: xirkus at z1r0 dot com
-Status: Open
+Status: Feedback
Bug Type: Compile Failure
Operating System: Linux Kernel 2.4.21
PHP Version: 4.3.2
New Comment:

What does config.log have about this? Check the 20-30 last lines.



Previous Comments:
------------------------------------------------------------------------

[2003-10-10 11:06:04] xirkus at z1r0 dot com

I've tried with a vanilla:

--with-xslt-sablot

and :

--with-xslt-sablot=/usr/local

as suggested by [email]sniperphp.net[/email]. No go. It still breaks at the same
point.

I would like to continue using 4.3.2 as I also have postgresql
functionality enabled and there are reports that version 4.3.3 has
problems connecting to the postgresql server. This is a production box
and until 4.3.4 stable comes out, I would rather not be fiddling with a
working php install.

Thanks,

Mel

------------------------------------------------------------------------

[2003-10-09 18:12:28] [email]sniperphp.net[/email]

And by using correct configure options might help too:

--with-xslt-sablot=/usr/local


------------------------------------------------------------------------

[2003-10-09 18:07:00] [email]elmichaphp.net[/email]

Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP --
the problem might already be fixed. Please download a new
PHP version from [url]http://www.php.net/downloads.php[/url]

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Please try with the latest stable snapshot from <http://snaps.php.net>.

------------------------------------------------------------------------

[2003-10-09 13:30:25] xirkus at z1r0 dot com

Description:
------------
When ever I attempt to compile php 4.3.2 with both the :

--enable-xslt
--with-xslt-sablot=/usr/local/lib

options and :

--enable-yp

in my configure script, I receive the following errors:

configure: error: Unable to find required yp/nis library
make: *** No targets sepcified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.
make: *** No rule to make target `distclean'. Stop.

If I remove the xslt options, configure compiles php without any
problems what so ever.

Help resolving this issue would be greatly appreciated.

Mel Llaguno


Expected result:
----------------
I should be able to compile php with both the --enable-yp and
--enable-xslt options working.



------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=25809&edit=1[/url]