From: topitz at definiens dot com
Operating system: Win2k
PHP version: 4.3.3
PHP Bug Type: Mail related
Bug description: base64 encoding is wrong

Description:
------------
I use the SendMail() from the php.net (->alexbartl.net). Till now it
works fine, but now i updated the webserver to IIS5 on Win2k from IIS4 on
NT4, and now the base64 encoding seems to work wrong (HTML and Attachment
part). The SMTP Server is Linux. Mail will received with Outlook.
I tried already to change the cht from iso-8859-1 to utf-8, but it
doesn't becomes better.

This problem i got only with Win2k/IIS5!

Reproduce code:
---------------
$TEXT="Hallo, this a test for my email program. Hallo, this a test for
my email program. ....long text with breaks ....
test for my email program. Hallo, this a test for my email program.";
$HTML=false;

if (SendMail(
"phpmailerdefiniens.com","PHP Apache Webmailer", //sender
"topitzdefiniens.com","Tiberius Opitz", //recipient
"Testmail", //subject
$TEXT,$HTML,$ATTM)) echo "Mail send successfull.";

function
SendMail($From,$FromName,$To,$ToName,$Subject,$Tex t,$Html,$AttmFiles){
.... see php.net
}

Expected result:
----------------
the script should send a mail with multipart data (text/html/attachment)
and print a success message after sending.

Actual result:
--------------
I got the email abreviated, but with additional characters (wrong
decoded)like: ܈^H[XZ[ܘ[KO...
I've the same problem with attechments.

--
Edit bug report at [url]http://bugs.php.net/?id=26036&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=26036&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=26036&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=26036&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=26036&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=26036&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=26036&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=26036&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=26036&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=26036&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=26036&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=26036&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=26036&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=26036&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=26036&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=26036&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=26036&r=float[/url]