Professional Web Applications Themes

#26038 [Com]: session_start(): Failed to initialize storage module - PHP Development

ID: 26038 Comment by: carloxsi at hotmail dot com Reported By: pedro at dehumanizer dot com Status: Open Bug Type: Session related Operating System: FreeBSD 4.9 PHP Version: 4CVS-2003-10-30 (stable) New Comment: Carlo Previous Comments: ------------------------------------------------------------------------ [2003-10-30 07:34:12] pedro at dehumanizer dot com By the way, if I use Apache 1.3.28 instead, configuring the same version of PHP with exactly the same options (except replacing --with-apxs2 with --with-apxs), the problem disappears. ------------------------------------------------------------------------ [2003-10-30 07:30:51] pedro at dehumanizer dot com Description: ------------ I believe this bug had already been reported by someone else (#25876), but it was marked as "bogus". I'm ...

  1. #1

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: carloxsi at hotmail dot com
    Reported By: pedro at dehumanizer dot com
    Status: Open
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    Carlo


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-10-30 07:34:12] pedro at dehumanizer dot com

    By the way, if I use Apache 1.3.28 instead, configuring the same
    version of PHP with exactly the same options (except replacing
    --with-apxs2 with --with-apxs), the problem disappears.

    ------------------------------------------------------------------------

    [2003-10-30 07:30:51] pedro at dehumanizer dot com

    Description:
    ------------
    I believe this bug had already been reported by someone else (#25876),
    but it was marked as "bogus".

    I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
    (and 2.0.47 before), and tried several PHP versions from 4.3.2 to
    4CVS-20031030 (today's). All of them exhibit this problem, with
    SquirrelMail 1.4.2.

    I don't think it's a SquirrelMail problem, however, as the line in
    question is a simple

    session_start();

    The problem is intermitent - when navigating through the webmail, from
    time to time, when I click on a link, a blank page appears *very
    quickly*, just in the frame which was supposed to be changed. In the
    logs, I get this error:

    [client 62.169.69.5] PHP Fatal error: session_start(): Failed to
    initialize storage module. in /var/www/htdocs/mail/functions/global.php
    on line 295, referer: [url]https://www.dehumanizer.com/mail/src/webmail.php[/url]

    If I reload the page, or go back from the blank page and click on the
    same link again, it usually works then. The error rate is hard to
    calculate, but it should be less than 1 in 10 times.

    I've tried changing the sessions handler between files and mm, but it
    doesn't solve the problem. Neither does activating register_globals,
    which SquirrelMail doesn't need, anyway.

    PHP configure options:

    ../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
    --with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
    --enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
    --enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
    --with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
    --enable-mbstring --enable-mbregex --enable-zend-multibyte
    --with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local




    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=26038&edit=1[/url]
    carloxsi at hotmail dot com Guest

  2. #2

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: darren at cpanel dot net
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-11-17 18:08:18] net

    It's not PHP bug. (Apache2 is really not ready for production)


    ------------------------------------------------------------------------

    [2003-10-30 07:34:12] pedro at dehumanizer dot com

    By the way, if I use Apache 1.3.28 instead, configuring the same
    version of PHP with exactly the same options (except replacing
    --with-apxs2 with --with-apxs), the problem disappears.

    ------------------------------------------------------------------------

    [2003-10-30 07:30:51] pedro at dehumanizer dot com

    Description:
    ------------
    I believe this bug had already been reported by someone else (#25876),
    but it was marked as "bogus".

    I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
    (and 2.0.47 before), and tried several PHP versions from 4.3.2 to
    4CVS-20031030 (today's). All of them exhibit this problem, with
    SquirrelMail 1.4.2.

    I don't think it's a SquirrelMail problem, however, as the line in
    question is a simple

    session_start();

    The problem is intermitent - when navigating through the webmail, from
    time to time, when I click on a link, a blank page appears *very
    quickly*, just in the frame which was supposed to be changed. In the
    logs, I get this error:

    [client 62.169.69.5] PHP Fatal error: session_start(): Failed to
    initialize storage module. in /var/www/htdocs/mail/functions/global.php
    on line 295, referer: https://www.dehumanizer.com/mail/src/webmail.php

    If I reload the page, or go back from the blank page and click on the
    same link again, it usually works then. The error rate is hard to
    calculate, but it should be less than 1 in 10 times.

    I've tried changing the sessions handler between files and mm, but it
    doesn't solve the problem. Neither does activating register_globals,
    which SquirrelMail doesn't need, anyway.

    PHP configure options:

    ../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
    --with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
    --enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
    --enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
    --with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
    --enable-mbstring --enable-mbregex --enable-zend-multibyte
    --with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local




    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    darren Guest

  3. #3

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: der at derdev dot com
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    I confirm problem on RedHat 7.3, source-built apache 1.3.29, php 4.3.4
    as module. Mysql 3.23.56, localhost socket connect.


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-12-16 17:05:45] darren at cpanel dot net

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.

    ------------------------------------------------------------------------

    [2003-11-17 18:08:18] net

    It's not PHP bug. (Apache2 is really not ready for production)


    ------------------------------------------------------------------------

    [2003-10-30 07:34:12] pedro at dehumanizer dot com

    By the way, if I use Apache 1.3.28 instead, configuring the same
    version of PHP with exactly the same options (except replacing
    --with-apxs2 with --with-apxs), the problem disappears.

    ------------------------------------------------------------------------

    [2003-10-30 07:30:51] pedro at dehumanizer dot com

    Description:
    ------------
    I believe this bug had already been reported by someone else (#25876),
    but it was marked as "bogus".

    I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
    (and 2.0.47 before), and tried several PHP versions from 4.3.2 to
    4CVS-20031030 (today's). All of them exhibit this problem, with
    SquirrelMail 1.4.2.

    I don't think it's a SquirrelMail problem, however, as the line in
    question is a simple

    session_start();

    The problem is intermitent - when navigating through the webmail, from
    time to time, when I click on a link, a blank page appears *very
    quickly*, just in the frame which was supposed to be changed. In the
    logs, I get this error:

    [client 62.169.69.5] PHP Fatal error: session_start(): Failed to
    initialize storage module. in /var/www/htdocs/mail/functions/global.php
    on line 295, referer: https://www.dehumanizer.com/mail/src/webmail.php

    If I reload the page, or go back from the blank page and click on the
    same link again, it usually works then. The error rate is hard to
    calculate, but it should be less than 1 in 10 times.

    I've tried changing the sessions handler between files and mm, but it
    doesn't solve the problem. Neither does activating register_globals,
    which SquirrelMail doesn't need, anyway.

    PHP configure options:

    ../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
    --with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
    --enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
    --enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
    --with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
    --enable-mbstring --enable-mbregex --enable-zend-multibyte
    --with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local




    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    der Guest

  4. #4

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: dewaard at netcollective dot nl
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    I encountered this problem while working on a custom
    session handler with session_set_save_handler(). All the
    virtual hosts on that particular server that contain
    session_start() where having this issue, except from the
    virtual host on which I was developing the custom
    session handler. The only way to solve it was an Apache
    restart.

    After a while the problem occured again and an Apache
    restart fixed this occurence to. I don't know what
    caused the problem, but i'm quite sure it happened
    because of my experiments with
    session_set_save_handler(). I didn't do anything else
    that relates to sessions and didn't mess with the ini
    settings.

    The error occured on PHP 4.3.3 (Apache 1.3.29, Red Hat
    8). I've just updated to PHP 4.3.4, but I'm afraid that
    won't solve this issue. I will true to find out more
    about this problem and will share all the clues that i
    can find.


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-12-29 16:51:31] der at derdev dot com

    I confirm problem on RedHat 7.3, source-built apache 1.3.29, php 4.3.4
    as module. Mysql 3.23.56, localhost socket connect.

    ------------------------------------------------------------------------

    [2003-12-16 17:05:45] darren at cpanel dot net

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.

    ------------------------------------------------------------------------

    [2003-11-17 18:08:18] net

    It's not PHP bug. (Apache2 is really not ready for production)


    ------------------------------------------------------------------------

    [2003-10-30 07:34:12] pedro at dehumanizer dot com

    By the way, if I use Apache 1.3.28 instead, configuring the same
    version of PHP with exactly the same options (except replacing
    --with-apxs2 with --with-apxs), the problem disappears.

    ------------------------------------------------------------------------

    [2003-10-30 07:30:51] pedro at dehumanizer dot com

    Description:
    ------------
    I believe this bug had already been reported by someone else (#25876),
    but it was marked as "bogus".

    I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
    (and 2.0.47 before), and tried several PHP versions from 4.3.2 to
    4CVS-20031030 (today's). All of them exhibit this problem, with
    SquirrelMail 1.4.2.

    I don't think it's a SquirrelMail problem, however, as the line in
    question is a simple

    session_start();

    The problem is intermitent - when navigating through the webmail, from
    time to time, when I click on a link, a blank page appears *very
    quickly*, just in the frame which was supposed to be changed. In the
    logs, I get this error:

    [client 62.169.69.5] PHP Fatal error: session_start(): Failed to
    initialize storage module. in /var/www/htdocs/mail/functions/global.php
    on line 295, referer: https://www.dehumanizer.com/mail/src/webmail.php

    If I reload the page, or go back from the blank page and click on the
    same link again, it usually works then. The error rate is hard to
    calculate, but it should be less than 1 in 10 times.

    I've tried changing the sessions handler between files and mm, but it
    doesn't solve the problem. Neither does activating register_globals,
    which SquirrelMail doesn't need, anyway.

    PHP configure options:

    ../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
    --with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
    --enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
    --enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
    --with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
    --enable-mbstring --enable-mbregex --enable-zend-multibyte
    --with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local




    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    dewaard Guest

  5. #5

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: bugs dot php dot net at mkaart dot net
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    Hi,

    I had similar problems on my Gentoo Linux box running Apache 2.0.48 and
    php4. The problem was solved when I changed the following setting from
    "user" to "files" in the php.ini:

    session.save_handler = files

    Note: This broke drupal (a CMS i have running), but enabling .htaccess
    for drupal, which sets session.save_handler to user, fixed that as
    well.

    Hope this helps...

    Regards,

    Marnix Kaart


    Previous Comments:
    ------------------------------------------------------------------------

    [2004-01-05 03:28:35] dewaard at netcollective dot nl

    I encountered this problem while working on a custom
    session handler with session_set_save_handler(). All the
    virtual hosts on that particular server that contain
    session_start() where having this issue, except from the
    virtual host on which I was developing the custom
    session handler. The only way to solve it was an Apache
    restart.

    After a while the problem occured again and an Apache
    restart fixed this occurence to. I don't know what
    caused the problem, but i'm quite sure it happened
    because of my experiments with
    session_set_save_handler(). I didn't do anything else
    that relates to sessions and didn't mess with the ini
    settings.

    The error occured on PHP 4.3.3 (Apache 1.3.29, Red Hat
    8). I've just updated to PHP 4.3.4, but I'm afraid that
    won't solve this issue. I will true to find out more
    about this problem and will share all the clues that i
    can find.

    ------------------------------------------------------------------------

    [2003-12-29 16:51:31] der at derdev dot com

    I confirm problem on RedHat 7.3, source-built apache 1.3.29, php 4.3.4
    as module. Mysql 3.23.56, localhost socket connect.

    ------------------------------------------------------------------------

    [2003-12-16 17:05:45] darren at cpanel dot net

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.

    ------------------------------------------------------------------------

    [2003-11-17 18:08:18] net

    It's not PHP bug. (Apache2 is really not ready for production)


    ------------------------------------------------------------------------

    [2003-10-30 07:34:12] pedro at dehumanizer dot com

    By the way, if I use Apache 1.3.28 instead, configuring the same
    version of PHP with exactly the same options (except replacing
    --with-apxs2 with --with-apxs), the problem disappears.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/26038

    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    bugs Guest

  6. #6

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: mivox at mivox dot com
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    Happens frequently on my osCommerce site, hosted at Pair, running
    Apache 1.3.29 and PHP 4.3.4. The problems started in November 2003, and
    they began upgrading to FreeBSD 4.6-STABLE (incl. the Apache and PHP
    versions noted above) in November.

    I have just tried implementing the suggestion given above about the
    session.save_handler = files php setting, by adding the following to my
    ..htaccess file (as per Pair's suggestion):

    php_value session.save_handler files
    php_value magic_quotes_gpc 1

    If the problem reappears after altering the .htaccess, I will report
    back. It seems to be running fine right now, but it is a maddeningly
    intermittent problem.


    Previous Comments:
    ------------------------------------------------------------------------

    [2004-02-05 06:42:40] bugs dot php dot net at mkaart dot net

    Hi,

    I had similar problems on my Gentoo Linux box running Apache 2.0.48 and
    php4. The problem was solved when I changed the following setting from
    "user" to "files" in the php.ini:

    session.save_handler = files

    Note: This broke drupal (a CMS i have running), but enabling .htaccess
    for drupal, which sets session.save_handler to user, fixed that as
    well.

    Hope this helps...

    Regards,

    Marnix Kaart

    ------------------------------------------------------------------------

    [2004-01-05 03:28:35] dewaard at netcollective dot nl

    I encountered this problem while working on a custom
    session handler with session_set_save_handler(). All the
    virtual hosts on that particular server that contain
    session_start() where having this issue, except from the
    virtual host on which I was developing the custom
    session handler. The only way to solve it was an Apache
    restart.

    After a while the problem occured again and an Apache
    restart fixed this occurence to. I don't know what
    caused the problem, but i'm quite sure it happened
    because of my experiments with
    session_set_save_handler(). I didn't do anything else
    that relates to sessions and didn't mess with the ini
    settings.

    The error occured on PHP 4.3.3 (Apache 1.3.29, Red Hat
    8). I've just updated to PHP 4.3.4, but I'm afraid that
    won't solve this issue. I will true to find out more
    about this problem and will share all the clues that i
    can find.

    ------------------------------------------------------------------------

    [2003-12-29 16:51:31] der at derdev dot com

    I confirm problem on RedHat 7.3, source-built apache 1.3.29, php 4.3.4
    as module. Mysql 3.23.56, localhost socket connect.

    ------------------------------------------------------------------------

    [2003-12-16 17:05:45] darren at cpanel dot net

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.

    ------------------------------------------------------------------------

    [2003-11-17 18:08:18] net

    It's not PHP bug. (Apache2 is really not ready for production)


    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/26038

    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    mivox Guest

  7. #7

    Default #26038 [Com]: session_start(): Failed to initialize storage module

    ID: 26038
    Comment by: mivox at mivox dot com
    Reported By: pedro at dehumanizer dot com
    Status: Bogus
    Bug Type: Session related
    Operating System: FreeBSD 4.9
    PHP Version: 4CVS-2003-10-30 (stable)
    New Comment:

    Correction: Pair upgraded *to* FreeBSD 4.8-STABLE *from* 4.6...


    Previous Comments:
    ------------------------------------------------------------------------

    [2004-02-12 16:52:36] mivox at mivox dot com

    Happens frequently on my osCommerce site, hosted at Pair, running
    Apache 1.3.29 and PHP 4.3.4. The problems started in November 2003, and
    they began upgrading to FreeBSD 4.6-STABLE (incl. the Apache and PHP
    versions noted above) in November.

    I have just tried implementing the suggestion given above about the
    session.save_handler = files php setting, by adding the following to my
    ..htaccess file (as per Pair's suggestion):

    php_value session.save_handler files
    php_value magic_quotes_gpc 1

    If the problem reappears after altering the .htaccess, I will report
    back. It seems to be running fine right now, but it is a maddeningly
    intermittent problem.

    ------------------------------------------------------------------------

    [2004-02-05 06:42:40] bugs dot php dot net at mkaart dot net

    Hi,

    I had similar problems on my Gentoo Linux box running Apache 2.0.48 and
    php4. The problem was solved when I changed the following setting from
    "user" to "files" in the php.ini:

    session.save_handler = files

    Note: This broke drupal (a CMS i have running), but enabling .htaccess
    for drupal, which sets session.save_handler to user, fixed that as
    well.

    Hope this helps...

    Regards,

    Marnix Kaart

    ------------------------------------------------------------------------

    [2004-01-05 03:28:35] dewaard at netcollective dot nl

    I encountered this problem while working on a custom
    session handler with session_set_save_handler(). All the
    virtual hosts on that particular server that contain
    session_start() where having this issue, except from the
    virtual host on which I was developing the custom
    session handler. The only way to solve it was an Apache
    restart.

    After a while the problem occured again and an Apache
    restart fixed this occurence to. I don't know what
    caused the problem, but i'm quite sure it happened
    because of my experiments with
    session_set_save_handler(). I didn't do anything else
    that relates to sessions and didn't mess with the ini
    settings.

    The error occured on PHP 4.3.3 (Apache 1.3.29, Red Hat
    8). I've just updated to PHP 4.3.4, but I'm afraid that
    won't solve this issue. I will true to find out more
    about this problem and will share all the clues that i
    can find.

    ------------------------------------------------------------------------

    [2003-12-29 16:51:31] der at derdev dot com

    I confirm problem on RedHat 7.3, source-built apache 1.3.29, php 4.3.4
    as module. Mysql 3.23.56, localhost socket connect.

    ------------------------------------------------------------------------

    [2003-12-16 17:05:45] darren at cpanel dot net

    Just FYI, this also happens with apache 1.3.29 and php 4.3.3 and 4.3.4
    on RedHat Linux.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/26038

    --
    Edit this bug report at http://bugs.php.net/?id=26038&edit=1
    mivox Guest

Similar Threads

  1. Replies: 0
    Last Post: November 17th, 11:10 PM
  2. #26038 [Opn]: session_start(): Failed to initialize storage module
    By pedro at dehumanizer dot com in forum PHP Development
    Replies: 4
    Last Post: October 31st, 01:07 PM
  3. #26038 [Fbk->Opn]: session_start(): Failed to initialize storage module
    By pedro at dehumanizer dot com in forum PHP Development
    Replies: 0
    Last Post: October 31st, 10:51 AM
  4. Replies: 0
    Last Post: October 31st, 02:09 AM
  5. #26038 [NEW]: session_start(): Failed to initialize storage module
    By pedro at dehumanizer dot com in forum PHP Development
    Replies: 0
    Last Post: October 30th, 12:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139