From: pedro at dehumanizer dot com
Operating system: FreeBSD 4.9
PHP version: 4CVS-2003-10-30 (stable)
PHP Bug Type: Apache2 related
Bug description: session_start(): Failed to initialize storage module

Description:
------------
I believe this bug had already been reported by someone else (#25876), but
it was marked as "bogus".

I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
(and 2.0.47 before), and tried several PHP versions from 4.3.2 to
4CVS-20031030 (today's). All of them exhibit this problem, with
SquirrelMail 1.4.2.

I don't think it's a SquirrelMail problem, however, as the line in
question is a simple

session_start();

The problem is intermitent - when navigating through the webmail, from
time to time, when I click on a link, a blank page appears *very quickly*,
just in the frame which was supposed to be changed. In the logs, I get
this error:

[client 62.169.69.5] PHP Fatal error: session_start(): Failed to
initialize storage module. in /var/www/htdocs/mail/functions/global.php on
line 295, referer: [url]https://www.dehumanizer.com/mail/src/webmail.php[/url]

If I reload the page, or go back from the blank page and click on the same
link again, it usually works then. The error rate is hard to calculate,
but it should be less than 1 in 10 times.

I've tried changing the sessions handler between files and mm, but it
doesn't solve the problem. Neither does activating register_globals, which
SquirrelMail doesn't need, anyway.

PHP configure options:

../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
--with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
--enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
--enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
--with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
--enable-mbstring --enable-mbregex --enable-zend-multibyte
--with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local



--
Edit bug report at [url]http://bugs.php.net/?id=26038&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=26038&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=26038&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=26038&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=26038&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=26038&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=26038&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=26038&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=26038&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=26038&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=26038&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=26038&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=26038&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=26038&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=26038&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=26038&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=26038&r=float[/url]