ID: 26038
Updated by: [email]sniperphp.net[/email]
Reported By: pedro at dehumanizer dot com
-Status: Open
+Status: Bogus
Bug Type: Session related
Operating System: FreeBSD 4.9
PHP Version: 4CVS-2003-10-30 (stable)
New Comment:

It's not PHP bug. (Apache2 is really not ready for production)



Previous Comments:
------------------------------------------------------------------------

[2003-10-30 07:34:12] pedro at dehumanizer dot com

By the way, if I use Apache 1.3.28 instead, configuring the same
version of PHP with exactly the same options (except replacing
--with-apxs2 with --with-apxs), the problem disappears.

------------------------------------------------------------------------

[2003-10-30 07:30:51] pedro at dehumanizer dot com

Description:
------------
I believe this bug had already been reported by someone else (#25876),
but it was marked as "bogus".

I'm using FreeBSD 4.9 (and 4.8-STABLE before), Apache 2.0.48 from ports
(and 2.0.47 before), and tried several PHP versions from 4.3.2 to
4CVS-20031030 (today's). All of them exhibit this problem, with
SquirrelMail 1.4.2.

I don't think it's a SquirrelMail problem, however, as the line in
question is a simple

session_start();

The problem is intermitent - when navigating through the webmail, from
time to time, when I click on a link, a blank page appears *very
quickly*, just in the frame which was supposed to be changed. In the
logs, I get this error:

[client 62.169.69.5] PHP Fatal error: session_start(): Failed to
initialize storage module. in /var/www/htdocs/mail/functions/global.php
on line 295, referer: [url]https://www.dehumanizer.com/mail/src/webmail.php[/url]

If I reload the page, or go back from the blank page and click on the
same link again, it usually works then. The error rate is hard to
calculate, but it should be less than 1 in 10 times.

I've tried changing the sessions handler between files and mm, but it
doesn't solve the problem. Neither does activating register_globals,
which SquirrelMail doesn't need, anyway.

PHP configure options:

../configure --disable-cgi --with-apxs2=/usr/local/sbin/apxs
--with-openssl --with-zlib --with-gdbm --with-imap --with-iconv
--enable-ftp --with-mysql=/usr/local/mysql --with-curl --disable-debug
--enable-exif --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir
--with-png-dir --enable-dio --with-gettext=/usr/local --with-bz2
--enable-mbstring --enable-mbregex --enable-zend-multibyte
--with-mysql-sock=/tmp/mysql.sock --with-mm=/usr/local




------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=26038&edit=1[/url]