From: dqj at requesttech dot com
Operating system: Redhat 9.0
PHP version: 4.3.3
PHP Bug Type: Reproducible crash
Bug description: pg_lo_import causes crash under all cirstances

Description:
------------
No changes to php.ini distribution. No output shown in logs. Just
doesn't finish the page. (I have put echoes and breaks in to narrow it to
the pg_lo_import() call). We have checked file permissions, etc. This
code has worked under PHP 4.2 and other versions. Have tried switching
the pg_lo_import parameters back and forth, just in case, as described in
the bug doentation.



Reproduce code:
---------------
<?php
$res = pg_connect( "host=myhost dbname=mytest user=myuser password=zzz"
);
pg_exec( $res, "BEGIN" );
$oid = pg_lo_import( $res, "/tmp/dqj.tmp" );
pg_exec( $res, "COMMIT" );
echo "RES: $res, OID: $oid<br/>"; flush();
?>


Expected result:
----------------
$oid should have a value. Echoed results should appear.


Actual result:
--------------
Blank page. (Or echoed results prior to subroutine call, if debug is
included.)


--
Edit bug report at [url]http://bugs.php.net/?id=26043&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=26043&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=26043&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=26043&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=26043&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=26043&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=26043&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=26043&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=26043&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=26043&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=26043&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=26043&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=26043&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=26043&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=26043&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=26043&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=26043&r=float[/url]