ID: 26043
User updated by: dqj at requesttech dot com
Reported By: dqj at requesttech dot com
Status: Open
Bug Type: PostgreSQL related
Operating System: Redhat 9.0
PHP Version: 4.3.3
New Comment:

Forgot to mention that the Postgres version is 7.3.4.


Previous Comments:
------------------------------------------------------------------------

[2003-10-30 14:26:13] dqj at requesttech dot com

I was wrong about there not being anything in the logs. In the httpd
error_log, there was the following:

[Thu Oct 30 14:25:10 2003] [notice] child pid 16877 exit signal
Segmentation fault (11)

This occurs whenever a valid filename is given to pg_lo_import.

------------------------------------------------------------------------

[2003-10-30 13:49:41] [email]sniperphp.net[/email]

Please try using this CVS snapshot:

[url]http://snaps.php.net/php4-STABLE-latest.tar.gz[/url]

For Windows:

[url]http://snaps.php.net/win32/php4-win32-STABLE-latest.zip[/url]



------------------------------------------------------------------------

[2003-10-30 13:48:23] dqj at requesttech dot com

Description:
------------
No changes to php.ini distribution. No output shown in logs. Just
doesn't finish the page. (I have put echoes and breaks in to narrow it
to the pg_lo_import() call). We have checked file permissions, etc.
This code has worked under PHP 4.2 and other versions. Have tried
switching the pg_lo_import parameters back and forth, just in case, as
described in the bug doentation.



Reproduce code:
---------------
<?php
$res = pg_connect( "host=myhost dbname=mytest user=myuser password=zzz"
);
pg_exec( $res, "BEGIN" );
$oid = pg_lo_import( $res, "/tmp/dqj.tmp" );
pg_exec( $res, "COMMIT" );
echo "RES: $res, OID: $oid<br/>"; flush();
?>


Expected result:
----------------
$oid should have a value. Echoed results should appear.


Actual result:
--------------
Blank page. (Or echoed results prior to subroutine call, if debug is
included.)



------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=26043&edit=1[/url]