From: orsaini at allainet dot com
Operating system: Lunux Apache 2.0.47
PHP version: 4.3.2
PHP Bug Type: *Directory/Filesystem functions
Bug description: relative include path not working with include() from shell command line execut

Description:
------------
relative path in include function is not working when I run the script
from command prompt or through cron job. but worked fine when I run same
script from web browser through Apache.

Reproduce code:
---------------
include("../../foldername/file.php");

Expected result:
----------------
should include the path when I run php through command prompt

/usr/bin/php /path/test.php

Actual result:
--------------
Warning: main(../../foldername/file.php): failed to open stream: No such
file or directory

--
Edit bug report at [url]http://bugs.php.net/?id=26259&edit=1[/url]
--
Try a CVS snapshot (php4): [url]http://bugs.php.net/fix.php?id=26259&r=trysnapshot4[/url]
Try a CVS snapshot (php5): [url]http://bugs.php.net/fix.php?id=26259&r=trysnapshot5[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=26259&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=26259&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=26259&r=needtrace[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=26259&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=26259&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=26259&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=26259&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=26259&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=26259&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=26259&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=26259&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=26259&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=26259&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=26259&r=float[/url]