Professional Web Applications Themes

#35793 [Com]: General error: 2050 - PHP Bugs

ID: 35793 Comment by: andiesPostfach at web dot de Reported By: deadman_great at mail dot ru Status: No Feedback Bug Type: PDO related Operating System: RH Fedora Core 2 PHP Version: 5CVS-2005-12-25 (snap) Assigned To: Wez New Comment: The Problem still exists in PHP 5.2 RC5 !! System ist SUSE-Linux 9.3 MySQL Version 5.0.18 Previous Comments: ------------------------------------------------------------------------ [2006-08-23 11:14:46] t dot meesters at gmail dot com This problem still occurs with: PHP-5.1.5 MySQL-5.0.22 Linux platform Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error message remains: SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by mysql_stmt_close() call ------------------------------------------------------------------------ [2006-08-01 20:52:55] mass ...

  1. #1

    Default #35793 [Com]: General error: 2050

    ID: 35793
    Comment by: andiesPostfach at web dot de
    Reported By: deadman_great at mail dot ru
    Status: No Feedback
    Bug Type: PDO related
    Operating System: RH Fedora Core 2
    PHP Version: 5CVS-2005-12-25 (snap)
    Assigned To: Wez
    New Comment:

    The Problem still exists in PHP 5.2 RC5 !!

    System ist SUSE-Linux 9.3
    MySQL Version 5.0.18


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-08-23 11:14:46] t dot meesters at gmail dot com

    This problem still occurs with:
    PHP-5.1.5
    MySQL-5.0.22
    Linux platform

    Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error
    message remains:

    SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by
    mysql_stmt_close() call

    ------------------------------------------------------------------------

    [2006-08-01 20:52:55] mass at carlsoft dot net

    Can we at least change this error message to be more specific, perhaps
    suggesting to emulate prepares (as wez php . net suggested)? or
    better yet make the emulation default?

    ------------------------------------------------------------------------

    [2006-05-07 01:00:00] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    [2006-05-02 14:53:18] email at steffenweber dot net

    Upgrading to PHP 5.1.3 and using
    $db->setAttribute(PDO::ATTR_EMULATE_PREPARES, true); fixes the problem
    for me.

    ------------------------------------------------------------------------

    [2006-04-30 00:56:35] [email]wezphp.net[/email]

    Please read this blog entry and see if following the advice there
    helps:
    [url]http://netevil.org/node.php?nid=795[/url]
    (you'll want to upgrade to PHP 5.1.3 or a current snapshot first).

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/35793[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=35793&edit=1[/url]
    andiesPostfach at web dot de Guest

  2. #2

    Default #35793 [Com]: General error: 2050

    ID: 35793
    Comment by: michal dot vrchota at seznam dot cz
    Reported By: deadman_great at mail dot ru
    Status: No Feedback
    Bug Type: PDO related
    Operating System: RH Fedora Core 2
    PHP Version: 5CVS-2005-12-25 (snap)
    Assigned To: Wez
    New Comment:

    I think I have solved this problem:

    You have to free your PDOStatement instance

    Of course You have to call closeCursor() method to be sure, but if you
    have more queries and still using same identifier ($stmt) you have free
    it by passing NULL value

    Sample:
    $stmt->closeCursor();
    $stmt = NULL;

    // now it works ;)


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-10-16 14:46:09] andiesPostfach at web dot de

    The Problem still exists in PHP 5.2 RC5 !!

    System ist SUSE-Linux 9.3
    MySQL Version 5.0.18

    ------------------------------------------------------------------------

    [2006-08-23 11:14:46] t dot meesters at gmail dot com

    This problem still occurs with:
    PHP-5.1.5
    MySQL-5.0.22
    Linux platform

    Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error
    message remains:

    SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by
    mysql_stmt_close() call

    ------------------------------------------------------------------------

    [2006-08-01 20:52:55] mass at carlsoft dot net

    Can we at least change this error message to be more specific, perhaps
    suggesting to emulate prepares (as wez php . net suggested)? or
    better yet make the emulation default?

    ------------------------------------------------------------------------

    [2006-05-07 01:00:00] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    [2006-05-02 14:53:18] email at steffenweber dot net

    Upgrading to PHP 5.1.3 and using
    $db->setAttribute(PDO::ATTR_EMULATE_PREPARES, true); fixes the problem
    for me.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/35793[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=35793&edit=1[/url]
    michal dot vrchota at seznam dot cz Guest

  3. #3

    Default #35793 [Com]: General error: 2050

    ID: 35793
    Comment by: richard at phase dot org
    Reported By: deadman_great at mail dot ru
    Status: No Feedback
    Bug Type: PDO related
    Operating System: RH Fedora Core 2
    PHP Version: 5CVS-2005-12-25 (snap)
    Assigned To: Wez
    New Comment:

    $this->pdo->setAttribute(PDO::ATTR_EMULATE_PREPARES, true);

    (a suggested fix above) fails on 5.2.RC6 as PDO::ATTR_EMULATE_PREPARES
    appears no longer to be defined.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-10-17 01:15:58] michal dot vrchota at seznam dot cz

    I think I have solved this problem:

    You have to free your PDOStatement instance

    Of course You have to call closeCursor() method to be sure, but if you
    have more queries and still using same identifier ($stmt) you have free
    it by passing NULL value

    Sample:
    $stmt->closeCursor();
    $stmt = NULL;

    // now it works ;)

    ------------------------------------------------------------------------

    [2006-10-16 14:46:09] andiesPostfach at web dot de

    The Problem still exists in PHP 5.2 RC5 !!

    System ist SUSE-Linux 9.3
    MySQL Version 5.0.18

    ------------------------------------------------------------------------

    [2006-08-23 11:14:46] t dot meesters at gmail dot com

    This problem still occurs with:
    PHP-5.1.5
    MySQL-5.0.22
    Linux platform

    Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error
    message remains:

    SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by
    mysql_stmt_close() call

    ------------------------------------------------------------------------

    [2006-08-01 20:52:55] mass at carlsoft dot net

    Can we at least change this error message to be more specific, perhaps
    suggesting to emulate prepares (as wez php . net suggested)? or
    better yet make the emulation default?

    ------------------------------------------------------------------------

    [2006-05-07 01:00:00] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/35793[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=35793&edit=1[/url]
    richard at phase dot org Guest

  4. #4

    Default #35793 [Com]: General error: 2050

    ID: 35793
    Comment by: arnaud dot lb at gmail dot com
    Reported By: deadman_great at mail dot ru
    Status: No Feedback
    Bug Type: PDO related
    Operating System: RH Fedora Core 2
    PHP Version: 5CVS-2005-12-25 (snap)
    Assigned To: Wez
    New Comment:

    I have the same problem with php-5.2, mysql-5.0.26 on
    Debian system.

    Fixed the problem using the
    PDO::MYSQL_ATTR_USE_BUFFERED_QUERY option.

    It seems that closeCursor() does not works properly.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-01 15:11:55] richard at phase dot org

    $this->pdo->setAttribute(PDO::ATTR_EMULATE_PREPARES, true);

    (a suggested fix above) fails on 5.2.RC6 as PDO::ATTR_EMULATE_PREPARES
    appears no longer to be defined.

    ------------------------------------------------------------------------

    [2006-10-17 01:15:58] michal dot vrchota at seznam dot cz

    I think I have solved this problem:

    You have to free your PDOStatement instance

    Of course You have to call closeCursor() method to be sure, but if you
    have more queries and still using same identifier ($stmt) you have free
    it by passing NULL value

    Sample:
    $stmt->closeCursor();
    $stmt = NULL;

    // now it works ;)

    ------------------------------------------------------------------------

    [2006-10-16 14:46:09] andiesPostfach at web dot de

    The Problem still exists in PHP 5.2 RC5 !!

    System ist SUSE-Linux 9.3
    MySQL Version 5.0.18

    ------------------------------------------------------------------------

    [2006-08-23 11:14:46] t dot meesters at gmail dot com

    This problem still occurs with:
    PHP-5.1.5
    MySQL-5.0.22
    Linux platform

    Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error
    message remains:

    SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by
    mysql_stmt_close() call

    ------------------------------------------------------------------------

    [2006-08-01 20:52:55] mass at carlsoft dot net

    Can we at least change this error message to be more specific, perhaps
    suggesting to emulate prepares (as wez php . net suggested)? or
    better yet make the emulation default?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/35793[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=35793&edit=1[/url]
    arnaud dot lb at gmail dot com Guest

  5. #5

    Default #35793 [Com]: General error: 2050

    ID: 35793
    Comment by: dennis at inmarket dot lviv dot ua
    Reported By: deadman_great at mail dot ru
    Status: No Feedback
    Bug Type: PDO related
    Operating System: RH Fedora Core 2
    PHP Version: 5CVS-2005-12-25 (snap)
    Assigned To: Wez
    New Comment:

    Remember to have these "fixes" in your code on every connection you
    might have to the same database.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-03 08:53:42] arnaud dot lb at gmail dot com

    I have the same problem with php-5.2, mysql-5.0.26 on
    Debian system.

    Fixed the problem using the
    PDO::MYSQL_ATTR_USE_BUFFERED_QUERY option.

    It seems that closeCursor() does not works properly.

    ------------------------------------------------------------------------

    [2006-11-01 15:11:55] richard at phase dot org

    $this->pdo->setAttribute(PDO::ATTR_EMULATE_PREPARES, true);

    (a suggested fix above) fails on 5.2.RC6 as PDO::ATTR_EMULATE_PREPARES
    appears no longer to be defined.

    ------------------------------------------------------------------------

    [2006-10-17 01:15:58] michal dot vrchota at seznam dot cz

    I think I have solved this problem:

    You have to free your PDOStatement instance

    Of course You have to call closeCursor() method to be sure, but if you
    have more queries and still using same identifier ($stmt) you have free
    it by passing NULL value

    Sample:
    $stmt->closeCursor();
    $stmt = NULL;

    // now it works ;)

    ------------------------------------------------------------------------

    [2006-10-16 14:46:09] andiesPostfach at web dot de

    The Problem still exists in PHP 5.2 RC5 !!

    System ist SUSE-Linux 9.3
    MySQL Version 5.0.18

    ------------------------------------------------------------------------

    [2006-08-23 11:14:46] t dot meesters at gmail dot com

    This problem still occurs with:
    PHP-5.1.5
    MySQL-5.0.22
    Linux platform

    Using PDO::ATTR_EMULATE_PREPARES doesn't resolve the problem, the error
    message remains:

    SQLSTATE[HY000]: General error: 2050 Row retrieval was canceled by
    mysql_stmt_close() call

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/35793[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=35793&edit=1[/url]
    dennis at inmarket dot lviv dot ua Guest

  6. Moderated Post

    Default #35793 [Com]: General error: 2050

    Removed by Administrator
    baptiste Guest
    Moderated Post

  7. Moderated Post

    Default #35793 [Com]: General error: 2050

    Removed by Administrator
    vishalraj82 Guest
    Moderated Post

Similar Threads

  1. general help
    By jonker25 in forum Macromedia Flash Player
    Replies: 0
    Last Post: October 13th, 08:05 PM
  2. Replies: 1
    Last Post: November 5th, 10:08 PM
  3. RealPlayer : General Error
    By mjt in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: September 23rd, 12:52 AM
  4. IIS 5 - General error Unable to open registry key
    By Robert Blakeman in forum ASP Database
    Replies: 1
    Last Post: August 1st, 05:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139