Professional Web Applications Themes

#39448 [NEW]: Maximum execution time exceeded even if is unlimited - PHP Bugs

From: jschwabik at koop dot cz Operating system: CentOS release 4.3 PHP version: 5.2.0 PHP Bug Type: Performance problem Bug description: Maximum execution time exceeded even if is unlimited Description: ------------ I've got script running from linux shell and sometimes it crashes with "Maximum execution time of 30 seconds exceeded in some line" error in the script. The command on which it crashes is unpredictable. The script is runnig sometimes 10 minutes, sometimes 30 minutes and crashes on different lines. (It never runs 30 seconds). I am running it from command line (CLI) (max_execution_time should be 0) an I set ...

  1. #1

    Default #39448 [NEW]: Maximum execution time exceeded even if is unlimited

    From: jschwabik at koop dot cz
    Operating system: CentOS release 4.3
    PHP version: 5.2.0
    PHP Bug Type: Performance problem
    Bug description: Maximum execution time exceeded even if is unlimited

    Description:
    ------------
    I've got script running from linux shell and sometimes it crashes with
    "Maximum execution time of 30 seconds exceeded in some line" error in the
    script.

    The command on which it crashes is unpredictable. The script is runnig
    sometimes 10 minutes, sometimes 30 minutes and crashes on different lines.
    (It never runs 30 seconds).

    I am running it from command line (CLI) (max_execution_time should be 0)
    an I set it with set_time_limit(0) to 0.

    I've tried two servers 4 php versions (4.4.2, 4.4.4,5.1.6,5.2.0)

    In my php.ini is max_execution_time set to 0.

    Sometimes it ends on ifx_fetch_row().
    Sometimes it ends on mktime().

    My configure
    './configure' '--with-config-file-path=/etc/php.ini'
    '--with-apache=../apache_1.3.37/' '--with-informix=/opt/informix'
    '--with-mysql=/usr/local/mysql/' '--enable-ftp' '--with-gd'
    '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-zlib'
    '--with-jpeg-dir=/usr/' '--with-freetype-dir=/usr' '--with-dom=./ext'
    '--with-ldap' '--with-mssql=/usr/local/' '--enable-dbase'
    '--with-iconv=/usr/local'


    PHP Core Info
    ..
    ..
    ..
    max_execution_time => 0 => 30
    max_input_time => -1 => 60
    open_basedir => no value => no value
    output_buffering => 0 => no value
    output_handler => no value => no value
    post_max_size => 8M => 8M
    precision => 12 => 12
    safe_mode => Off => Off
    ..
    ..
    ..

    Reproduce code:
    ---------------
    <?
    set_time_limit(0);

    //connection to MYsql database
    //connection to Informix database

    //running Informix query (10 queries)


    //doing some transformations and inserting into MYsql database (multiple
    insert every 100 rows)

    echo "End";


    ?>




    Expected result:
    ----------------
    "End" is echoed or some meaningful error message.

    Actual result:
    --------------
    Fatal error:Maximum execution time of 30 seconds exceeded in ...

    --
    Edit bug report at [url]http://bugs.php.net/?id=39448&edit=1[/url]
    --
    Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39448&r=trysnapshot44[/url]
    Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39448&r=trysnapshot52[/url]
    Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=39448&r=trysnapshot60[/url]
    Fixed in CVS: [url]http://bugs.php.net/fix.php?id=39448&r=fixedcvs[/url]
    Fixed in release: [url]http://bugs.php.net/fix.php?id=39448&r=alreadyfixed[/url]
    Need backtrace: [url]http://bugs.php.net/fix.php?id=39448&r=needtrace[/url]
    Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=39448&r=needscript[/url]
    Try newer version: [url]http://bugs.php.net/fix.php?id=39448&r=oldversion[/url]
    Not developer issue: [url]http://bugs.php.net/fix.php?id=39448&r=support[/url]
    Expected behavior: [url]http://bugs.php.net/fix.php?id=39448&r=notwrong[/url]
    Not enough info: [url]http://bugs.php.net/fix.php?id=39448&r=notenoughinfo[/url]
    Submitted twice: [url]http://bugs.php.net/fix.php?id=39448&r=submittedtwice[/url]
    register_globals: [url]http://bugs.php.net/fix.php?id=39448&r=globals[/url]
    PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=39448&r=php3[/url]
    Daylight Savings: [url]http://bugs.php.net/fix.php?id=39448&r=dst[/url]
    IIS Stability: [url]http://bugs.php.net/fix.php?id=39448&r=isapi[/url]
    Install GNU Sed: [url]http://bugs.php.net/fix.php?id=39448&r=gnused[/url]
    Floating point limitations: [url]http://bugs.php.net/fix.php?id=39448&r=float[/url]
    No Zend Extensions: [url]http://bugs.php.net/fix.php?id=39448&r=nozend[/url]
    MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=39448&r=mysqlcfg[/url]
    jschwabik at koop dot cz Guest

  2. #2

    Default #39448 [Opn->Fbk]: Maximum execution time exceeded even if is unlimited

    ID: 39448
    Updated by: [email]tony2001php.net[/email]
    Reported By: jschwabik at koop dot cz
    -Status: Open
    +Status: Feedback
    Bug Type: Performance problem
    Operating System: CentOS release 4.3
    PHP Version: 5.2.0
    New Comment:

    Not reproducible.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-09 12:39:24] jschwabik at koop dot cz

    Description:
    ------------
    I've got script running from linux shell and sometimes it crashes with
    "Maximum execution time of 30 seconds exceeded in some line" error in
    the script.

    The command on which it crashes is unpredictable. The script is runnig
    sometimes 10 minutes, sometimes 30 minutes and crashes on different
    lines. (It never runs 30 seconds).

    I am running it from command line (CLI) (max_execution_time should be
    0) an I set it with set_time_limit(0) to 0.

    I've tried two servers 4 php versions (4.4.2, 4.4.4,5.1.6,5.2.0)

    In my php.ini is max_execution_time set to 0.

    Sometimes it ends on ifx_fetch_row().
    Sometimes it ends on mktime().

    My configure
    './configure' '--with-config-file-path=/etc/php.ini'
    '--with-apache=../apache_1.3.37/' '--with-informix=/opt/informix'
    '--with-mysql=/usr/local/mysql/' '--enable-ftp' '--with-gd'
    '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-zlib'
    '--with-jpeg-dir=/usr/' '--with-freetype-dir=/usr' '--with-dom=./ext'
    '--with-ldap' '--with-mssql=/usr/local/' '--enable-dbase'
    '--with-iconv=/usr/local'


    PHP Core Info
    ..
    ..
    ..
    max_execution_time => 0 => 30
    max_input_time => -1 => 60
    open_basedir => no value => no value
    output_buffering => 0 => no value
    output_handler => no value => no value
    post_max_size => 8M => 8M
    precision => 12 => 12
    safe_mode => Off => Off
    ..
    ..
    ..

    Reproduce code:
    ---------------
    <?
    set_time_limit(0);

    //connection to MYsql database
    //connection to Informix database

    //running Informix query (10 queries)


    //doing some transformations and inserting into MYsql database
    (multiple insert every 100 rows)

    echo "End";


    ?>




    Expected result:
    ----------------
    "End" is echoed or some meaningful error message.

    Actual result:
    --------------
    Fatal error:Maximum execution time of 30 seconds exceeded in ...


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39448&edit=1[/url]
    tony2001@php.net Guest

  3. #3

    Default #39448 [Com]: Maximum execution time exceeded even if is unlimited

    ID: 39448
    Comment by: christoph at ziegenberg dot de
    Reported By: jschwabik at koop dot cz
    Status: Feedback
    Bug Type: Performance problem
    Operating System: CentOS release 4.3
    PHP Version: 5.2.0
    New Comment:

    Perhaps this has to do with the problem in Bug #39361, where ini
    settings which are valid for a directory only are still active when
    leaving the directory (although ini_get() returns the correct value).

    I tested some settings and they worked, so I though this problem is a
    mbstring problem - but it possibly occurs also with other ini
    settings...


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-09 17:10:02] [email]tony2001php.net[/email]

    Not reproducible.

    ------------------------------------------------------------------------

    [2006-11-09 12:39:24] jschwabik at koop dot cz

    Description:
    ------------
    I've got script running from linux shell and sometimes it crashes with
    "Maximum execution time of 30 seconds exceeded in some line" error in
    the script.

    The command on which it crashes is unpredictable. The script is runnig
    sometimes 10 minutes, sometimes 30 minutes and crashes on different
    lines. (It never runs 30 seconds).

    I am running it from command line (CLI) (max_execution_time should be
    0) an I set it with set_time_limit(0) to 0.

    I've tried two servers 4 php versions (4.4.2, 4.4.4,5.1.6,5.2.0)

    In my php.ini is max_execution_time set to 0.

    Sometimes it ends on ifx_fetch_row().
    Sometimes it ends on mktime().

    My configure
    './configure' '--with-config-file-path=/etc/php.ini'
    '--with-apache=../apache_1.3.37/' '--with-informix=/opt/informix'
    '--with-mysql=/usr/local/mysql/' '--enable-ftp' '--with-gd'
    '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-zlib'
    '--with-jpeg-dir=/usr/' '--with-freetype-dir=/usr' '--with-dom=./ext'
    '--with-ldap' '--with-mssql=/usr/local/' '--enable-dbase'
    '--with-iconv=/usr/local'


    PHP Core Info
    ..
    ..
    ..
    max_execution_time => 0 => 30
    max_input_time => -1 => 60
    open_basedir => no value => no value
    output_buffering => 0 => no value
    output_handler => no value => no value
    post_max_size => 8M => 8M
    precision => 12 => 12
    safe_mode => Off => Off
    ..
    ..
    ..

    Reproduce code:
    ---------------
    <?
    set_time_limit(0);

    //connection to MYsql database
    //connection to Informix database

    //running Informix query (10 queries)


    //doing some transformations and inserting into MYsql database
    (multiple insert every 100 rows)

    echo "End";


    ?>




    Expected result:
    ----------------
    "End" is echoed or some meaningful error message.

    Actual result:
    --------------
    Fatal error:Maximum execution time of 30 seconds exceeded in ...


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39448&edit=1[/url]
    christoph at ziegenberg dot de Guest

  4. #4

    Default #39448 [Com]: Maximum execution time exceeded even if is unlimited

    ID: 39448
    Comment by: quentinjs at gmail dot dom
    Reported By: jschwabik at koop dot cz
    Status: No Feedback
    Bug Type: Performance problem
    Operating System: CentOS release 4.3
    PHP Version: 5.2.0
    New Comment:

    I'm using IIS, MySQL, and PHP 5.1.1. This problem starting happening
    randomly within the code, and there doesn't seem to be a reason for it
    other then it seems to be related to MySQL calls... but I haven't
    taken the time yet to test that theory. Its also is random which makes
    it VERY hard to create a reproducable version.

    I'll be upgrading PHP and MySQL tonight and will then spend some time
    building a test case to reproduce this problem as its becoming more
    frequent as of late.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-11-17 01:00:01] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    [2006-11-10 19:29:35] christoph at ziegenberg dot de

    Perhaps this has to do with the problem in Bug #39361, where ini
    settings which are valid for a directory only are still active when
    leaving the directory (although ini_get() returns the correct value).

    I tested some settings and they worked, so I though this problem is a
    mbstring problem - but it possibly occurs also with other ini
    settings...

    ------------------------------------------------------------------------

    [2006-11-09 17:10:02] [email]tony2001php.net[/email]

    Not reproducible.

    ------------------------------------------------------------------------

    [2006-11-09 12:39:24] jschwabik at koop dot cz

    Description:
    ------------
    I've got script running from linux shell and sometimes it crashes with
    "Maximum execution time of 30 seconds exceeded in some line" error in
    the script.

    The command on which it crashes is unpredictable. The script is runnig
    sometimes 10 minutes, sometimes 30 minutes and crashes on different
    lines. (It never runs 30 seconds).

    I am running it from command line (CLI) (max_execution_time should be
    0) an I set it with set_time_limit(0) to 0.

    I've tried two servers 4 php versions (4.4.2, 4.4.4,5.1.6,5.2.0)

    In my php.ini is max_execution_time set to 0.

    Sometimes it ends on ifx_fetch_row().
    Sometimes it ends on mktime().

    My configure
    './configure' '--with-config-file-path=/etc/php.ini'
    '--with-apache=../apache_1.3.37/' '--with-informix=/opt/informix'
    '--with-mysql=/usr/local/mysql/' '--enable-ftp' '--with-gd'
    '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-zlib'
    '--with-jpeg-dir=/usr/' '--with-freetype-dir=/usr' '--with-dom=./ext'
    '--with-ldap' '--with-mssql=/usr/local/' '--enable-dbase'
    '--with-iconv=/usr/local'


    PHP Core Info
    ..
    ..
    ..
    max_execution_time => 0 => 30
    max_input_time => -1 => 60
    open_basedir => no value => no value
    output_buffering => 0 => no value
    output_handler => no value => no value
    post_max_size => 8M => 8M
    precision => 12 => 12
    safe_mode => Off => Off
    ..
    ..
    ..

    Reproduce code:
    ---------------
    <?
    set_time_limit(0);

    //connection to MYsql database
    //connection to Informix database

    //running Informix query (10 queries)


    //doing some transformations and inserting into MYsql database
    (multiple insert every 100 rows)

    echo "End";


    ?>




    Expected result:
    ----------------
    "End" is echoed or some meaningful error message.

    Actual result:
    --------------
    Fatal error:Maximum execution time of 30 seconds exceeded in ...


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39448&edit=1[/url]
    quentinjs at gmail dot dom Guest

Similar Threads

  1. maximum execution time exceeded errors
    By Jeremy Watts in forum PHP Development
    Replies: 1
    Last Post: June 14th, 01:59 PM
  2. Maximum Execution Time Exceeded...
    By Olivier Bellemare in forum PHP Development
    Replies: 4
    Last Post: March 7th, 11:59 PM
  3. #25150 [Fbk->NoF]: Maximum execution time of 30 seconds exceeded
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: August 26th, 05:59 AM
  4. #25150 [Opn->Fbk]: Maximum execution time of 30 seconds exceeded
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: August 20th, 01:37 AM
  5. #25150 [NEW]: Maximum execution time of 30 seconds exceeded
    By alain at antinea dot org in forum PHP Development
    Replies: 0
    Last Post: August 19th, 04:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139