From: paolo dot sfredda at aruba dot it
Operating system: Windows XP
PHP version: 4.4.4
PHP Bug Type: Apache2 related
Bug description: Apache 2.2.2 and PHP 4.4.x as module don't work together

Description:
------------
My configuration:
OS: Windows XP Pro
Apache: 2.2
PHP: 4.4.4 and/or several patches (stable, cvs, latest and so on)

Problem: the Loadmodule command in http.conf get a sintax error due to it
can't find the dll.

I need to use THIS VERSION of PHP because my internet provider use that.
So i need to reproduce an exact local test environment.

I read in this site that the problem is many times reported but you don't
have a resolutive answer.

Reproduce code:
---------------
As written in your install.txt, in my http.conf:
LoadModule php4_module "C:/Programmi/PHP/php4apache2.dll"
ScriptAlias /php/ "C:/Programmi/PHP/"
AddType application/x-httpd-php .php
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4


Expected result:
----------------
Using PHP 4.4.4 (NOT AN ANOTHER VERSION!!!) as a module with Apache 2.2

Actual result:
--------------
Sintax error at the line where placed Loadmodule statement becouse it
cant'find the dll file

--
Edit bug report at [url]http://bugs.php.net/?id=39586&edit=1[/url]
--
Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39586&r=trysnapshot44[/url]
Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39586&r=trysnapshot52[/url]
Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=39586&r=trysnapshot60[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=39586&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=39586&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=39586&r=needtrace[/url]
Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=39586&r=needscript[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=39586&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=39586&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=39586&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=39586&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=39586&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=39586&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=39586&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=39586&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=39586&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=39586&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=39586&r=float[/url]
No Zend Extensions: [url]http://bugs.php.net/fix.php?id=39586&r=nozend[/url]
MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=39586&r=mysqlcfg[/url]