Professional Web Applications Themes

#39722 [NEW]: PHP-CGI process stalls - PHP Bugs

From: shri_phadte at yahoo dot co dot in Operating system: Windows XP PHP version: 5.2.0 PHP Bug Type: Date/time related Bug description: PHP-CGI process stalls Description: ------------ When i call strtotime(...) continuously in a loop with parameter undefined the PHP-CGI process stalls and needs to be stopped manually Reproduce code: --------------- for($i=0;$i<20;$i++) strtotime($UndefinedVariable); Expected result: ---------------- should throw 20 Warnings Actual result: -------------- PHP-CGI process Stalls On approx 13th itration of for loop -- Edit bug report at [url]http://bugs.php.net/?id=39722&edit=1[/url] -- Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39722&r=trysnapshot44[/url] Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39722&r=trysnapshot52[/url] Try a CVS snapshot (PHP 6.0): ...

  1. #1

    Default #39722 [NEW]: PHP-CGI process stalls

    From: shri_phadte at yahoo dot co dot in
    Operating system: Windows XP
    PHP version: 5.2.0
    PHP Bug Type: Date/time related
    Bug description: PHP-CGI process stalls

    Description:
    ------------
    When i call strtotime(...) continuously in a loop with parameter undefined
    the PHP-CGI process stalls and needs to be stopped manually

    Reproduce code:
    ---------------
    for($i=0;$i<20;$i++)
    strtotime($UndefinedVariable);

    Expected result:
    ----------------
    should throw 20 Warnings

    Actual result:
    --------------
    PHP-CGI process Stalls On approx 13th itration of for loop

    --
    Edit bug report at [url]http://bugs.php.net/?id=39722&edit=1[/url]
    --
    Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39722&r=trysnapshot44[/url]
    Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39722&r=trysnapshot52[/url]
    Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=39722&r=trysnapshot60[/url]
    Fixed in CVS: [url]http://bugs.php.net/fix.php?id=39722&r=fixedcvs[/url]
    Fixed in release: [url]http://bugs.php.net/fix.php?id=39722&r=alreadyfixed[/url]
    Need backtrace: [url]http://bugs.php.net/fix.php?id=39722&r=needtrace[/url]
    Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=39722&r=needscript[/url]
    Try newer version: [url]http://bugs.php.net/fix.php?id=39722&r=oldversion[/url]
    Not developer issue: [url]http://bugs.php.net/fix.php?id=39722&r=support[/url]
    Expected behavior: [url]http://bugs.php.net/fix.php?id=39722&r=notwrong[/url]
    Not enough info: [url]http://bugs.php.net/fix.php?id=39722&r=notenoughinfo[/url]
    Submitted twice: [url]http://bugs.php.net/fix.php?id=39722&r=submittedtwice[/url]
    register_globals: [url]http://bugs.php.net/fix.php?id=39722&r=globals[/url]
    PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=39722&r=php3[/url]
    Daylight Savings: [url]http://bugs.php.net/fix.php?id=39722&r=dst[/url]
    IIS Stability: [url]http://bugs.php.net/fix.php?id=39722&r=isapi[/url]
    Install GNU Sed: [url]http://bugs.php.net/fix.php?id=39722&r=gnused[/url]
    Floating point limitations: [url]http://bugs.php.net/fix.php?id=39722&r=float[/url]
    No Zend Extensions: [url]http://bugs.php.net/fix.php?id=39722&r=nozend[/url]
    MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=39722&r=mysqlcfg[/url]
    shri_phadte at yahoo dot co dot in Guest

  2. #2

    Default #39722 [Opn->Fbk]: PHP-CGI process stalls

    ID: 39722
    Updated by: [email]tony2001php.net[/email]
    Reported By: shri_phadte at yahoo dot co dot in
    -Status: Open
    +Status: Feedback
    Bug Type: Date/time related
    Operating System: Windows XP
    PHP Version: 5.2.0
    New Comment:

    Cannot reproduce.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-04 03:58:23] shri_phadte at yahoo dot co dot in

    Description:
    ------------
    When i call strtotime(...) continuously in a loop with parameter
    undefined the PHP-CGI process stalls and needs to be stopped manually

    Reproduce code:
    ---------------
    for($i=0;$i<20;$i++)
    strtotime($UndefinedVariable);

    Expected result:
    ----------------
    should throw 20 Warnings

    Actual result:
    --------------
    PHP-CGI process Stalls On approx 13th itration of for loop


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39722&edit=1[/url]
    tony2001@php.net Guest

  3. #3

    Default #39722 [Fbk->Opn]: PHP-CGI process stalls

    ID: 39722
    User updated by: shri_phadte at yahoo dot co dot in
    Reported By: shri_phadte at yahoo dot co dot in
    -Status: Feedback
    +Status: Open
    Bug Type: Date/time related
    Operating System: Windows XP
    -PHP Version: 5.2.0
    +PHP Version: 5.0.2
    New Comment:

    The correct PHP version which i found this problem is 5.0.2 running on
    an old version of Apache. I Upgraded them to the latest version and it
    is working fine.You can close the bug or if u want to address this bug
    and need more details please let me know


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-04 10:51:41] [email]tony2001php.net[/email]

    Cannot reproduce.

    ------------------------------------------------------------------------

    [2006-12-04 03:58:23] shri_phadte at yahoo dot co dot in

    Description:
    ------------
    When i call strtotime(...) continuously in a loop with parameter
    undefined the PHP-CGI process stalls and needs to be stopped manually

    Reproduce code:
    ---------------
    for($i=0;$i<20;$i++)
    strtotime($UndefinedVariable);

    Expected result:
    ----------------
    should throw 20 Warnings

    Actual result:
    --------------
    PHP-CGI process Stalls On approx 13th itration of for loop


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39722&edit=1[/url]
    shri_phadte at yahoo dot co dot in Guest

  4. #4

    Default #39722 [Opn->Csd]: PHP-CGI process stalls

    ID: 39722
    Updated by: [email]tony2001php.net[/email]
    Reported By: shri_phadte at yahoo dot co dot in
    -Status: Open
    +Status: Closed
    Bug Type: Date/time related
    Operating System: Windows XP
    PHP Version: 5.0.2
    New Comment:

    Latest version works fine -> closed.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-05 08:27:18] shri_phadte at yahoo dot co dot in

    The correct PHP version which i found this problem is 5.0.2 running on
    an old version of Apache. I Upgraded them to the latest version and it
    is working fine.You can close the bug or if u want to address this bug
    and need more details please let me know

    ------------------------------------------------------------------------

    [2006-12-04 10:51:41] [email]tony2001php.net[/email]

    Cannot reproduce.

    ------------------------------------------------------------------------

    [2006-12-04 03:58:23] shri_phadte at yahoo dot co dot in

    Description:
    ------------
    When i call strtotime(...) continuously in a loop with parameter
    undefined the PHP-CGI process stalls and needs to be stopped manually

    Reproduce code:
    ---------------
    for($i=0;$i<20;$i++)
    strtotime($UndefinedVariable);

    Expected result:
    ----------------
    should throw 20 Warnings

    Actual result:
    --------------
    PHP-CGI process Stalls On approx 13th itration of for loop


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39722&edit=1[/url]
    tony2001@php.net Guest

Similar Threads

  1. XML connector stalls
    By metStevo in forum Macromedia Flash Data Integration
    Replies: 0
    Last Post: October 10th, 07:11 PM
  2. Shockwave stalls on One site only.
    By Xela1 in forum Macromedia Shockwave
    Replies: 2
    Last Post: August 2nd, 05:16 PM
  3. web page stalls after macromedia logo
    By taheal in forum Macromedia Director Basics
    Replies: 0
    Last Post: November 29th, 06:24 AM
  4. #23502 [Com]: compiler stalls
    By christophe dot godard at alcatel dot fr in forum PHP Development
    Replies: 0
    Last Post: November 17th, 08:19 AM
  5. PS7 stalls/hangs when getting blend menu
    By Sean Condon in forum Adobe Photoshop 7, CS, CS2 & CS3
    Replies: 2
    Last Post: July 11th, 12:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139