Professional Web Applications Themes

#39833 [NEW]: Session variables overwritten by local variables (register_globals=off) - PHP Bugs

From: sup1382 at accedo dot es Operating system: OpenBSD 3.9 PHP version: 5.2.0 PHP Bug Type: Session related Bug description: Session variables overwritten by local variables (register_globals=off) Description: ------------ Session variables are being overwritten by local variables with everything (that I've checked) set as default, register_globals=off, bug_compat_42=off, etc. In my workstation (Fedora Core 5), I get the correct output. (Surprisingly first time I execute the script in the OpenBSD box I get the correct output. Then always the buggie one). This are the options used in 'configure': --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx --enable-cli --with-gettext=/usr/local/base/ --enable-dio --with-pear=/usr/share/pear --enable-bcmath --enable-session --enable-trans-sid --enable-calendar --enable-ctype ...

  1. #1

    Default #39833 [NEW]: Session variables overwritten by local variables (register_globals=off)

    From: sup1382 at accedo dot es
    Operating system: OpenBSD 3.9
    PHP version: 5.2.0
    PHP Bug Type: Session related
    Bug description: Session variables overwritten by local variables (register_globals=off)

    Description:
    ------------
    Session variables are being overwritten by local variables with everything
    (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested with
    5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''


    --
    Edit bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    --
    Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39833&r=trysnapshot44[/url]
    Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39833&r=trysnapshot52[/url]
    Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=39833&r=trysnapshot60[/url]
    Fixed in CVS: [url]http://bugs.php.net/fix.php?id=39833&r=fixedcvs[/url]
    Fixed in release: [url]http://bugs.php.net/fix.php?id=39833&r=alreadyfixed[/url]
    Need backtrace: [url]http://bugs.php.net/fix.php?id=39833&r=needtrace[/url]
    Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=39833&r=needscript[/url]
    Try newer version: [url]http://bugs.php.net/fix.php?id=39833&r=oldversion[/url]
    Not developer issue: [url]http://bugs.php.net/fix.php?id=39833&r=support[/url]
    Expected behavior: [url]http://bugs.php.net/fix.php?id=39833&r=notwrong[/url]
    Not enough info: [url]http://bugs.php.net/fix.php?id=39833&r=notenoughinfo[/url]
    Submitted twice: [url]http://bugs.php.net/fix.php?id=39833&r=submittedtwice[/url]
    register_globals: [url]http://bugs.php.net/fix.php?id=39833&r=globals[/url]
    PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=39833&r=php3[/url]
    Daylight Savings: [url]http://bugs.php.net/fix.php?id=39833&r=dst[/url]
    IIS Stability: [url]http://bugs.php.net/fix.php?id=39833&r=isapi[/url]
    Install GNU Sed: [url]http://bugs.php.net/fix.php?id=39833&r=gnused[/url]
    Floating point limitations: [url]http://bugs.php.net/fix.php?id=39833&r=float[/url]
    No Zend Extensions: [url]http://bugs.php.net/fix.php?id=39833&r=nozend[/url]
    MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=39833&r=mysqlcfg[/url]
    sup1382 at accedo dot es Guest

  2. #2

    Default #39833 [Com]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    Comment by: judas dot iscariote at gmail dot com
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    works as expected here, are you sure register_globals is disabled ?


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-14 14:33:14] sup1382 at accedo dot es

    Description:
    ------------
    Session variables are being overwritten by local variables with
    everything (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested
    with 5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    judas dot iscariote at gmail dot com Guest

  3. #3

    Default #39833 [Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-14 19:14:31] judas dot iscariote at gmail dot com

    works as expected here, are you sure register_globals is disabled ?

    ------------------------------------------------------------------------

    [2006-12-14 14:33:14] sup1382 at accedo dot es

    Description:
    ------------
    Session variables are being overwritten by local variables with
    everything (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested
    with 5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  4. #4

    Default #39833 [Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-14 22:48:10] sup1382 at accedo dot es

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.

    ------------------------------------------------------------------------

    [2006-12-14 19:14:31] judas dot iscariote at gmail dot com

    works as expected here, are you sure register_globals is disabled ?

    ------------------------------------------------------------------------

    [2006-12-14 14:33:14] sup1382 at accedo dot es

    Description:
    ------------
    Session variables are being overwritten by local variables with
    everything (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested
    with 5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  5. #5

    Default #39833 [Opn->Fbk]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    Updated by: [email]tony2001php.net[/email]
    Reported By: sup1382 at accedo dot es
    -Status: Open
    +Status: Feedback
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    Add phpinfo() to end of this code and put the URL here.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-14 23:07:53] sup1382 at accedo dot es

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)

    ------------------------------------------------------------------------

    [2006-12-14 22:48:10] sup1382 at accedo dot es

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.

    ------------------------------------------------------------------------

    [2006-12-14 19:14:31] judas dot iscariote at gmail dot com

    works as expected here, are you sure register_globals is disabled ?

    ------------------------------------------------------------------------

    [2006-12-14 14:33:14] sup1382 at accedo dot es

    Description:
    ------------
    Session variables are being overwritten by local variables with
    everything (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested
    with 5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    tony2001@php.net Guest

  6. #6

    Default #39833 [Fbk->Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    -Status: Feedback
    +Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-15 09:55:29] [email]tony2001php.net[/email]

    Add phpinfo() to end of this code and put the URL here.

    ------------------------------------------------------------------------

    [2006-12-14 23:07:53] sup1382 at accedo dot es

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)

    ------------------------------------------------------------------------

    [2006-12-14 22:48:10] sup1382 at accedo dot es

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.

    ------------------------------------------------------------------------

    [2006-12-14 19:14:31] judas dot iscariote at gmail dot com

    works as expected here, are you sure register_globals is disabled ?

    ------------------------------------------------------------------------

    [2006-12-14 14:33:14] sup1382 at accedo dot es

    Description:
    ------------
    Session variables are being overwritten by local variables with
    everything (that I've checked) set as default, register_globals=off,
    bug_compat_42=off, etc.

    In my workstation (Fedora Core 5), I get the correct output.

    (Surprisingly first time I execute the script in the OpenBSD box I get
    the correct output. Then always the buggie one).

    This are the options used in 'configure':

    --with-apxs=/usr/sbin/apxs --without-mysql --enable-xml --enable-wddx
    --enable-cli --with-gettext=/usr/local/base/ --enable-dio
    --with-pear=/usr/share/pear --enable-bcmath --enable-session
    --enable-trans-sid --enable-calendar --enable-ctype --enable-ftp
    --with-pcre-regex --with-posix --enable-sockets --enable-sysvsem
    --enable-sysvshm --enable-yp --enable-exif --without-sqlite

    (Copied from the OpenBSD ports, the same problem applies also to the
    packaged version in OpenBSD 3.9, PHP 5.05, I've recompiled and tested
    with 5.2 to check if the problem continues, and it does).





    Reproduce code:
    ---------------
    <?php

    session_start();
    $_SESSION["test"] = "test";
    $test = null;
    print("<br>Local var test: '".$test."'");
    print("<br>Session var test: '".$_SESSION["test"]."'");

    ?>



    Expected result:
    ----------------
    Local var test: ''
    Session var test: 'test'


    Actual result:
    --------------
    Local var test: ''
    Session var test: ''



    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  7. #7

    Default #39833 [Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-15 11:10:54] sup1382 at accedo dot es

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url

    ------------------------------------------------------------------------

    [2006-12-15 09:55:29] [email]tony2001php.net[/email]

    Add phpinfo() to end of this code and put the URL here.

    ------------------------------------------------------------------------

    [2006-12-14 23:07:53] sup1382 at accedo dot es

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)

    ------------------------------------------------------------------------

    [2006-12-14 22:48:10] sup1382 at accedo dot es

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.

    ------------------------------------------------------------------------

    [2006-12-14 19:14:31] judas dot iscariote at gmail dot com

    works as expected here, are you sure register_globals is disabled ?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  8. #8

    Default #39833 [Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    Updated by: [email]tony2001php.net[/email]
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    I am currently away from my computer and don't have access to my
    mailbox.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-15 11:31:43] sup1382 at accedo dot es

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.

    ------------------------------------------------------------------------

    [2006-12-15 11:10:54] sup1382 at accedo dot es

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url

    ------------------------------------------------------------------------

    [2006-12-15 09:55:29] [email]tony2001php.net[/email]

    Add phpinfo() to end of this code and put the URL here.

    ------------------------------------------------------------------------

    [2006-12-14 23:07:53] sup1382 at accedo dot es

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)

    ------------------------------------------------------------------------

    [2006-12-14 22:48:10] sup1382 at accedo dot es

    Yes, absolutely. The most strange behavior, is that first output is ok,
    then always the bad one.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    tony2001@php.net Guest

  9. #9

    Default #39833 [Opn]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-15 11:46:31] [email]tony2001php.net[/email]

    I am currently away from my computer and don't have access to my
    mailbox.

    ------------------------------------------------------------------------

    [2006-12-15 11:31:43] sup1382 at accedo dot es

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.

    ------------------------------------------------------------------------

    [2006-12-15 11:10:54] sup1382 at accedo dot es

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url

    ------------------------------------------------------------------------

    [2006-12-15 09:55:29] [email]tony2001php.net[/email]

    Add phpinfo() to end of this code and put the URL here.

    ------------------------------------------------------------------------

    [2006-12-14 23:07:53] sup1382 at accedo dot es

    BTW, in my parameters of 'config' there was one directory wrong
    --with-gettext=/usr/local/base/ is really
    --with-gettext=/usr/local/bin/

    I've made a symlink to avoid this, but I believe this problem has
    nothing to do with gettext (same result anyway)

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  10. #10

    Default #39833 [Opn->Fbk]: Session variables overwritten by local variables (register_globals=off)

    ID: 39833
    Updated by: [email]tony2001php.net[/email]
    Reported By: sup1382 at accedo dot es
    -Status: Open
    +Status: Feedback
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    ..


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-15 11:49:47] sup1382 at accedo dot es

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.

    ------------------------------------------------------------------------

    [2006-12-15 11:46:31] [email]tony2001php.net[/email]

    I am currently away from my computer and don't have access to my
    mailbox.

    ------------------------------------------------------------------------

    [2006-12-15 11:31:43] sup1382 at accedo dot es

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.

    ------------------------------------------------------------------------

    [2006-12-15 11:10:54] sup1382 at accedo dot es

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url

    ------------------------------------------------------------------------

    [2006-12-15 09:55:29] [email]tony2001php.net[/email]

    Add phpinfo() to end of this code and put the URL here.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    tony2001@php.net Guest

  11. #11

    Default #39833 [Fbk->Opn]: Session variables overwritten by local variables (SSL, register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    -Summary: Session variables overwritten by local variables
    (register_globals=off)
    Reported By: sup1382 at accedo dot es
    -Status: Feedback
    +Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    ..


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-18 10:53:01] [email]tony2001php.net[/email]

    ..

    ------------------------------------------------------------------------

    [2006-12-15 11:49:47] sup1382 at accedo dot es

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.

    ------------------------------------------------------------------------

    [2006-12-15 11:46:31] [email]tony2001php.net[/email]

    I am currently away from my computer and don't have access to my
    mailbox.

    ------------------------------------------------------------------------

    [2006-12-15 11:31:43] sup1382 at accedo dot es

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.

    ------------------------------------------------------------------------

    [2006-12-15 11:10:54] sup1382 at accedo dot es

    Ups, this is a hosting production server I prefer, too much server info
    to disclose it to the public, if it is posible I'll send you by mail the
    url

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  12. #12

    Default #39833 [Opn]: Session variables overwritten by local variables (SSL, register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    Status: Open
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    I've checked that in a SSL connection, register_globals always is being
    "on" (yet in 5.2 version), php.ini is right pd, and there
    register_globals is off, I know it because several personalized vars
    are ok (include_path, etc), but register_globals always stay true, no
    matter what I put in php.ini, or httpd.conf (php_flag register_globals
    off, etc). No problems in normal transmision (port 80). Seems to be a
    very big problem for only being suffered by me. Anybody using SSL with
    register_globals=off out there without problems?


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-19 10:14:07] sup1382 at accedo dot es

    ..

    ------------------------------------------------------------------------

    [2006-12-18 10:53:01] [email]tony2001php.net[/email]

    ..

    ------------------------------------------------------------------------

    [2006-12-15 11:49:47] sup1382 at accedo dot es

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.

    ------------------------------------------------------------------------

    [2006-12-15 11:46:31] [email]tony2001php.net[/email]

    I am currently away from my computer and don't have access to my
    mailbox.

    ------------------------------------------------------------------------

    [2006-12-15 11:31:43] sup1382 at accedo dot es

    I've send you by mail the URLs, I've forgotten to write here that this
    script was running under a SSL connection, this seems to be a important
    fact becouse testing under the standard port doesn't produce any errors,
    this appears only under SSL, as you can see in the URLs.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    sup1382 at accedo dot es Guest

  13. #13

    Default #39833 [Opn->Fbk]: Session variables overwritten by local variables (SSL, register_globals=off)

    ID: 39833
    Updated by: [email]tony2001php.net[/email]
    Reported By: sup1382 at accedo dot es
    -Status: Open
    +Status: Feedback
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    Please make sure you're using right php.ini (the correct one can be
    found in phpinfo()), restarted Apache and did not set register_globals
    in VirtualHost section, htaccess etc. etc.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-19 10:23:08] sup1382 at accedo dot es

    I've checked that in a SSL connection, register_globals always is being
    "on" (yet in 5.2 version), php.ini is right pd, and there
    register_globals is off, I know it because several personalized vars
    are ok (include_path, etc), but register_globals always stay true, no
    matter what I put in php.ini, or httpd.conf (php_flag register_globals
    off, etc). No problems in normal transmision (port 80). Seems to be a
    very big problem for only being suffered by me. Anybody using SSL with
    register_globals=off out there without problems?

    ------------------------------------------------------------------------

    [2006-12-19 10:14:07] sup1382 at accedo dot es

    ..

    ------------------------------------------------------------------------

    [2006-12-18 10:53:01] [email]tony2001php.net[/email]

    ..

    ------------------------------------------------------------------------

    [2006-12-15 11:49:47] sup1382 at accedo dot es

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.

    ------------------------------------------------------------------------

    [2006-12-15 11:46:31] [email]tony2001php.net[/email]

    I am currently away from my computer and don't have access to my
    mailbox.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/39833[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=39833&edit=1[/url]
    tony2001@php.net Guest

  14. #14

    Default #39833 [Fbk->Csd]: Session variables overwritten by local variables (SSL, register_globals=off)

    ID: 39833
    User updated by: sup1382 at accedo dot es
    Reported By: sup1382 at accedo dot es
    -Status: Feedback
    +Status: Closed
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0
    New Comment:

    Ok, now I understand what happened, I had a (%$*"&!!) "php_admin_value
    register_globals on" in the <VirtualHost [ip]> section of the ssl
    subdomain, in httpd.conf, the problem was that version 5.05 don't
    reflected this change [phpinfo() shows register_globals as off, even
    with this line activated in httpd.conf], things get clearer with v.5.2

    Thank you for the support and sorry for the bogus info.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-19 10:29:42] tony2001php.net

    Please make sure you're using right php.ini (the correct one can be
    found in phpinfo()), restarted Apache and did not set register_globals
    in VirtualHost section, htaccess etc. etc.

    ------------------------------------------------------------------------

    [2006-12-19 10:23:08] sup1382 at accedo dot es

    I've checked that in a SSL connection, register_globals always is being
    "on" (yet in 5.2 version), php.ini is right pd, and there
    register_globals is off, I know it because several personalized vars
    are ok (include_path, etc), but register_globals always stay true, no
    matter what I put in php.ini, or httpd.conf (php_flag register_globals
    off, etc). No problems in normal transmision (port 80). Seems to be a
    very big problem for only being suffered by me. Anybody using SSL with
    register_globals=off out there without problems?

    ------------------------------------------------------------------------

    [2006-12-19 10:14:07] sup1382 at accedo dot es

    ..

    ------------------------------------------------------------------------

    [2006-12-18 10:53:01] tony2001php.net

    ..

    ------------------------------------------------------------------------

    [2006-12-15 11:49:47] sup1382 at accedo dot es

    If you have any webmail (Gmail-Hotmail, etc) account I'll send you
    again the URLs, or I'll wait no problem.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/39833

    --
    Edit this bug report at http://bugs.php.net/?id=39833&edit=1
    sup1382 at accedo dot es Guest

  15. #15

    Default #39833 [Csd->Bgs]: Session variables overwritten by local variables (SSL, register_globals=off)

    ID: 39833
    Updated by: [email]tony2001php.net[/email]
    Reported By: sup1382 at accedo dot es
    -Status: Closed
    +Status: Bogus
    Bug Type: Session related
    Operating System: OpenBSD 3.9
    PHP Version: 5.2.0


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-19 11:54:14] sup1382 at accedo dot es

    Ok, now I understand what happened, I had a (%$*"&!!) "php_admin_value
    register_globals on" in the <VirtualHost [ip]> section of the ssl
    subdomain, in httpd.conf, the problem was that version 5.05 don't
    reflected this change [phpinfo() shows register_globals as off, even
    with this line activated in httpd.conf], things get clearer with v.5.2

    Thank you for the support and sorry for the bogus info.

    ------------------------------------------------------------------------

    [2006-12-19 10:29:42] tony2001php.net

    Please make sure you're using right php.ini (the correct one can be
    found in phpinfo()), restarted Apache and did not set register_globals
    in VirtualHost section, htaccess etc. etc.

    ------------------------------------------------------------------------

    [2006-12-19 10:23:08] sup1382 at accedo dot es

    I've checked that in a SSL connection, register_globals always is being
    "on" (yet in 5.2 version), php.ini is right pd, and there
    register_globals is off, I know it because several personalized vars
    are ok (include_path, etc), but register_globals always stay true, no
    matter what I put in php.ini, or httpd.conf (php_flag register_globals
    off, etc). No problems in normal transmision (port 80). Seems to be a
    very big problem for only being suffered by me. Anybody using SSL with
    register_globals=off out there without problems?

    ------------------------------------------------------------------------

    [2006-12-19 10:14:07] sup1382 at accedo dot es

    ..

    ------------------------------------------------------------------------

    [2006-12-18 10:53:01] tony2001php.net

    ..

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/39833

    --
    Edit this bug report at http://bugs.php.net/?id=39833&edit=1
    tony2001@php.net Guest

Similar Threads

  1. Replies: 1
    Last Post: November 11th, 10:35 PM
  2. Variables are overwritten when another person logs in
    By Remco Groot Beumer in forum ASP.NET Building Controls
    Replies: 5
    Last Post: November 5th, 06:44 PM
  3. Replies: 0
    Last Post: July 9th, 03:05 PM
  4. #24562 [Bgs->Opn]: Server variables are invisible with register_globals on
    By sagi at boom dot org dot il in forum PHP Development
    Replies: 0
    Last Post: July 9th, 02:58 PM
  5. Replies: 0
    Last Post: July 9th, 02:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139