Professional Web Applications Themes

#39943 [NEW]: Configure scripts not detecting mysqlclient properly on 64bit - PHP Bugs

From: xachen at mac dot com Operating system: CentOS 4.4 - x86_64 PHP version: 5.2.0 PHP Bug Type: Compile Failure Bug description: Configure scripts not detecting mysqlclient properly on 64bit Description: ------------ When you go to ./configure your installation to work with MySQL and you have the libraries installed under /usr/lib64, as well as the appropriate ldconfig is provided and in place, PHP will still not detect it. This is fixable by going ln -s /usr/lib64/mysql /usr/lib Reproduce code: --------------- ../configure --enable-fastcgi --with-mysql Expected result: ---------------- For MySQL to compile properly. Actual result: -------------- checking for MySQL support... yes checking ...

  1. #1

    Default #39943 [NEW]: Configure scripts not detecting mysqlclient properly on 64bit

    From: xachen at mac dot com
    Operating system: CentOS 4.4 - x86_64
    PHP version: 5.2.0
    PHP Bug Type: Compile Failure
    Bug description: Configure scripts not detecting mysqlclient properly on 64bit

    Description:
    ------------
    When you go to ./configure your installation to work with MySQL and you
    have the libraries installed under /usr/lib64, as well as the appropriate
    ldconfig is provided and in place, PHP will still not detect it.

    This is fixable by going ln -s /usr/lib64/mysql /usr/lib

    Reproduce code:
    ---------------
    ../configure --enable-fastcgi --with-mysql


    Expected result:
    ----------------
    For MySQL to compile properly.

    Actual result:
    --------------
    checking for MySQL support... yes
    checking for specified location of the MySQL UNIX socket... no
    checking for MySQL UNIX socket location... /var/lib/mysql/mysql.sock
    configure: error: Cannot find libmysqlclient under /usr.

    --
    Edit bug report at [url]http://bugs.php.net/?id=39943&edit=1[/url]
    --
    Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=39943&r=trysnapshot44[/url]
    Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=39943&r=trysnapshot52[/url]
    Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=39943&r=trysnapshot60[/url]
    Fixed in CVS: [url]http://bugs.php.net/fix.php?id=39943&r=fixedcvs[/url]
    Fixed in release: [url]http://bugs.php.net/fix.php?id=39943&r=alreadyfixed[/url]
    Need backtrace: [url]http://bugs.php.net/fix.php?id=39943&r=needtrace[/url]
    Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=39943&r=needscript[/url]
    Try newer version: [url]http://bugs.php.net/fix.php?id=39943&r=oldversion[/url]
    Not developer issue: [url]http://bugs.php.net/fix.php?id=39943&r=support[/url]
    Expected behavior: [url]http://bugs.php.net/fix.php?id=39943&r=notwrong[/url]
    Not enough info: [url]http://bugs.php.net/fix.php?id=39943&r=notenoughinfo[/url]
    Submitted twice: [url]http://bugs.php.net/fix.php?id=39943&r=submittedtwice[/url]
    register_globals: [url]http://bugs.php.net/fix.php?id=39943&r=globals[/url]
    PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=39943&r=php3[/url]
    Daylight Savings: [url]http://bugs.php.net/fix.php?id=39943&r=dst[/url]
    IIS Stability: [url]http://bugs.php.net/fix.php?id=39943&r=isapi[/url]
    Install GNU Sed: [url]http://bugs.php.net/fix.php?id=39943&r=gnused[/url]
    Floating point limitations: [url]http://bugs.php.net/fix.php?id=39943&r=float[/url]
    No Zend Extensions: [url]http://bugs.php.net/fix.php?id=39943&r=nozend[/url]
    MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=39943&r=mysqlcfg[/url]
    xachen at mac dot com Guest

  2. #2

    Default #39943 [Com]: Configure scripts not detecting mysqlclient properly on 64bit

    ID: 39943
    Comment by: judas dot iscariote at gmail dot com
    Reported By: xachen at mac dot com
    Status: Open
    Bug Type: Compile Failure
    Operating System: CentOS 4.4 - x86_64
    PHP Version: 5.2.0
    New Comment:

    Bogus ;)

    Use the --with-libdir=lib64 configure flag.


    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-24 20:17:15] xachen at mac dot com

    Description:
    ------------
    When you go to ./configure your installation to work with MySQL and you
    have the libraries installed under /usr/lib64, as well as the
    appropriate ldconfig is provided and in place, PHP will still not
    detect it.

    This is fixable by going ln -s /usr/lib64/mysql /usr/lib

    Reproduce code:
    ---------------
    ../configure --enable-fastcgi --with-mysql


    Expected result:
    ----------------
    For MySQL to compile properly.

    Actual result:
    --------------
    checking for MySQL support... yes
    checking for specified location of the MySQL UNIX socket... no
    checking for MySQL UNIX socket location... /var/lib/mysql/mysql.sock
    configure: error: Cannot find libmysqlclient under /usr.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39943&edit=1[/url]
    judas dot iscariote at gmail dot com Guest

  3. #3

    Default #39943 [Opn->Bgs]: Configure scripts not detecting mysqlclient properly on 64bit

    ID: 39943
    Updated by: [email]edinkphp.net[/email]
    Reported By: xachen at mac dot com
    -Status: Open
    +Status: Bogus
    Bug Type: Compile Failure
    Operating System: CentOS 4.4 - x86_64
    PHP Version: 5.2.0
    New Comment:

    Sorry, but your problem does not imply a bug in PHP itself. For a
    list of more appropriate places to ask for help using PHP, please
    visit [url]http://www.php.net/support.php[/url] as this bug system is not the
    appropriate forum for asking support questions. Due to the volume
    of reports we can not explain in detail here why your report is not
    a bug. The support channels will be able to provide an explanation
    for you.

    Thank you for your interest in PHP.




    Previous Comments:
    ------------------------------------------------------------------------

    [2006-12-24 20:49:36] judas dot iscariote at gmail dot com

    Bogus ;)

    Use the --with-libdir=lib64 configure flag.

    ------------------------------------------------------------------------

    [2006-12-24 20:17:15] xachen at mac dot com

    Description:
    ------------
    When you go to ./configure your installation to work with MySQL and you
    have the libraries installed under /usr/lib64, as well as the
    appropriate ldconfig is provided and in place, PHP will still not
    detect it.

    This is fixable by going ln -s /usr/lib64/mysql /usr/lib

    Reproduce code:
    ---------------
    ../configure --enable-fastcgi --with-mysql


    Expected result:
    ----------------
    For MySQL to compile properly.

    Actual result:
    --------------
    checking for MySQL support... yes
    checking for specified location of the MySQL UNIX socket... no
    checking for MySQL UNIX socket location... /var/lib/mysql/mysql.sock
    configure: error: Cannot find libmysqlclient under /usr.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=39943&edit=1[/url]
    edink@php.net Guest

Similar Threads

  1. #25681 [Opn->WFx]: configure fails detecting libxml2
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: September 28th, 08:14 PM
  2. #25681 [NEW]: configure fails detecting libxml2
    By axel at pearbough dot net in forum PHP Development
    Replies: 0
    Last Post: September 28th, 07:44 PM
  3. Replies: 1
    Last Post: August 2nd, 10:04 AM
  4. #24913 [Opn]: configure doesn't detect C++ compiler properly
    By djain at gmx dot net in forum PHP Development
    Replies: 0
    Last Post: August 2nd, 02:40 AM
  5. configure 802.1x using scripts
    By jin yu in forum Windows Networking
    Replies: 0
    Last Post: July 10th, 06:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139