Professional Web Applications Themes

#40268 [NEW]: PHP make install failed to create - PHP Bugs

From: thomastja at gmail dot com Operating system: Aix 5.3 PHP version: 4.4.4 PHP Bug Type: Compile Failure Bug description: PHP make install failed to create Description: ------------ Any input will be welcome. I am trying to compile PHP in the following env. Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0, libtool 1.5.22 I run the following configure command ../configure --prefix=/fpx/usr/php --with-apxs2=/fpx/usr/apache/bin/apxs --with-config-file-path=/fpx/usr/apache/conf --enable-shared completed successfully. ../make completed successfully ../make install failed with errors Reproduce code: --------------- bash-3.00# make install /fpx/usr/apache/build/instdso.sh SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la /fpx/usr/apache/modules libtool: install: warning: remember to run `libtool --finish /fpx/install/php/php-4.4.4/libs' chmod 755 /fpx/usr/apache/modules/libphp4.so chmod: failed to ...

  1. #1

    Default #40268 [NEW]: PHP make install failed to create

    From: thomastja at gmail dot com
    Operating system: Aix 5.3
    PHP version: 4.4.4
    PHP Bug Type: Compile Failure
    Bug description: PHP make install failed to create

    Description:
    ------------
    Any input will be welcome.

    I am trying to compile PHP in the following env.
    Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
    libtool 1.5.22

    I run the following configure command

    ../configure --prefix=/fpx/usr/php
    --with-apxs2=/fpx/usr/apache/bin/apxs
    --with-config-file-path=/fpx/usr/apache/conf
    --enable-shared

    completed successfully.

    ../make

    completed successfully

    ../make install

    failed with errors





    Reproduce code:
    ---------------
    bash-3.00# make install
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
    /fpx/usr/apache/modules
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-4.4.4/libs'
    chmod 755 /fpx/usr/apache/modules/libphp4.so
    chmod: failed to get attributes of `/fpx/usr/apache/modules/libphp4.so': A
    file or directory in the path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: *** [install-sapi] Error 1

    Expected result:
    ----------------
    Successfull compile of PHP and creation of

    Actual result:
    --------------
    make install failed with error.

    --
    Edit bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    --
    Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=40268&r=trysnapshot44[/url]
    Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=40268&r=trysnapshot52[/url]
    Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=40268&r=trysnapshot60[/url]
    Fixed in CVS: [url]http://bugs.php.net/fix.php?id=40268&r=fixedcvs[/url]
    Fixed in release: [url]http://bugs.php.net/fix.php?id=40268&r=alreadyfixed[/url]
    Need backtrace: [url]http://bugs.php.net/fix.php?id=40268&r=needtrace[/url]
    Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=40268&r=needscript[/url]
    Try newer version: [url]http://bugs.php.net/fix.php?id=40268&r=oldversion[/url]
    Not developer issue: [url]http://bugs.php.net/fix.php?id=40268&r=support[/url]
    Expected behavior: [url]http://bugs.php.net/fix.php?id=40268&r=notwrong[/url]
    Not enough info: [url]http://bugs.php.net/fix.php?id=40268&r=notenoughinfo[/url]
    Submitted twice: [url]http://bugs.php.net/fix.php?id=40268&r=submittedtwice[/url]
    register_globals: [url]http://bugs.php.net/fix.php?id=40268&r=globals[/url]
    PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=40268&r=php3[/url]
    Daylight Savings: [url]http://bugs.php.net/fix.php?id=40268&r=dst[/url]
    IIS Stability: [url]http://bugs.php.net/fix.php?id=40268&r=isapi[/url]
    Install GNU Sed: [url]http://bugs.php.net/fix.php?id=40268&r=gnused[/url]
    Floating point limitations: [url]http://bugs.php.net/fix.php?id=40268&r=float[/url]
    No Zend Extensions: [url]http://bugs.php.net/fix.php?id=40268&r=nozend[/url]
    MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=40268&r=mysqlcfg[/url]
    thomastja at gmail dot com Guest

  2. #2

    Default #40268 [Fbk->Opn]: PHP make install failed to create

    ID: 40268
    User updated by: thomastja at gmail dot com
    Reported By: thomastja at gmail dot com
    -Status: Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-29 08:49:05] [email]tony2001php.net[/email]

    What compiler & linker did you use?

    ------------------------------------------------------------------------

    [2007-01-29 08:33:00] thomastja at gmail dot com

    Description:
    ------------
    Any input will be welcome.

    I am trying to compile PHP in the following env.
    Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
    libtool 1.5.22

    I run the following configure command

    ../configure --prefix=/fpx/usr/php
    --with-apxs2=/fpx/usr/apache/bin/apxs
    --with-config-file-path=/fpx/usr/apache/conf
    --enable-shared

    completed successfully.

    ../make

    completed successfully

    ../make install

    failed with errors





    Reproduce code:
    ---------------
    bash-3.00# make install
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
    /fpx/usr/apache/modules
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-4.4.4/libs'
    chmod 755 /fpx/usr/apache/modules/libphp4.so
    chmod: failed to get attributes of
    `/fpx/usr/apache/modules/libphp4.so': A file or directory in the path
    name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: *** [install-sapi] Error 1

    Expected result:
    ----------------
    Successfull compile of PHP and creation of

    Actual result:
    --------------
    make install failed with error.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    thomastja at gmail dot com Guest

  3. #3

    Default #40268 [Opn]: PHP make install failed to create

    ID: 40268
    User updated by: thomastja at gmail dot com
    Reported By: thomastja at gmail dot com
    Status: Open
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-29 11:19:18] thomastja at gmail dot com

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.

    ------------------------------------------------------------------------

    [2007-01-29 08:49:05] [email]tony2001php.net[/email]

    What compiler & linker did you use?

    ------------------------------------------------------------------------

    [2007-01-29 08:33:00] thomastja at gmail dot com

    Description:
    ------------
    Any input will be welcome.

    I am trying to compile PHP in the following env.
    Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
    libtool 1.5.22

    I run the following configure command

    ../configure --prefix=/fpx/usr/php
    --with-apxs2=/fpx/usr/apache/bin/apxs
    --with-config-file-path=/fpx/usr/apache/conf
    --enable-shared

    completed successfully.

    ../make

    completed successfully

    ../make install

    failed with errors





    Reproduce code:
    ---------------
    bash-3.00# make install
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
    /fpx/usr/apache/modules
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-4.4.4/libs'
    chmod 755 /fpx/usr/apache/modules/libphp4.so
    chmod: failed to get attributes of
    `/fpx/usr/apache/modules/libphp4.so': A file or directory in the path
    name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: *** [install-sapi] Error 1

    Expected result:
    ----------------
    Successfull compile of PHP and creation of

    Actual result:
    --------------
    make install failed with error.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    thomastja at gmail dot com Guest

  4. #4

    Default #40268 [Opn->Fbk]: PHP make install failed to create

    ID: 40268
    Updated by: [email]tony2001php.net[/email]
    Reported By: thomastja at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    One of the possible reasons is your LD.
    Try with GNU ld, please.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-29 11:28:16] thomastja at gmail dot com

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?

    ------------------------------------------------------------------------

    [2007-01-29 11:19:18] thomastja at gmail dot com

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.

    ------------------------------------------------------------------------

    [2007-01-29 08:49:05] [email]tony2001php.net[/email]

    What compiler & linker did you use?

    ------------------------------------------------------------------------

    [2007-01-29 08:33:00] thomastja at gmail dot com

    Description:
    ------------
    Any input will be welcome.

    I am trying to compile PHP in the following env.
    Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
    libtool 1.5.22

    I run the following configure command

    ../configure --prefix=/fpx/usr/php
    --with-apxs2=/fpx/usr/apache/bin/apxs
    --with-config-file-path=/fpx/usr/apache/conf
    --enable-shared

    completed successfully.

    ../make

    completed successfully

    ../make install

    failed with errors





    Reproduce code:
    ---------------
    bash-3.00# make install
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
    /fpx/usr/apache/modules
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-4.4.4/libs'
    chmod 755 /fpx/usr/apache/modules/libphp4.so
    chmod: failed to get attributes of
    `/fpx/usr/apache/modules/libphp4.so': A file or directory in the path
    name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: *** [install-sapi] Error 1

    Expected result:
    ----------------
    Successfull compile of PHP and creation of

    Actual result:
    --------------
    make install failed with error.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    tony2001@php.net Guest

  5. #5

    Default #40268 [Fbk->Opn]: PHP make install failed to create

    ID: 40268
    User updated by: thomastja at gmail dot com
    Reported By: thomastja at gmail dot com
    -Status: Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    I have install the GNU ld

    bash-3.00# ld -version
    GNU ld version 2.14 20030612

    and found that it produce the same result.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-29 21:23:04] [email]tony2001php.net[/email]

    One of the possible reasons is your LD.
    Try with GNU ld, please.

    ------------------------------------------------------------------------

    [2007-01-29 11:28:16] thomastja at gmail dot com

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?

    ------------------------------------------------------------------------

    [2007-01-29 11:19:18] thomastja at gmail dot com

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.

    ------------------------------------------------------------------------

    [2007-01-29 08:49:05] [email]tony2001php.net[/email]

    What compiler & linker did you use?

    ------------------------------------------------------------------------

    [2007-01-29 08:33:00] thomastja at gmail dot com

    Description:
    ------------
    Any input will be welcome.

    I am trying to compile PHP in the following env.
    Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
    libtool 1.5.22

    I run the following configure command

    ../configure --prefix=/fpx/usr/php
    --with-apxs2=/fpx/usr/apache/bin/apxs
    --with-config-file-path=/fpx/usr/apache/conf
    --enable-shared

    completed successfully.

    ../make

    completed successfully

    ../make install

    failed with errors





    Reproduce code:
    ---------------
    bash-3.00# make install
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
    /fpx/usr/apache/modules
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-4.4.4/libs'
    chmod 755 /fpx/usr/apache/modules/libphp4.so
    chmod: failed to get attributes of
    `/fpx/usr/apache/modules/libphp4.so': A file or directory in the path
    name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: *** [install-sapi] Error 1

    Expected result:
    ----------------
    Successfull compile of PHP and creation of

    Actual result:
    --------------
    make install failed with error.


    ------------------------------------------------------------------------


    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    thomastja at gmail dot com Guest

  6. #6

    Default #40268 [Opn->Fbk]: PHP make install failed to create

    ID: 40268
    Updated by: [email]tony2001php.net[/email]
    Reported By: thomastja at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    Are you sure GNU ld was used in the build?
    Do you see any error messages that might be related to the problem?


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-30 04:26:07] thomastja at gmail dot com

    I have install the GNU ld

    bash-3.00# ld -version
    GNU ld version 2.14 20030612

    and found that it produce the same result.

    ------------------------------------------------------------------------

    [2007-01-29 21:23:04] [email]tony2001php.net[/email]

    One of the possible reasons is your LD.
    Try with GNU ld, please.

    ------------------------------------------------------------------------

    [2007-01-29 11:28:16] thomastja at gmail dot com

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?

    ------------------------------------------------------------------------

    [2007-01-29 11:19:18] thomastja at gmail dot com

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.

    ------------------------------------------------------------------------

    [2007-01-29 08:49:05] [email]tony2001php.net[/email]

    What compiler & linker did you use?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/40268[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    tony2001@php.net Guest

  7. #7

    Default #40268 [Fbk->Opn]: PHP make install failed to create

    ID: 40268
    User updated by: thomastja at gmail dot com
    Reported By: thomastja at gmail dot com
    -Status: Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    I retry again using the following:
    Apache_1.3.37 with php-4.4.4
    and the make install was successfull.

    So I clean up the system and retry again using
    Apache_2.2.3 and php-4.4.4
    but this time the make install failed with
    apxs:Error: Command failed with rc=65536

    I think my env is ok and suspect the error
    is with apache 2 and php 4 make install.
    Have anyone got this mix working?


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-30 09:06:01] [email]tony2001php.net[/email]

    Are you sure GNU ld was used in the build?
    Do you see any error messages that might be related to the problem?

    ------------------------------------------------------------------------

    [2007-01-30 04:26:07] thomastja at gmail dot com

    I have install the GNU ld

    bash-3.00# ld -version
    GNU ld version 2.14 20030612

    and found that it produce the same result.

    ------------------------------------------------------------------------

    [2007-01-29 21:23:04] [email]tony2001php.net[/email]

    One of the possible reasons is your LD.
    Try with GNU ld, please.

    ------------------------------------------------------------------------

    [2007-01-29 11:28:16] thomastja at gmail dot com

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?

    ------------------------------------------------------------------------

    [2007-01-29 11:19:18] thomastja at gmail dot com

    # gcc -v
    Using built-in specs.
    Target: powerpc-ibm-aix5.3.0.0
    Configured with: ../configure --with-as=/usr/bin/as
    --with-ld=/usr/bin/ld --disable-nls --enable-languages=c,c++
    --prefix=/opt/freeware --enable-threads
    --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
    Thread model: aix
    gcc version 4.0.0

    # ld -V
    ld: LD 1.64 (08/19/2003)

    # /fpx/usr/apache/build/libtool --version
    ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

    Hope the info helps.
    All comments are welcome.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/40268[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    thomastja at gmail dot com Guest

  8. #8

    Default #40268 [Opn->Fbk]: PHP make install failed to create

    ID: 40268
    Updated by: [email]tony2001php.net[/email]
    Reported By: thomastja at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    Works just fine with PHP 5.2, Apache 2.2.4, GCC 3.4.5 and native LD on
    AIX 5.1.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-01-31 01:17:04] thomastja at gmail dot com

    I retry again using the following:
    Apache_1.3.37 with php-4.4.4
    and the make install was successfull.

    So I clean up the system and retry again using
    Apache_2.2.3 and php-4.4.4
    but this time the make install failed with
    apxs:Error: Command failed with rc=65536

    I think my env is ok and suspect the error
    is with apache 2 and php 4 make install.
    Have anyone got this mix working?

    ------------------------------------------------------------------------

    [2007-01-30 09:06:01] [email]tony2001php.net[/email]

    Are you sure GNU ld was used in the build?
    Do you see any error messages that might be related to the problem?

    ------------------------------------------------------------------------

    [2007-01-30 04:26:07] thomastja at gmail dot com

    I have install the GNU ld

    bash-3.00# ld -version
    GNU ld version 2.14 20030612

    and found that it produce the same result.

    ------------------------------------------------------------------------

    [2007-01-29 21:23:04] [email]tony2001php.net[/email]

    One of the possible reasons is your LD.
    Try with GNU ld, please.

    ------------------------------------------------------------------------

    [2007-01-29 11:28:16] thomastja at gmail dot com

    I retry the whole setup with php-5.2.0
    and got the following during the make install

    Installing PHP SAPI module: apache2handler
    /fpx/usr/apache/build/instdso.sh
    SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp5.la
    /fpx/usr/apache/modules
    rm -f /fpx/usr/apache/modules/libphp5.so
    /fpx/usr/apache/build/libtool --mode=install cp libphp5.la
    /fpx/usr/apache/modules/
    cp .libs/libphp5.a /fpx/usr/apache/modules/libphp5.a
    cp .libs/libphp5.lai /fpx/usr/apache/modules/libphp5.la
    libtool: install: warning: remember to run `libtool --finish
    /fpx/install/php/php-5.2.0/libs'
    chmod 755 /fpx/usr/apache/modules/libphp5.so
    chmod: /fpx/usr/apache/modules/libphp5.so: A file or directory in the
    path name does not exist.
    apxs:Error: Command failed with rc=65536
    ..
    make: 1254-004 The error code from the last command is 1.
    >><<
    ls of php libs return

    bash-3.00# ls -al libs
    total 38528
    drwxr-xr-x 2 root system 256 Jan 29 19:19 .
    drwxr-xr-x 18 1002 1002 4096 Jan 29 19:19 ..
    -rw-r--r-- 1 root system 19717099 Jan 29 19:19 libphp5.a
    -rw-r--r-- 1 root system 1429 Jan 29 19:19 libphp5.la
    >><<<
    It seems to me that libtool is failing to create the libphp5.so. Any
    idea why ?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/40268[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    tony2001@php.net Guest

  9. #9

    Default #40268 [NoF->Opn]: PHP make install failed to create

    ID: 40268
    User updated by: thomastja at gmail dot com
    Reported By: thomastja at gmail dot com
    -Status: No Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    Have anyone tried the same on Aix 5.3


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-08 01:00:01] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    [2007-01-31 13:12:19] [email]tony2001php.net[/email]

    Works just fine with PHP 5.2, Apache 2.2.4, GCC 3.4.5 and native LD on
    AIX 5.1.

    ------------------------------------------------------------------------

    [2007-01-31 01:17:04] thomastja at gmail dot com

    I retry again using the following:
    Apache_1.3.37 with php-4.4.4
    and the make install was successfull.

    So I clean up the system and retry again using
    Apache_2.2.3 and php-4.4.4
    but this time the make install failed with
    apxs:Error: Command failed with rc=65536

    I think my env is ok and suspect the error
    is with apache 2 and php 4 make install.
    Have anyone got this mix working?

    ------------------------------------------------------------------------

    [2007-01-30 09:06:01] [email]tony2001php.net[/email]

    Are you sure GNU ld was used in the build?
    Do you see any error messages that might be related to the problem?

    ------------------------------------------------------------------------

    [2007-01-30 04:26:07] thomastja at gmail dot com

    I have install the GNU ld

    bash-3.00# ld -version
    GNU ld version 2.14 20030612

    and found that it produce the same result.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/40268[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    thomastja at gmail dot com Guest

  10. #10

    Default #40268 [Opn->Fbk]: PHP make install failed to create

    ID: 40268
    Updated by: [email]tony2001php.net[/email]
    Reported By: thomastja at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: Aix 5.3
    PHP Version: 4.4.4
    New Comment:

    Yes, I did. It works fine on AIX 5.3 as well.


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-02-09 08:58:21] thomastja at gmail dot com

    Have anyone tried the same on Aix 5.3

    ------------------------------------------------------------------------

    [2007-02-08 01:00:01] php-bugs at lists dot php dot net

    No feedback was provided for this bug for over a week, so it is
    being suspended automatically. If you are able to provide the
    information that was originally requested, please do so and change
    the status of the bug back to "Open".

    ------------------------------------------------------------------------

    [2007-01-31 13:12:19] [email]tony2001php.net[/email]

    Works just fine with PHP 5.2, Apache 2.2.4, GCC 3.4.5 and native LD on
    AIX 5.1.

    ------------------------------------------------------------------------

    [2007-01-31 01:17:04] thomastja at gmail dot com

    I retry again using the following:
    Apache_1.3.37 with php-4.4.4
    and the make install was successfull.

    So I clean up the system and retry again using
    Apache_2.2.3 and php-4.4.4
    but this time the make install failed with
    apxs:Error: Command failed with rc=65536

    I think my env is ok and suspect the error
    is with apache 2 and php 4 make install.
    Have anyone got this mix working?

    ------------------------------------------------------------------------

    [2007-01-30 09:06:01] [email]tony2001php.net[/email]

    Are you sure GNU ld was used in the build?
    Do you see any error messages that might be related to the problem?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    [url]http://bugs.php.net/40268[/url]

    --
    Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]
    tony2001@php.net Guest

Similar Threads

  1. #40268 [Opn->Fbk]: PHP make install failed to create
    By tony2001@php.net in forum PHP Bugs
    Replies: 0
    Last Post: January 29th, 08:49 AM
  2. Failed to create thread
    By wikimanuel in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: March 5th, 08:20 PM
  3. #21593 [Fbk->NoF]: make install:install-pear-* rules segfault
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: October 4th, 05:27 AM
  4. Replies: 0
    Last Post: September 28th, 08:28 PM
  5. Replies: 0
    Last Post: September 28th, 03:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139