ID: 40268
Updated by: [email]tony2001php.net[/email]
Reported By: thomastja at gmail dot com
-Status: Open
+Status: Feedback
Bug Type: Compile Failure
Operating System: Aix 5.3
PHP Version: 4.4.4
New Comment:

What compiler & linker did you use?


Previous Comments:
------------------------------------------------------------------------

[2007-01-29 08:33:00] thomastja at gmail dot com

Description:
------------
Any input will be welcome.

I am trying to compile PHP in the following env.
Aix 5.3, Apache 2.2.3, PHP 4.4.4, gcc version 4.0.0,
libtool 1.5.22

I run the following configure command

../configure --prefix=/fpx/usr/php
--with-apxs2=/fpx/usr/apache/bin/apxs
--with-config-file-path=/fpx/usr/apache/conf
--enable-shared

completed successfully.

../make

completed successfully

../make install

failed with errors





Reproduce code:
---------------
bash-3.00# make install
/fpx/usr/apache/build/instdso.sh
SH_LIBTOOL='/fpx/usr/apache/build/libtool' libphp4.la
/fpx/usr/apache/modules
libtool: install: warning: remember to run `libtool --finish
/fpx/install/php/php-4.4.4/libs'
chmod 755 /fpx/usr/apache/modules/libphp4.so
chmod: failed to get attributes of
`/fpx/usr/apache/modules/libphp4.so': A file or directory in the path
name does not exist.
apxs:Error: Command failed with rc=65536
..
make: *** [install-sapi] Error 1

Expected result:
----------------
Successfull compile of PHP and creation of

Actual result:
--------------
make install failed with error.


------------------------------------------------------------------------


--
Edit this bug report at [url]http://bugs.php.net/?id=40268&edit=1[/url]