From: mcrogerm at stjohn dot ac dot th
Operating system: Win2k Pro
PHP version: 5CVS-2007-02-01 (snap)
PHP Bug Type: Unknown/Other Function
Bug description: PHP module compiled with different version API

Description:
------------
After I installed ver. 5.2.0, I found a warning message on the command
line. I downloaded and installed the latest snapshot version, and the
error message is the same except for the version number.

I checked, and the file date on php5ts.dll is 2/1/2007, the same as on
php.exe.

Reproduce code:
---------------
c:\PHP>php --version


Expected result:
----------------
PHP 5.2.1RC5-dev (cli) (built: Feb 1 2007 04:24:39)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

Actual result:
--------------
PHP Warning: PHP Startup: dbg: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0
PHP 5.2.1RC5-dev (cli) (built: Feb 1 2007 04:24:39)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

--
Edit bug report at [url]http://bugs.php.net/?id=40302&edit=1[/url]
--
Try a CVS snapshot (PHP 4.4): [url]http://bugs.php.net/fix.php?id=40302&r=trysnapshot44[/url]
Try a CVS snapshot (PHP 5.2): [url]http://bugs.php.net/fix.php?id=40302&r=trysnapshot52[/url]
Try a CVS snapshot (PHP 6.0): [url]http://bugs.php.net/fix.php?id=40302&r=trysnapshot60[/url]
Fixed in CVS: [url]http://bugs.php.net/fix.php?id=40302&r=fixedcvs[/url]
Fixed in release: [url]http://bugs.php.net/fix.php?id=40302&r=alreadyfixed[/url]
Need backtrace: [url]http://bugs.php.net/fix.php?id=40302&r=needtrace[/url]
Need Reproduce Script: [url]http://bugs.php.net/fix.php?id=40302&r=needscript[/url]
Try newer version: [url]http://bugs.php.net/fix.php?id=40302&r=oldversion[/url]
Not developer issue: [url]http://bugs.php.net/fix.php?id=40302&r=support[/url]
Expected behavior: [url]http://bugs.php.net/fix.php?id=40302&r=notwrong[/url]
Not enough info: [url]http://bugs.php.net/fix.php?id=40302&r=notenoughinfo[/url]
Submitted twice: [url]http://bugs.php.net/fix.php?id=40302&r=submittedtwice[/url]
register_globals: [url]http://bugs.php.net/fix.php?id=40302&r=globals[/url]
PHP 3 support discontinued: [url]http://bugs.php.net/fix.php?id=40302&r=php3[/url]
Daylight Savings: [url]http://bugs.php.net/fix.php?id=40302&r=dst[/url]
IIS Stability: [url]http://bugs.php.net/fix.php?id=40302&r=isapi[/url]
Install GNU Sed: [url]http://bugs.php.net/fix.php?id=40302&r=gnused[/url]
Floating point limitations: [url]http://bugs.php.net/fix.php?id=40302&r=float[/url]
No Zend Extensions: [url]http://bugs.php.net/fix.php?id=40302&r=nozend[/url]
MySQL Configuration Error: [url]http://bugs.php.net/fix.php?id=40302&r=mysqlcfg[/url]