Professional Web Applications Themes

#40845 [NEW]: Failure during make - PHP Bugs

From: steve dot cersosimo at att dot com Operating system: Solaris 5.8 PHP version: 5.2.1 PHP Bug Type: Compile Failure Bug description: Failure during make Description: ------------ I am getting a failure when I try to make 5.2.1. Here is the failure line: /bin/sh /home/software/apps/php-5.2.1/libtool --silent --preserve-dup-deps --mode=compile gcc -IZend/ -I/home/software/apps/php-5.2.1/Zend/ -DPHP_ATOM_INC -I/home/software/apps/php-5.2.1/include -I/home/software/apps/php-5.2.1/main -I/home/software/apps/php-5.2.1 -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/include -I/home/software/apps/php-5.2.1/ext/date/lib -I/usr/local/mysql/include -I/home/oracle_8.1.7/OraHome/rdbms/public -I/home/oracle_8.1.7/OraHome/rdbms/demo -I/usr/local/pgsql/include -I/usr/local/freetds/include -I/home/software/apps/php-5.2.1/TSRM -I/home/software/apps/php-5.2.1/Zend -D_POSIX_PTHREAD_SEMANTICS -I/usr/local/include -g -O2 -c /home/software/apps/php-5.2.1/Zend/zend_strtod.c -o Zend/zend_strtod.lo /usr/ccs/bin/as: "/var/tmp//ccr15Fwa.s", line 3341: error: constant value must be between -4096 and 4095 make: *** [Zend/zend_strtod.lo] Error 1 My configure options are: ../configure --with-apxs2=/home/apache/bin/apxs --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl ...

  1. #1

    Default #40845 [NEW]: Failure during make

    From: steve dot cersosimo at att dot com
    Operating system: Solaris 5.8
    PHP version: 5.2.1
    PHP Bug Type: Compile Failure
    Bug description: Failure during make

    Description:
    ------------
    I am getting a failure when I try to make 5.2.1. Here is the failure
    line:
    /bin/sh /home/software/apps/php-5.2.1/libtool --silent --preserve-dup-deps
    --mode=compile gcc -IZend/ -I/home/software/apps/php-5.2.1/Zend/
    -DPHP_ATOM_INC -I/home/software/apps/php-5.2.1/include
    -I/home/software/apps/php-5.2.1/main -I/home/software/apps/php-5.2.1
    -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/include
    -I/home/software/apps/php-5.2.1/ext/date/lib -I/usr/local/mysql/include
    -I/home/oracle_8.1.7/OraHome/rdbms/public
    -I/home/oracle_8.1.7/OraHome/rdbms/demo -I/usr/local/pgsql/include
    -I/usr/local/freetds/include -I/home/software/apps/php-5.2.1/TSRM
    -I/home/software/apps/php-5.2.1/Zend -D_POSIX_PTHREAD_SEMANTICS
    -I/usr/local/include -g -O2 -c
    /home/software/apps/php-5.2.1/Zend/zend_strtod.c -o Zend/zend_strtod.lo
    /usr/ccs/bin/as: "/var/tmp//ccr15Fwa.s", line 3341: error: constant value
    must be between -4096 and 4095
    make: *** [Zend/zend_strtod.lo] Error 1

    My configure options are:
    ../configure --with-apxs2=/home/apache/bin/apxs
    --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl
    --with-config-file-path=/etc --with-pear --enable-ftp
    --with-pgsql=/usr/local/pgsql --enable-sockets --with-ldap=/usr/local
    --with-zlib=/usr/local --with-oci8=/home/oracle_8.1.7/OraHome
    --with-sybase-ct=/usr/local/freetds --with-gmp=/usr/local
    --with-mcrypt=/usr/local --with-snmp --enable-pcntl --enable-soap
    --enable-zip

    Any help is appreciated.



    --
    Edit bug report at http://bugs.php.net/?id=40845&edit=1
    --
    Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=40845&r=trysnapshot44
    Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=40845&r=trysnapshot52
    Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=40845&r=trysnapshot60
    Fixed in CVS: http://bugs.php.net/fix.php?id=40845&r=fixedcvs
    Fixed in release: http://bugs.php.net/fix.php?id=40845&r=alreadyfixed
    Need backtrace: http://bugs.php.net/fix.php?id=40845&r=needtrace
    Need Reproduce Script: http://bugs.php.net/fix.php?id=40845&r=needscript
    Try newer version: http://bugs.php.net/fix.php?id=40845&r=oldversion
    Not developer issue: http://bugs.php.net/fix.php?id=40845&r=support
    Expected behavior: http://bugs.php.net/fix.php?id=40845&r=notwrong
    Not enough info: http://bugs.php.net/fix.php?id=40845&r=notenoughinfo
    Submitted twice: http://bugs.php.net/fix.php?id=40845&r=submittedtwice
    register_globals: http://bugs.php.net/fix.php?id=40845&r=globals
    PHP 3 support discontinued: http://bugs.php.net/fix.php?id=40845&r=php3
    Daylight Savings: http://bugs.php.net/fix.php?id=40845&r=dst
    IIS Stability: http://bugs.php.net/fix.php?id=40845&r=isapi
    Install GNU Sed: http://bugs.php.net/fix.php?id=40845&r=gnused
    Floating point limitations: http://bugs.php.net/fix.php?id=40845&r=float
    No Zend Extensions: http://bugs.php.net/fix.php?id=40845&r=nozend
    MySQL Configuration Error: http://bugs.php.net/fix.php?id=40845&r=mysqlcfg
    steve Guest

  2. #2

    Default #40845 [Opn->Fbk]: Failure during make

    ID: 40845
    Updated by: net
    Reported By: steve dot cersosimo at att dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: Solaris 5.8
    PHP Version: 5.2.1
    New Comment:

    Looks like a problem with your assembler binary: 
    value must be between -4096 and 4095


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-03-17 19:17:36] steve dot cersosimo at att dot com

    Description:
    ------------
    I am getting a failure when I try to make 5.2.1. Here is the failure
    line:
    /bin/sh /home/software/apps/php-5.2.1/libtool --silent
    --preserve-dup-deps --mode=compile gcc -IZend/
    -I/home/software/apps/php-5.2.1/Zend/ -DPHP_ATOM_INC
    -I/home/software/apps/php-5.2.1/include
    -I/home/software/apps/php-5.2.1/main -I/home/software/apps/php-5.2.1
    -I/usr/local/include/libxml2 -I/usr/local/ssl/include
    -I/usr/local/include -I/home/software/apps/php-5.2.1/ext/date/lib
    -I/usr/local/mysql/include -I/home/oracle_8.1.7/OraHome/rdbms/public
    -I/home/oracle_8.1.7/OraHome/rdbms/demo -I/usr/local/pgsql/include
    -I/usr/local/freetds/include -I/home/software/apps/php-5.2.1/TSRM
    -I/home/software/apps/php-5.2.1/Zend -D_POSIX_PTHREAD_SEMANTICS
    -I/usr/local/include -g -O2 -c
    /home/software/apps/php-5.2.1/Zend/zend_strtod.c -o
    Zend/zend_strtod.lo
    /usr/ccs/bin/as: "/var/tmp//ccr15Fwa.s", line 3341: error: constant
    value must be between -4096 and 4095
    make: *** [Zend/zend_strtod.lo] Error 1

    My configure options are:
    ../configure --with-apxs2=/home/apache/bin/apxs
    --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl
    --with-config-file-path=/etc --with-pear --enable-ftp
    --with-pgsql=/usr/local/pgsql --enable-sockets --with-ldap=/usr/local
    --with-zlib=/usr/local --with-oci8=/home/oracle_8.1.7/OraHome
    --with-sybase-ct=/usr/local/freetds --with-gmp=/usr/local
    --with-mcrypt=/usr/local --with-snmp --enable-pcntl --enable-soap
    --enable-zip

    Any help is appreciated.




    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=40845&edit=1
    tony2001@php.net Guest

  3. #3

    Default #40845 [Com]: Failure during make

    ID: 40845
    Comment by: regis dot jarde at alcatel-lucent dot fr
    Reported By: steve dot cersosimo at att dot com
    Status: Feedback
    Bug Type: Compile Failure
    Operating System: Solaris 5.8
    PHP Version: 5.2.1
    New Comment:

    Same issue on my side.

    When I want to update my php 5.2.0 to the new 5.2.1 version i fall
    into the same issue.

    Notice I can compile from scratch the 5.2.0 without any problem (on the
    same server with the same ./configuration parameters) but couldn't
    compile the new 5.2.1 version.

    ../configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
    --with-pgsql --enable-so --with-gettext --with-gd=/usr/local
    --with-jpeg-dir

    here is my error messages :

    /bin/sh
    /a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/libtool
    --silent --preserve-dup-deps --mode=compile /net/build/bin/gcc -IZend/
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/Zend/
    -DPHP_ATOM_INC
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/include
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/main
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1
    -I/usr/local/include/libxml2
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/ext/date/lib
    -I/usr/local/include -I/usr/local/include/mysql
    -I/usr/local/pgsql/include
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/TSRM
    -I/a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/Zend
    -D_POSIX_PTHREAD_SEMANTICS -I/usr/include -g -O2 -c
    /a/pandora/vol/vol0/chantier/SunOS.5.9/client/usr-local/php-5.2.1/Zend/zend_strtod.c
    -o Zend/zend_strtod.lo
    /usr/ccs/bin/as: "/var/tmp//cccyeFEh.s", line 3337: error: constant
    value must be between -4096 and 4095
    make: *** [Zend/zend_strtod.lo] Error 1


    Previous Comments:
    ------------------------------------------------------------------------

    [2007-03-17 19:25:18] net

    Looks like a problem with your assembler binary: 
    value must be between -4096 and 4095

    ------------------------------------------------------------------------

    [2007-03-17 19:17:36] steve dot cersosimo at att dot com

    Description:
    ------------
    I am getting a failure when I try to make 5.2.1. Here is the failure
    line:
    /bin/sh /home/software/apps/php-5.2.1/libtool --silent
    --preserve-dup-deps --mode=compile gcc -IZend/
    -I/home/software/apps/php-5.2.1/Zend/ -DPHP_ATOM_INC
    -I/home/software/apps/php-5.2.1/include
    -I/home/software/apps/php-5.2.1/main -I/home/software/apps/php-5.2.1
    -I/usr/local/include/libxml2 -I/usr/local/ssl/include
    -I/usr/local/include -I/home/software/apps/php-5.2.1/ext/date/lib
    -I/usr/local/mysql/include -I/home/oracle_8.1.7/OraHome/rdbms/public
    -I/home/oracle_8.1.7/OraHome/rdbms/demo -I/usr/local/pgsql/include
    -I/usr/local/freetds/include -I/home/software/apps/php-5.2.1/TSRM
    -I/home/software/apps/php-5.2.1/Zend -D_POSIX_PTHREAD_SEMANTICS
    -I/usr/local/include -g -O2 -c
    /home/software/apps/php-5.2.1/Zend/zend_strtod.c -o Zend/zend_strtod.lo
    /usr/ccs/bin/as: "/var/tmp//ccr15Fwa.s", line 3341: error: constant
    value must be between -4096 and 4095
    make: *** [Zend/zend_strtod.lo] Error 1

    My configure options are:
    ../configure --with-apxs2=/home/apache/bin/apxs
    --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl
    --with-config-file-path=/etc --with-pear --enable-ftp
    --with-pgsql=/usr/local/pgsql --enable-sockets --with-ldap=/usr/local
    --with-zlib=/usr/local --with-oci8=/home/oracle_8.1.7/OraHome
    --with-sybase-ct=/usr/local/freetds --with-gmp=/usr/local
    --with-mcrypt=/usr/local --with-snmp --enable-pcntl --enable-soap
    --enable-zip

    Any help is appreciated.




    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=40845&edit=1
    regis Guest

Similar Threads

  1. #38980 [NEW]: Make install failure
    By sn4265 at att dot com in forum PHP Bugs
    Replies: 1
    Last Post: September 28th, 10:20 PM
  2. Replies: 1
    Last Post: January 27th, 05:13 AM
  3. #25588 [Com]: Make failure with OCI8 for Oracle support
    By fernando at napl dot com dot br in forum PHP Development
    Replies: 0
    Last Post: November 12th, 04:43 PM
  4. #25588 [Opn->Bgs]: Make failure with OCI8 for Oracle support
    By sniper@php.net in forum PHP Development
    Replies: 0
    Last Post: September 19th, 04:51 AM
  5. #25588 [NEW]: Make failure with OCI8 for Oracle support
    By russell dot edwards at cplaromas dot com in forum PHP Development
    Replies: 0
    Last Post: September 18th, 02:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139