Professional Web Applications Themes

8-bit characters anyone? - FreeBSD

I have an odd problem. I can't get any 8-bit characters to show up after an upgrade. On the console nothing happens after I run kbdmap and choose Swedish ISO-8859-1. It just beeps, and prints the non-Swedish characters like before. In KDE, after having added my own xmodmap to the .xinitrc file, I though that they might appear. No such luck. Even after setting the keyboard layout on Control Panel/Regional/Keyboard Layout to Swedish do they not appear. Oddly enough, in emacs everything looks like it should! What am I missing, and what didn't I do after the upgrade? /Andreas -- ...

  1. #1

    Default 8-bit characters anyone?


    I have an odd problem. I can't get any 8-bit characters
    to show up after an upgrade.

    On the console nothing happens after I run kbdmap and choose Swedish
    ISO-8859-1. It just beeps, and prints the non-Swedish characters like
    before.

    In KDE, after having added my own xmodmap to the .xinitrc file, I though
    that they might appear. No such luck. Even after setting the keyboard
    layout on Control Panel/Regional/Keyboard Layout to Swedish do they not
    appear.

    Oddly enough, in emacs everything looks like it should!

    What am I missing, and what didn't I do after the upgrade?

    /Andreas

    --
    A: Because it fouls the order in which people normally read text.
    Q: Why is top-posting such a bad thing?
    A: Top-posting.
    Q: What is the most annoying thing on usenet and in e-mail?
    Andreas Guest

  2. #2

    Default Re: 8-bit characters anyone?

    On 2005-03-22 21:07, Andreas Davour <UU.SE> wrote: 

    You have probably forgotten to set the locale related stuff correctly in
    your environment. What does the following in one of your shells?

    % env | grep LANG
    % env | grep LC_

    - Giorgos

    Giorgos Guest

  3. #3

    Default Re: 8-bit characters anyone?


    Thanks for you response!

    On Tue, 22 Mar 2005, Giorgos Keramidas wrote:
     
    >
    > You have probably forgotten to set the locale related stuff correctly in
    > your environment. What does the following in one of your shells?
    >
    > % env | grep LANG
    > % env | grep LC_[/ref]

    Nothing at all. Though, I never did fiddle with locales before the
    upgrade either. In KDE I have configured the locale as Swedish, and the
    date, currency and those things look ok.

    /andreas

    --
    A: Because it fouls the order in which people normally read text.
    Q: Why is top-posting such a bad thing?
    A: Top-posting.
    Q: What is the most annoying thing on usenet and in e-mail?
    Andreas Guest

  4. #4

    Default Re: 8-bit characters anyone?

    On 2005-03-22 23:02, Andreas Davour <UU.SE> wrote: 
    >>
    >>You have probably forgotten to set the locale related stuff correctly in
    >>your environment. What does the following in one of your shells?
    >>
    >> % env | grep LANG
    >> % env | grep LC_[/ref]
    >
    > Nothing at all. Though, I never did fiddle with locales before the
    > upgrade either. In KDE I have configured the locale as Swedish, and the
    > date, currency and those things look ok.[/ref]

    This is probably what's causing you trouble.

    FWIW, using the XKB input extension here, I noticed that the X server
    fails to get/output any 8-bit character until I correctly set my
    environment in the login shell or my ``.xinitrc'' file.

    For instance, for Greek text input, I use:

    [-- .xinitrc file --]

    % # Clear all existing locale environment.
    % __junk=""
    % unset __junk `env | sed -n -E '/^(LANG|LC_[A-Z]+)=.*$/ s/=.*$//p'`
    % export LANG='C'
    % export LC_CTYPE='el_GR.ISO8859-7'
    % export LC_COLLATE='el_GR.ISO8859-7'
    %
    % # Finally, fire up the window manager.
    % exec wmaker

    [-- /etc/X11/xorg.conf --]

    % Section "InputDevice"
    % Identifier "Keyboard0"
    % Driver "keyboard"
    % Option "XkbRules" "xorg"
    % Option "XkbModel" "pc105"
    %
    % # Support for Greek input. You must also have a matching locale
    % # setup in the environment of your xinit process.
    % Option "XkbLayout" "us,el"
    % Option "XkbOptions" "grp:alt_shift_toggle"
    % EndSection

    The xorg.conf stuff fails to work if I comment out the locale settings
    in my .xinitrc file.

    - Giorgos

    Giorgos Guest

  5. #5

    Default Re: 8-bit characters anyone?

    On Wed, 23 Mar 2005, Giorgos Keramidas wrote:
     
    >>
    >> Nothing at all. Though, I never did fiddle with locales before the
    >> upgrade either. In KDE I have configured the locale as Swedish, and the
    >> date, currency and those things look ok.[/ref]
    >
    > This is probably what's causing you trouble.
    >
    > FWIW, using the XKB input extension here, I noticed that the X server
    > fails to get/output any 8-bit character until I correctly set my
    > environment in the login shell or my ``.xinitrc'' file.
    >
    > For instance, for Greek text input, I use:[/ref]
    [snip]

    Thanks! I'll try to set some locale settings in my .xinitrc and see if
    that solves anything. I don't use xorg, since I have been using XFree86
    since the early 1990-ies and don't want to learn it all over again.
    Maybe that's what troubling my setup.

    Now I'll just wait for another long compile, and then shut down X and
    try this out.

    /Andreas

    --
    A: Because it fouls the order in which people normally read text.
    Q: Why is top-posting such a bad thing?
    A: Top-posting.
    Q: What is the most annoying thing on usenet and in e-mail?
    Andreas Guest

  6. #6

    Default Re: 8-bit characters anyone?

    On Wed, 23 Mar 2005, Giorgos Keramidas wrote:
     
    >>
    >> Nothing at all. Though, I never did fiddle with locales before the
    >> upgrade either. In KDE I have configured the locale as Swedish, and the
    >> date, currency and those things look ok.[/ref]
    >
    > This is probably what's causing you trouble.
    >
    > FWIW, using the XKB input extension here, I noticed that the X server
    > fails to get/output any 8-bit character until I correctly set my
    > environment in the login shell or my ``.xinitrc'' file.
    >
    > For instance, for Greek text input, I use:
    >
    > [-- .xinitrc file --][/ref]

    After adapting this to my locale, things look like they should in X. Now
    I'll just have to figure out how to get the console to work as I want as
    well.

    Things must have changed from my last install, when this wasn't
    necessary.

    Thanks for your help!

    /Andreas

    --
    A: Because it fouls the order in which people normally read text.
    Q: Why is top-posting such a bad thing?
    A: Top-posting.
    Q: What is the most annoying thing on usenet and in e-mail?
    Andreas Guest

Similar Threads

  1. What's up with the fat characters in my PDF? (I and L)
    By Martin_Bergstrom@adobeforums.com in forum Adobe Acrobat Macintosh
    Replies: 14
    Last Post: July 14th, 10:12 AM
  2. Modifying with odd characters
    By stacekz in forum Dreamweaver AppDev
    Replies: 2
    Last Post: March 21st, 05:26 PM
  3. Replies: 1
    Last Post: August 12th, 03:28 PM
  4. Replies: 3
    Last Post: July 9th, 10:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139