I've been playing with this for a couple of months now and haven't got any closer to a solution. It is not application specific. The problem can be seen when printing from any application to the Adobe PDF 8 printer.

The only thing I can think of that may be different is that I modified the Adobe installer to include the volume serial number for our organization.

Things I have tried that have not worked:
* Cleared caches, preferences, fixed permissions, verified no disk problems
* removed PPD, and PDF plugins from /Library/Printers/PPD\ Plugins/ and /usr/libexec/cups/backend/pdf088
* removed preferences and application support files from /Library and ~/Library
* Let Acrobat repair everything
* Reset print system
* Ran all updates
* Manually uninstalled CS3 and re-installed

I have the same problem on Leopard, but I am able to fix it by fixing the two aliases located in ~/Library/Preferences/com.adobe.print/AdobePDF8/Aliases/ Or just simply delething them and letting them regenerate.

I know more people out there are having the same problem, I just don't see any answers out there that actually work.

Thank you,
Ken