bin <--- bin ---> lib ---> lib/rbbr ---> lib/rbbr/doc <--- lib/rbbr/doc ---> lib/rbbr/ui ---> lib/rbbr/ui/gtk <--- lib/rbbr/ui/gtk <--- lib/rbbr/ui <--- lib/rbbr <--- lib ---> data ---> data/locale ---> data/locale/fr ---> data/locale/fr/LC_MESSAGES <--- data/locale/fr/LC_MESSAGES <--- data/locale/fr ---> data/locale/ja ---> data/locale/ja/LC_MESSAGES <--- data/locale/ja/LC_MESSAGES <--- data/locale/ja <--- data/locale ---> data/rbbr ---> data/rbbr/rd <--- data/rbbr/rd <--- data/rbbr <--- data install.rb: config done. F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>ruby inst all.rb setup install.rb: entering setup phase... L10n is not supported on this environment. ---> bin set #! line to "#!c:/ruby/bin/ruby" for F:/rubyAll/rbbr-0.5.0-withapi.tar.gz/rbb r-0.5.0-withapi.tar/rbbr-0.5.0/bin/rbbr ... rm -f rbbr rm -f rbbr.tmp <--- bin ---> lib ---> lib/rbbr ---> lib/rbbr/doc <--- lib/rbbr/doc ---> lib/rbbr/ui ---> lib/rbbr/ui/gtk <--- lib/rbbr/ui/gtk <--- lib/rbbr/ui <--- lib/rbbr <--- lib ---> data ---> data/locale ---> data/locale/fr ---> data/locale/fr/LC_MESSAGES <--- data/locale/fr/LC_MESSAGES <--- data/locale/fr ---> data/locale/ja ---> data/locale/ja/LC_MESSAGES <--- data/locale/ja/LC_MESSAGES <--- data/locale/ja <--- data/locale ---> data/rbbr ---> data/rbbr/rd <--- data/rbbr/rd <--- data/rbbr <--- data install.rb: setup done. F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>ruby inst all.rb install install.rb: entering install phase... ---> bin mkdir -p c:/ruby/bin/ install rbbr c:/ruby/bin/ <--- bin ---> lib mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/ install rbbr.rb c:/ruby/lib/ruby/site_ruby/1.8/ ---> lib/rbbr mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr install config.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr install doc.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr install metainfo.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr ---> lib/rbbr/doc mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc install rd.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc install refe.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc install ri.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc <--- lib/rbbr/doc ---> lib/rbbr/ui mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui install gtk.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui ---> lib/rbbr/ui/gtk mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install aboutdialog.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install browselist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install browser.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install confmanager.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install constlist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install docviewer.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install libselectiondialog.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install methodlist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install moduledisplay.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install modulelabel.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install modulelistview.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install moduletreeview.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install stockbrowser.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk install windowutils.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk <--- lib/rbbr/ui/gtk <--- lib/rbbr/ui <--- lib/rbbr <--- lib ---> data mkdir -p c:/ruby/share/ ---> data/locale mkdir -p c:/ruby/share/locale ---> data/locale/fr mkdir -p c:/ruby/share/locale/fr ---> data/locale/fr/LC_MESSAGES mkdir -p c:/ruby/share/locale/fr/LC_MESSAGES <--- data/locale/fr/LC_MESSAGES <--- data/locale/fr ---> data/locale/ja mkdir -p c:/ruby/share/locale/ja ---> data/locale/ja/LC_MESSAGES mkdir -p c:/ruby/share/locale/ja/LC_MESSAGES <--- data/locale/ja/LC_MESSAGES <--- data/locale/ja <--- data/locale ---> data/rbbr mkdir -p c:/ruby/share/rbbr install icon.png c:/ruby/share/rbbr ---> data/rbbr/rd mkdir -p c:/ruby/share/rbbr/rd install GConf c:/ruby/share/rbbr/rd install GConf%3A%3ABadAddressError c:/ruby/share/rbbr/rd install GConf%3A%3ABadAdressError c:/ruby/share/rbbr/rd install GConf%3A%3ABadKeyError c:/ruby/share/rbbr/rd install GConf%3A%3AChangeSet c:/ruby/share/rbbr/rd install GConf%3A%3AClient c:/ruby/share/rbbr/rd install GConf%3A%3ACorruptError c:/ruby/share/rbbr/rd install GConf%3A%3AEngine c:/ruby/share/rbbr/rd install GConf%3A%3AEntry c:/ruby/share/rbbr/rd install GConf%3A%3AError c:/ruby/share/rbbr/rd install GConf%3A%3AFailedError c:/ruby/share/rbbr/rd install GConf%3A%3AInShutdownError c:/ruby/share/rbbr/rd install GConf%3A%3AIsDirError c:/ruby/share/rbbr/rd install GConf%3A%3AIsKeyError c:/ruby/share/rbbr/rd install GConf%3A%3ALocalEngineError c:/ruby/share/rbbr/rd install GConf%3A%3ALockFailedError c:/ruby/share/rbbr/rd install GConf%3A%3AMetaInfo c:/ruby/share/rbbr/rd install GConf%3A%3ANoPermissionError c:/ruby/share/rbbr/rd install GConf%3A%3ANoServerError c:/ruby/share/rbbr/rd install GConf%3A%3ANoWritableDatabaseError c:/ruby/share/rbbr/rd install GConf%3A%3AOafError c:/ruby/share/rbbr/rd install GConf%3A%3AOverriddenError c:/ruby/share/rbbr/rd install GConf%3A%3AParseError c:/ruby/share/rbbr/rd install GConf%3A%3ASchema c:/ruby/share/rbbr/rd install GConf%3A%3ATypeMismatchError c:/ruby/share/rbbr/rd install Gdk c:/ruby/share/rbbr/rd install Gdk%3A%3AAtom c:/ruby/share/rbbr/rd install Gdk%3A%3AColor c:/ruby/share/rbbr/rd install Gdk%3A%3AColormap c:/ruby/share/rbbr/rd install Gdk%3A%3ACursor c:/ruby/share/rbbr/rd install Gdk%3A%3ADrawable c:/ruby/share/rbbr/rd install Gdk%3A%3AGL c:/ruby/share/rbbr/rd install Gdk%3A%3AGL%3A%3AContext c:/ruby/share/rbbr/rd install Gdk%3A%3AGLConfig c:/ruby/share/rbbr/rd install Gdk%3A%3AGLContext c:/ruby/share/rbbr/rd install Gdk%3A%3AGLDrawable c:/ruby/share/rbbr/rd install Gdk%3A%3AGLPixmap c:/ruby/share/rbbr/rd install Gdk%3A%3AGLWindow c:/ruby/share/rbbr/rd install Gdk%3A%3AImage c:/ruby/share/rbbr/rd install Gdk%3A%3AKeyval c:/ruby/share/rbbr/rd install Gdk%3A%3APixmap c:/ruby/share/rbbr/rd install Gdk%3A%3ARectangle c:/ruby/share/rbbr/rd install Gdk%3A%3ARegion c:/ruby/share/rbbr/rd install Gdk%3A%3ARGB c:/ruby/share/rbbr/rd install Gdk%3A%3AThread c:/ruby/share/rbbr/rd install Gdk%3A%3AWindow c:/ruby/share/rbbr/rd install GLib c:/ruby/share/rbbr/rd install GLib%3A%3AInstantiatable c:/ruby/share/rbbr/rd install GLib%3A%3AType c:/ruby/share/rbbr/rd install Gst c:/ruby/share/rbbr/rd install Gst%3A%3AAutoplug c:/ruby/share/rbbr/rd install Gst%3A%3AAutoplugFactory c:/ruby/share/rbbr/rd install Gst%3A%3ABin c:/ruby/share/rbbr/rd install Gst%3A%3ACaps c:/ruby/share/rbbr/rd install Gst%3A%3AClock c:/ruby/share/rbbr/rd install Gst%3A%3AClockEntry c:/ruby/share/rbbr/rd install Gst%3A%3ACpu c:/ruby/share/rbbr/rd install Gst%3A%3AElement c:/ruby/share/rbbr/rd install Gst%3A%3AElementFactory c:/ruby/share/rbbr/rd install Gst%3A%3AEvent c:/ruby/share/rbbr/rd install Gst%3A%3AEventMask c:/ruby/share/rbbr/rd install Gst%3A%3AEventSeek c:/ruby/share/rbbr/rd install Gst%3A%3AEventSegmentSeek c:/ruby/share/rbbr/rd install Gst%3A%3AEventSize c:/ruby/share/rbbr/rd install Gst%3A%3AFormat c:/ruby/share/rbbr/rd install Gst%3A%3AIndexFactory c:/ruby/share/rbbr/rd install Gst%3A%3AObject c:/ruby/share/rbbr/rd install Gst%3A%3APad c:/ruby/share/rbbr/rd install Gst%3A%3APadTemplate c:/ruby/share/rbbr/rd install Gst%3A%3AParse c:/ruby/share/rbbr/rd install Gst%3A%3APipeline c:/ruby/share/rbbr/rd install Gst%3A%3APlugin c:/ruby/share/rbbr/rd install Gst%3A%3APluginFeature c:/ruby/share/rbbr/rd install Gst%3A%3AQueryType c:/ruby/share/rbbr/rd install Gst%3A%3ARegistry c:/ruby/share/rbbr/rd install Gst%3A%3ASchedulerFactory c:/ruby/share/rbbr/rd install Gst%3A%3ASystemClock c:/ruby/share/rbbr/rd install Gst%3A%3AThread c:/ruby/share/rbbr/rd install Gst%3A%3AType c:/ruby/share/rbbr/rd install Gst%3A%3ATypeFactory c:/ruby/share/rbbr/rd install Gst%3A%3AXML c:/ruby/share/rbbr/rd install Gtk c:/ruby/share/rbbr/rd install Gtk%3A%3AAccelerator c:/ruby/share/rbbr/rd install Gtk%3A%3AAccelGroup c:/ruby/share/rbbr/rd install Gtk%3A%3AAccelLabel c:/ruby/share/rbbr/rd install Gtk%3A%3AAccelMap c:/ruby/share/rbbr/rd install Gtk%3A%3AAccessible c:/ruby/share/rbbr/rd install Gtk%3A%3AAdjustment c:/ruby/share/rbbr/rd install Gtk%3A%3AAlignment c:/ruby/share/rbbr/rd install Gtk%3A%3AAllocation c:/ruby/share/rbbr/rd install Gtk%3A%3AArrow c:/ruby/share/rbbr/rd install Gtk%3A%3AAspectFrame c:/ruby/share/rbbr/rd install Gtk%3A%3ABin c:/ruby/share/rbbr/rd install Gtk%3A%3ABox c:/ruby/share/rbbr/rd installGtk%3A%3AButton c:/ruby/share/rbbr/rd install Gtk%3A%3AButtonBox c:/ruby/share/rbbr/rd install Gtk%3A%3ACalendar c:/ruby/share/rbbr/rd install Gtk%3A%3ACellEditable c:/ruby/share/rbbr/rd install Gtk%3A%3ACellRenderer c:/ruby/share/rbbr/rd install Gtk%3A%3ACellRendererPixbuf c:/ruby/share/rbbr/rd install Gtk%3A%3ACellRendererText c:/ruby/share/rbbr/rd install Gtk%3A%3ACellRendererToggle c:/ruby/share/rbbr/rd install Gtk%3A%3ACheckButton c:/ruby/share/rbbr/rd install Gtk%3A%3ACheckMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3AClipboard c:/ruby/share/rbbr/rd install Gtk%3A%3AColorSelection c:/ruby/share/rbbr/rd install Gtk%3A%3AColorSelectionDialog c:/ruby/share/rbbr/rd install Gtk%3A%3ACombo c:/ruby/share/rbbr/rd install Gtk%3A%3ADialog c:/ruby/share/rbbr/rd install Gtk%3A%3ADrag c:/ruby/share/rbbr/rd install Gtk%3A%3ADrawingArea c:/ruby/share/rbbr/rd install Gtk%3A%3AEditable c:/ruby/share/rbbr/rd install Gtk%3A%3AEntry c:/ruby/share/rbbr/rd install Gtk%3A%3AEventBox c:/ruby/share/rbbr/rd install Gtk%3A%3AFileSelection c:/ruby/share/rbbr/rd install Gtk%3A%3AFixed c:/ruby/share/rbbr/rd install Gtk%3A%3AFontSelection c:/ruby/share/rbbr/rd install Gtk%3A%3AFontSelectionDialog c:/ruby/share/rbbr/rd install Gtk%3A%3AFrame c:/ruby/share/rbbr/rd install Gtk%3A%3AGL c:/ruby/share/rbbr/rd install Gtk%3A%3AHandleBox c:/ruby/share/rbbr/rd install Gtk%3A%3AHBox c:/ruby/share/rbbr/rd install Gtk%3A%3AHButtonBox c:/ruby/share/rbbr/rd install Gtk%3A%3AHPaned c:/ruby/share/rbbr/rd install Gtk%3A%3AHRuler c:/ruby/share/rbbr/rd install Gtk%3A%3AHScale c:/ruby/share/rbbr/rd install Gtk%3A%3AHScrollbar c:/ruby/share/rbbr/rd install Gtk%3A%3AHSeparator c:/ruby/share/rbbr/rd install Gtk%3A%3AIconFactory c:/ruby/share/rbbr/rd install Gtk%3A%3AIconSet c:/ruby/share/rbbr/rd install Gtk%3A%3AIconSize c:/ruby/share/rbbr/rd install Gtk%3A%3AIconSource c:/ruby/share/rbbr/rd install Gtk%3A%3AImage c:/ruby/share/rbbr/rd install Gtk%3A%3AImage%3A%3APixmap c:/ruby/share/rbbr/rd install Gtk%3A%3AImageMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3AInputDialog c:/ruby/share/rbbr/rd install Gtk%3A%3AInvisible c:/ruby/share/rbbr/rd install Gtk%3A%3AItem c:/ruby/share/rbbr/rd install Gtk%3A%3AItemFactory c:/ruby/share/rbbr/rd install Gtk%3A%3ALabel c:/ruby/share/rbbr/rd install Gtk%3A%3ALayout c:/ruby/share/rbbr/rd install Gtk%3A%3AListStore c:/ruby/share/rbbr/rd install Gtk%3A%3AMenu c:/ruby/share/rbbr/rd install Gtk%3A%3AMenuBar c:/ruby/share/rbbr/rd install Gtk%3A%3AMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3AMenuShell c:/ruby/share/rbbr/rd install Gtk%3A%3AMessageDialog c:/ruby/share/rbbr/rd install Gtk%3A%3AMisc c:/ruby/share/rbbr/rd install Gtk%3A%3ANotebook c:/ruby/share/rbbr/rd install Gtk%3A%3ANotebookPage c:/ruby/share/rbbr/rd install Gtk%3A%3AObject c:/ruby/share/rbbr/rd install Gtk%3A%3AOptionMenu c:/ruby/share/rbbr/rd install Gtk%3A%3APaned c:/ruby/share/rbbr/rd install Gtk%3A%3APlug c:/ruby/share/rbbr/rd install Gtk%3A%3AProgress c:/ruby/share/rbbr/rd install Gtk%3A%3AProgressBar c:/ruby/share/rbbr/rd install Gtk%3A%3ARadioButton c:/ruby/share/rbbr/rd install Gtk%3A%3ARadioMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3ARange c:/ruby/share/rbbr/rd install Gtk%3A%3AScale c:/ruby/share/rbbr/rd install Gtk%3A%3AScrollbar c:/ruby/share/rbbr/rd install Gtk%3A%3AScrolledWindow c:/ruby/share/rbbr/rd install Gtk%3A%3ASelection c:/ruby/share/rbbr/rd install Gtk%3A%3ASelectionData c:/ruby/share/rbbr/rd install Gtk%3A%3ASeparator c:/ruby/share/rbbr/rd install Gtk%3A%3ASeparatorMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3ASizeGroup c:/ruby/share/rbbr/rd install Gtk%3A%3ASocket c:/ruby/share/rbbr/rd install Gtk%3A%3ASpinButton c:/ruby/share/rbbr/rd install Gtk%3A%3AStatusbar c:/ruby/share/rbbr/rd install Gtk%3A%3AStock c:/ruby/share/rbbr/rd install Gtk%3A%3AStyle c:/ruby/share/rbbr/rd install Gtk%3A%3ATable c:/ruby/share/rbbr/rd install Gtk%3A%3ATargetList c:/ruby/share/rbbr/rd install Gtk%3A%3ATearoffMenuItem c:/ruby/share/rbbr/rd install Gtk%3A%3ATextBuffer c:/ruby/share/rbbr/rd install Gtk%3A%3ATextChildAnchor c:/ruby/share/rbbr/rd install Gtk%3A%3ATextIter c:/ruby/share/rbbr/rd install Gtk%3A%3ATextMark c:/ruby/share/rbbr/rd install Gtk%3A%3ATextTag c:/ruby/share/rbbr/rd install Gtk%3A%3ATextTagTable c:/ruby/share/rbbr/rd install Gtk%3A%3ATextView c:/ruby/share/rbbr/rd install Gtk%3A%3AToggleButton c:/ruby/share/rbbr/rd install Gtk%3A%3AToolbar c:/ruby/share/rbbr/rd install Gtk%3A%3ATooltips c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeDragDest c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeDragSource c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeIter c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeModel c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeModelSort c:/ruby/share/rbbr/rd install Gtk%3A%3ATreePath c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeRowReference c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeSelection c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeSortable c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeStore c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeView c:/ruby/share/rbbr/rd install Gtk%3A%3ATreeViewColumn c:/ruby/share/rbbr/rd install Gtk%3A%3AVBox c:/ruby/share/rbbr/rd install Gtk%3A%3AVButtonBox c:/ruby/share/rbbr/rd install Gtk%3A%3AViewport c:/ruby/share/rbbr/rd install Gtk%3A%3AVPaned c:/ruby/share/rbbr/rd install Gtk%3A%3AVRuler c:/ruby/share/rbbr/rd install Gtk%3A%3AVScale c:/ruby/share/rbbr/rd install Gtk%3A%3AVScrollbar c:/ruby/share/rbbr/rd install Gtk%3A%3AVSeparator c:/ruby/share/rbbr/rd install Gtk%3A%3AWidget c:/ruby/share/rbbr/rd install Gtk%3A%3AWindow c:/ruby/share/rbbr/rd install Gtk%3A%3AWindowGroup c:/ruby/share/rbbr/rd install README c:/ruby/share/rbbr/rd <--- data/rbbr/rd <--- data/rbbr <--- data install.rb: install done. F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>cd c: C:\Documents and Settings\Administrator F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>c: C:\Documents and Settings\Administrator>cd .. C:\Documents and Settings>cd .. C:\>cd ruby C:\ruby>cd bin C:\ruby\bin>ruby rbbr C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16:in `require': No s uch file to load -- gettext (LoadError) from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16 from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39:in `require' from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39 from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35:in `require' from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35 from rbbr:20:in `require' from rbbr:20 C:\ruby\bin> -Rich ----- Original Message ----- From: "Masao Mutoh" To: "ruby-talk ML" Sent: Thursday, December 11, 2003 10:06 AM Subject: Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I get ruby 'extras' to just plain work?!) [ref] > Hi, > > On Thu, 11 Dec 2003 06:55:57 +0900 > "Rich" wrote: >[ref] > > --rbbr-- > > > > 1. Following the install directions - > > "Install > > ------- > > 1. Install Ruby-GetText-Package, ri and ReFe. (All of them are optional) > > 2. De-Compress ruby-gnome2-api.tar.gz and rbbr's archive(Optional) > > withapi package include this api files. > > 3. Puts ruby-gnome2-api/* to (rbbr's top directory)/data/rbbr/rd/* > > 4. Move rbbr's top directory and type: > > > > $ ruby install.rb config > > $ ruby install.rb setup > > ($ su) > > # ruby install.rb install > > > > You can also install files in your favor directory by > > supplying install.rb some options. Try "ruby setup.rb --help"." > > > > #1 - no > > #2 - yes > > #3 - no > > #4 - yes (install.rb config, install.rb setup, install.rb install) > > > > 2. I then went to the Usage section - > > "Usage > > ----- > > > > Run the following command: > > > > $ rbbr" > > > > This makes no sense to me... so I found the file 'rbbr' > > (C:\ruby\lib\ruby\site_ruby\1.8\rbbr) and... > > - double clicked (it asked what to use to open it... and I said Cancel) > > - changed it's name to have the extension '.rb' and double clicked[/ref][/ref] it...[ref][ref] > > the console window opened then closed. > > - went to the same location and typed 'ruby rbbr.rb' into the command > > prompt and... > > "C:\ruby\lib\ruby\site_ruby\1.8>ruby rbbr.rb > > c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16:in[/ref][/ref] `require':[ref][ref] > > No s > > uch file to load -- gettext (LoadError) > > from[/ref][/ref] c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16[ref][ref] > > from c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39:in[/ref][/ref] `require'[ref][ref] > > from c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39 > > from rbbr.rb:35:in `require' > > from rbbr.rb:35"[/ref] > > 1. Re-install rbbr. > 2. cd c:\ruby\bin > 3. ruby rbbr > > Can you execute rbbr? > If not, what's the error messages? > > -- > .:% Masao Mutoh >[/ref] [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => <000a01c3c032$10a2d330$2e00a8c0@stone> [ref] => <83173408.0312090552.3089857@posting.google.com><000501c3bec9$4d4223f0$2e00a8c0@stone><20031210102002.GA6031@lb.tenfour><000401c3bf68$96b78760$2e00a8c0@stone> <20031212020601.14a2d3c2.mutoh@highway.ne.jp> [htmlstate] => on_nl2br [postusername] => Rich [ip] => rich@lithinos.c [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 9 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) --> ANN: REXML 2.7.2 - Ruby

ANN: REXML 2.7.2 - Ruby

Hi, Long time, no release. 2.7.2 is in the CVS repository, so it should be included with Ruby 1.8.1. Here's the change log since 2.7.1: * More fixes for compatability with the Ruby 1.8 series * Exceptions are normalized * Some changes to the Light API * Improvements to encoding support. iconv is now used whenever possible, falling back to the old encoding mechanism for backwards compatability (Ruby < 1.8) * Bug to maintain inline external entity instances * Removed a cascading tainting issue with encoding * Function::string() now handles Element nodes properly, which means that XPath text() now works ...

  1. #1

    Default ANN: REXML 2.7.2

    Hi,

    Long time, no release.

    2.7.2 is in the CVS repository, so it should be included with Ruby
    1.8.1.

    Here's the change log since 2.7.1:
    * More fixes for compatability with the Ruby 1.8 series
    * Exceptions are normalized
    * Some changes to the Light API
    * Improvements to encoding support. iconv is now used whenever
    possible, falling back to the old encoding mechanism for backwards
    compatability (Ruby < 1.8)
    * Bug to maintain inline external entity instances
    * Removed a cascading tainting issue with encoding
    * Function::string() now handles Element nodes properly, which means
    that XPath text() now works properly.
    * A minor indentation bug was fixed
    * Applied a patch from Simon Conrad-Armes that improves REXML's
    handling of namespaces in the SAX2 pr
    * Encoding support is more reliable and thread resistant. The Output
    class now works like you'd intuitively expect it to. It is now much
    easier to shift between encodings in various was -- by changing the
    encoding, by creating an Output with the encoding, etc.
    * Doent::DECLARATION is deprecated. Use XMLDecl::default() (static
    method).

    Thanks to all the people who submitted patches, fixed, or reported
    bugs.

    Notice that most of these changes are bug fixes. Optimization is
    still the issue that's at the top of my list, but I've had a hard time
    getting anywhere with it. Ruby optimizations are entirely
    counterintuitive to me; I think this is just the nature of high level
    languages.

    My optimization strategy includes a three-pronged attack:

    * Optimize the base pr. This will improve performance across
    REXML, since all prs use it.
    * Finalize the Light API. This will improve (memory) space
    requirements for those who choose to use it, and will provide the
    leanest, fastest possible tree pr.
    * Add libxml awareness. That is, if REXML sees libxml is installed,
    it'll use that as the base pr instead of the native Ruby pr.

    Next in line after optimization is doentation. The main
    doentation needs to be rewritten, and I need to work on the
    changelog. I've got a system for automating the changelog, but I need
    to merge it with the REXML project. The tutorial is out of date, and
    incomplete, and I haven't looked at the rdoc output in a while -- I'm
    sure it's pretty ugly.

    Just below that is the creation of some utility classes, which
    probably won't become part of the standard REXML distribution: RelaxNG
    validation, an XPath tool, and so on. Then there's some work on
    Namespace support that Tobias has been hounding me about; I've placed
    that on the back burner for the moment, because it only applies to
    writing sub-trees -- which, while admittedly desireable, isn't useful
    in any XML processing *I* do, and requires a major overhaul of
    Namespace support in REXML. If this is important to anybody, I
    recommend contributing patches to REXML, 'cause I've got other things
    which I think are more important, and I don't know when I'm going to
    get to it.

    Finally, I've been really bad about getting back to people, and I'm
    sorry about that. The bug tracker has been having chronic problems
    since we upgraded the server, and I haven't had time to fix it. I've
    dropped the Freshmeat entry; it was too much of a pain maintaining 4
    release announcement mechanisms.

    BTW, the darcs repository is now the preferred repository to make
    changes in, despite the fact that the Subversion repository is listed
    in the RAA. The reason is that it is much easier for users to submit,
    and for me to accept, darcs patches; as Subversion doesn't have any
    concept of patches, I have to either provide direct write access to
    the repository to contributors, or I have to manually pick apart and
    apply patches, and darcs is just easier.

    The REXML home page is, as always,

    http://www.germane-software.com/software/XML/rexml/

    The Subversion repository is at:

    http://www.germane-software.com/repositories/public/rexml

    with the standard trunk/, tags/, and branches/ subhierarchy.

    The darcs repository is at:

    http://www.germane-software.com/darcs/rexml

    That's the root of the development branch.

    darcs is at:

    http://abridgegame.org/darcs/


    Thanks for your patience,

    Sean

    --
    ### SER
    ### Deutsch|Esperanto|Francaise|Linux|XML|Java|Ruby|Ai kido|Dirigibles
    ### http://www.germane-software.com/~ser jabber.com:ser ICQ:83578737
    ### GPG: http://www.germane-software.com/~ser/Security/ser_public.gpg
    Sean Guest

  2. #2

    Default Why can't I get ruby 'extras' to just plain work?!

    I'm getting really frustrated.

    First: I'm not a professional programmer - programming is a hobby with me,
    so I'll be the first to admit - I don't really know what I'm doing but I
    should know enough.
    Second: I absolutely _love_ Ruby and everything that I've been able to do.
    Third: I can't get anything to work.

    I'm on Win2000. I used the PragProg installer for the latest 1.8 release...
    and I can't get...
    mysql-ruby-2.4.2-1-winpkg
    or,
    rexml_2.7.2
    or,
    exerb-win32-2.6.5.0
    or,
    rbbr-0.5.0-withapi.tar.gz
    to work - at all...

    I read the doentation online and in the downloaded files I do exactly (to
    the best of my knowledge) what I'm supposed to do - in short, I try my best
    and I still can't get anything to work.

    I feel like a kid in a candy shop where the candy I want is an illusion and
    I'm startin' to not like the candy shop very much. : - (

    What do I need to do to solve my problem??

    Could I request better install docs in general? Not everybody who uses Ruby
    is a Linux Admin...

    Thanks in advance for all the help I can get!!

    -Rich
    P.s. - Please no suggestions of switching to Linux... : - )


    Rich Guest

  3. #3

    Default Re: Why can't I get ruby 'extras' to just plain work?!

    * Rich <com> [1256 02:56]:
     

    Do you get errors? What are they?

    --
    I do not fear computers. I fear the lack of them.
    -- Isaac Asimov
    Rasputin :: Jack of All Trades - Master of Nuns

    Rasputin Guest

  4. #4

    Default rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I get ruby 'extras' to just plain work?!)

    --rexml--

    1. Using a file with these lines: 

    2. I get this error:
    "D:\rubyMine\rexml\tests>ruby include.rb
    c:/ruby/lib/ruby/site_ruby/1.8/rexml/encoding.rb:39:in `load': No such file
    to l
    oad -- rexml/encodings/UTF-8.rb (LoadError)
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/encoding.rb:39:in
    `old_enc='
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/xmldecl.rb:74:in
    `encoding='
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/xmldecl.rb:30:in
    `initialize'
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/xmldecl.rb:84:in `new'
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/xmldecl.rb:84:in `default'
    from c:/ruby/lib/ruby/site_ruby/1.8/rexml/doent.rb:24
    from include.rb:1:in `require'
    from include.rb:1"

    3. I've looked at the file to see what it was trying to load - and it's
    trying to load "rexml/encodings/UTF-8.rb". I don't have that file. I
    downloaded 3 different times to see if maybe it just wasn't in the Zip file
    I downloaded. No luck.

    --rbbr--

    1. Following the install directions -
    "Install
    -------
    1. Install Ruby-GetText-Package, ri and ReFe. (All of them are optional)
    2. De-Compress ruby-gnome2-api.tar.gz and rbbr's archive(Optional)
    withapi package include this api files.
    3. Puts ruby-gnome2-api/* to (rbbr's top directory)/data/rbbr/rd/*
    4. Move rbbr's top directory and type:

    $ ruby install.rb config
    $ ruby install.rb setup
    ($ su)
    # ruby install.rb install

    You can also install files in your favor directory by
    supplying install.rb some options. Try "ruby setup.rb --help"."

    #1 - no
    #2 - yes
    #3 - no
    #4 - yes (install.rb config, install.rb setup, install.rb install)

    2. I then went to the Usage section -
    "Usage
    -----

    Run the following command:

    $ rbbr"

    This makes no sense to me... so I found the file 'rbbr'
    (C:\ruby\lib\ruby\site_ruby\1.8\rbbr) and...
    - double clicked (it asked what to use to open it... and I said Cancel)
    - changed it's name to have the extension '.rb' and double clicked it...
    the console window opened then closed.
    - went to the same location and typed 'ruby rbbr.rb' into the command
    prompt and...
    "C:\ruby\lib\ruby\site_ruby\1.8>ruby rbbr.rb
    c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16:in `require':
    No s
    uch file to load -- gettext (LoadError)
    from c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16
    from c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39:in `require'
    from c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39
    from rbbr.rb:35:in `require'
    from rbbr.rb:35"

    --mysql-ruby-- ( I noticed that what I referred to earlier was wrong -
    sorry!! This is the right name for what I tried to get working...)

    1. Following Install section:
    " Install
    % ruby ./setup.rb
    % ruby ./test.rb hostname user passwd
    # ruby ./install.rb"

    When I type "ruby setup.rb" into a command prompt I get:
    "F:\rubyAll\ruby-mysql-0.2.2.tar.gz\ruby-mysql-0.2.2.tar\ruby-mysql-0.2.2>ru
    by se
    tup.rb
    setup.rb:8:in ``': No such file or directory - mysql_config --socket
    (Errno::ENO
    ENT)
    from setup.rb:8"

    --exerb--

    When I run the file "exerb-win32.exe" inside
    "F:\rubyAll\exerb-win32-2.6.5.0\exerb-win32-2.6.5.0" all I get are old
    versions of Ruby (1.68)... I'm using 1.8. What do I need to do to get it to
    compile my scripts to 1.8?


    I think that covers it... thanks for listening to my problems - I'm really
    grateful for any help I can get...

    -Rich


    ----- Original Message -----
    From: "Rasputin" <mine.nu>
    To: "ruby-talk ML" <org>
    Sent: Wednesday, December 10, 2003 3:20 AM
    Subject: Re: Why can't I get ruby 'extras' to just plain work?!

     [/ref]
    release... [/ref]
    (to [/ref]
    best 
    >
    > Do you get errors? What are they?
    >
    > --
    > I do not fear computers. I fear the lack of them.
    > -- Isaac Asimov
    > Rasputin :: Jack of All Trades - Master of Nuns
    >[/ref]


    Rich Guest

  5. #5

    Default Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I get ruby 'extras' to just plain work?!)

    Hi Rich,

    I have no answer to the rest of your problems, but

    "Rich" <com> wrote: 
    You have to specify it in your recipe file. And to use 1.8 core,
    you need to install exerb or or exerb core collection from
    http://exerb.sourceforge.jp/index.en.html . The doentation of
    recipe file can be found in doc directory of exerb.

    By the way, exerb is now under major rework and the current
    version is 3.0.0-preview7, however the doentation in
    English is not ready yet. (exerb-win32 has not been released
    for 3.0.0 exerb.)
     

    Takashi Sano


    Takashi Guest

  6. #6

    Default Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I get ruby 'extras' to just plain work?!)

    Awesome - I'll try and wait for the 3.0.0 release then

    Will the Windows version be released at the same time?

    BTW - thanks for paying attention to me - I feel ignored sometimes... :-)

    -Rich

    ----- Original Message -----
    From: "Takashi & Kayoko Sano" <kcn.ne.jp>
    To: "ruby-talk ML" <org>
    Sent: Wednesday, December 10, 2003 6:22 PM
    Subject: Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I
    get ruby 'extras' to just plain work?!)

     
    > You have to specify it in your recipe file. And to use 1.8 core,
    > you need to install exerb or or exerb core collection from
    > http://exerb.sourceforge.jp/index.en.html . The doentation of
    > recipe file can be found in doc directory of exerb.
    >
    > By the way, exerb is now under major rework and the current
    > version is 3.0.0-preview7, however the doentation in
    > English is not ready yet. (exerb-win32 has not been released
    > for 3.0.0 exerb.)

    >
    > Takashi Sano
    >[/ref]



    Rich Guest

  7. #7

    Default Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I get ruby 'extras' to just plain work?!)

    Hi Rich,

    "Rich" <com> wrote: 

    I'm not the author, so I don't know. But you can use exerb
    (not exerb-win32) instead. You can install it just by
    typing what the readme file says on the command line.
    Though We Windows people generally prefer GUI...

    I forgot to mention, but the latest exerb is now resolved
    some problems on extensions it had before, such as YAML's
    Syck cannot be used with exerb. As far as I know, now you
    can require yaml in your program to be compiled with exerb.
    If anyone had a problem with it, try the current release.
     

    Takashi Sano

    Takashi Guest

  8. #8

    Default Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't Iget ruby 'extras' to just plain work?!)

    Hi,

    On Thu, 11 Dec 2003 06:55:57 +0900
    "Rich" <com> wrote:
     

    1. Re-install rbbr.
    2. cd c:\ruby\bin
    3. ruby rbbr

    Can you execute rbbr?
    If not, what's the error messages?

    --
    :% Masao Mutoh<ne.jp>


    Masao Guest

  9. #9

    Default rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    Thanks for your suggestions (and for your patience) ... here is everything
    that happens when I...
     

    F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>ruby
    inst
    all.rb config
    install.rb: entering config phase...
    ---> bin
    <--- bin
    ---> lib
    ---> lib/rbbr
    ---> lib/rbbr/doc
    <--- lib/rbbr/doc
    ---> lib/rbbr/ui
    ---> lib/rbbr/ui/gtk
    <--- lib/rbbr/ui/gtk
    <--- lib/rbbr/ui
    <--- lib/rbbr
    <--- lib
    ---> data
    ---> data/locale
    ---> data/locale/fr
    ---> data/locale/fr/LC_MESSAGES
    <--- data/locale/fr/LC_MESSAGES
    <--- data/locale/fr
    ---> data/locale/ja
    ---> data/locale/ja/LC_MESSAGES
    <--- data/locale/ja/LC_MESSAGES
    <--- data/locale/ja
    <--- data/locale
    ---> data/rbbr
    ---> data/rbbr/rd
    <--- data/rbbr/rd
    <--- data/rbbr
    <--- data
    install.rb: config done.

    F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>ruby
    inst
    all.rb setup
    install.rb: entering setup phase...
    L10n is not supported on this environment.
    ---> bin
    set #! line to "#!c:/ruby/bin/ruby" for
    F:/rubyAll/rbbr-0.5.0-withapi.tar.gz/rbb
    r-0.5.0-withapi.tar/rbbr-0.5.0/bin/rbbr ...
    rm -f rbbr
    rm -f rbbr.tmp
    <--- bin
    ---> lib
    ---> lib/rbbr
    ---> lib/rbbr/doc
    <--- lib/rbbr/doc
    ---> lib/rbbr/ui
    ---> lib/rbbr/ui/gtk
    <--- lib/rbbr/ui/gtk
    <--- lib/rbbr/ui
    <--- lib/rbbr
    <--- lib
    ---> data
    ---> data/locale
    ---> data/locale/fr
    ---> data/locale/fr/LC_MESSAGES
    <--- data/locale/fr/LC_MESSAGES
    <--- data/locale/fr
    ---> data/locale/ja
    ---> data/locale/ja/LC_MESSAGES
    <--- data/locale/ja/LC_MESSAGES
    <--- data/locale/ja
    <--- data/locale
    ---> data/rbbr
    ---> data/rbbr/rd
    <--- data/rbbr/rd
    <--- data/rbbr
    <--- data
    install.rb: setup done.

    F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>ruby
    inst
    all.rb install
    install.rb: entering install phase...
    ---> bin
    mkdir -p c:/ruby/bin/
    install rbbr c:/ruby/bin/
    <--- bin
    ---> lib
    mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/
    install rbbr.rb c:/ruby/lib/ruby/site_ruby/1.8/
    ---> lib/rbbr
    mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr
    install config.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr
    install doc.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr
    install metainfo.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr
    ---> lib/rbbr/doc
    mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc
    install rd.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc
    install refe.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc
    install ri.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/doc
    <--- lib/rbbr/doc
    ---> lib/rbbr/ui
    mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui
    install gtk.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui
    ---> lib/rbbr/ui/gtk
    mkdir -p c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install aboutdialog.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install browselist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install browser.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install confmanager.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install constlist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install docviewer.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install libselectiondialog.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install methodlist.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install moduledisplay.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install modulelabel.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install modulelistview.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install moduletreeview.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install stockbrowser.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    install windowutils.rb c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk
    <--- lib/rbbr/ui/gtk
    <--- lib/rbbr/ui
    <--- lib/rbbr
    <--- lib
    ---> data
    mkdir -p c:/ruby/share/
    ---> data/locale
    mkdir -p c:/ruby/share/locale
    ---> data/locale/fr
    mkdir -p c:/ruby/share/locale/fr
    ---> data/locale/fr/LC_MESSAGES
    mkdir -p c:/ruby/share/locale/fr/LC_MESSAGES
    <--- data/locale/fr/LC_MESSAGES
    <--- data/locale/fr
    ---> data/locale/ja
    mkdir -p c:/ruby/share/locale/ja
    ---> data/locale/ja/LC_MESSAGES
    mkdir -p c:/ruby/share/locale/ja/LC_MESSAGES
    <--- data/locale/ja/LC_MESSAGES
    <--- data/locale/ja
    <--- data/locale
    ---> data/rbbr
    mkdir -p c:/ruby/share/rbbr
    install icon.png c:/ruby/share/rbbr
    ---> data/rbbr/rd
    mkdir -p c:/ruby/share/rbbr/rd
    install GConf c:/ruby/share/rbbr/rd
    install GConf%3A%3ABadAddressError c:/ruby/share/rbbr/rd
    install GConf%3A%3ABadAdressError c:/ruby/share/rbbr/rd
    install GConf%3A%3ABadKeyError c:/ruby/share/rbbr/rd
    install GConf%3A%3AChangeSet c:/ruby/share/rbbr/rd
    install GConf%3A%3AClient c:/ruby/share/rbbr/rd
    install GConf%3A%3ACorruptError c:/ruby/share/rbbr/rd
    install GConf%3A%3AEngine c:/ruby/share/rbbr/rd
    install GConf%3A%3AEntry c:/ruby/share/rbbr/rd
    install GConf%3A%3AError c:/ruby/share/rbbr/rd
    install GConf%3A%3AFailedError c:/ruby/share/rbbr/rd
    install GConf%3A%3AInShutdownError c:/ruby/share/rbbr/rd
    install GConf%3A%3AIsDirError c:/ruby/share/rbbr/rd
    install GConf%3A%3AIsKeyError c:/ruby/share/rbbr/rd
    install GConf%3A%3ALocalEngineError c:/ruby/share/rbbr/rd
    install GConf%3A%3ALockFailedError c:/ruby/share/rbbr/rd
    install GConf%3A%3AMetaInfo c:/ruby/share/rbbr/rd
    install GConf%3A%3ANoPermissionError c:/ruby/share/rbbr/rd
    install GConf%3A%3ANoServerError c:/ruby/share/rbbr/rd
    install GConf%3A%3ANoWritableDatabaseError c:/ruby/share/rbbr/rd
    install GConf%3A%3AOafError c:/ruby/share/rbbr/rd
    install GConf%3A%3AOverriddenError c:/ruby/share/rbbr/rd
    install GConf%3A%3APError c:/ruby/share/rbbr/rd
    install GConf%3A%3ASchema c:/ruby/share/rbbr/rd
    install GConf%3A%3ATypeMismatchError c:/ruby/share/rbbr/rd
    install Gdk c:/ruby/share/rbbr/rd
    install Gdk%3A%3AAtom c:/ruby/share/rbbr/rd
    install Gdk%3A%3AColor c:/ruby/share/rbbr/rd
    install Gdk%3A%3AColormap c:/ruby/share/rbbr/rd
    install Gdk%3A%3ACursor c:/ruby/share/rbbr/rd
    install Gdk%3A%3ADrawable c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGL c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGL%3A%3AContext c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGLConfig c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGLContext c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGLDrawable c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGLPixmap c:/ruby/share/rbbr/rd
    install Gdk%3A%3AGLWindow c:/ruby/share/rbbr/rd
    install Gdk%3A%3AImage c:/ruby/share/rbbr/rd
    install Gdk%3A%3AKeyval c:/ruby/share/rbbr/rd
    install Gdk%3A%3APixmap c:/ruby/share/rbbr/rd
    install Gdk%3A%3ARectangle c:/ruby/share/rbbr/rd
    install Gdk%3A%3ARegion c:/ruby/share/rbbr/rd
    install Gdk%3A%3ARGB c:/ruby/share/rbbr/rd
    install Gdk%3A%3AThread c:/ruby/share/rbbr/rd
    install Gdk%3A%3AWindow c:/ruby/share/rbbr/rd
    install GLib c:/ruby/share/rbbr/rd
    install GLib%3A%3AInstantiatable c:/ruby/share/rbbr/rd
    install GLib%3A%3AType c:/ruby/share/rbbr/rd
    install Gst c:/ruby/share/rbbr/rd
    install Gst%3A%3AAutoplug c:/ruby/share/rbbr/rd
    install Gst%3A%3AAutoplugFactory c:/ruby/share/rbbr/rd
    install Gst%3A%3ABin c:/ruby/share/rbbr/rd
    install Gst%3A%3ACaps c:/ruby/share/rbbr/rd
    install Gst%3A%3AClock c:/ruby/share/rbbr/rd
    install Gst%3A%3AClockEntry c:/ruby/share/rbbr/rd
    install Gst%3A%3ACpu c:/ruby/share/rbbr/rd
    install Gst%3A%3AElement c:/ruby/share/rbbr/rd
    install Gst%3A%3AElementFactory c:/ruby/share/rbbr/rd
    install Gst%3A%3AEvent c:/ruby/share/rbbr/rd
    install Gst%3A%3AEventMask c:/ruby/share/rbbr/rd
    install Gst%3A%3AEventSeek c:/ruby/share/rbbr/rd
    install Gst%3A%3AEventSegmentSeek c:/ruby/share/rbbr/rd
    install Gst%3A%3AEventSize c:/ruby/share/rbbr/rd
    install Gst%3A%3AFormat c:/ruby/share/rbbr/rd
    install Gst%3A%3AIndexFactory c:/ruby/share/rbbr/rd
    install Gst%3A%3AObject c:/ruby/share/rbbr/rd
    install Gst%3A%3APad c:/ruby/share/rbbr/rd
    install Gst%3A%3APadTemplate c:/ruby/share/rbbr/rd
    install Gst%3A%3AP c:/ruby/share/rbbr/rd
    install Gst%3A%3APipeline c:/ruby/share/rbbr/rd
    install Gst%3A%3APlugin c:/ruby/share/rbbr/rd
    install Gst%3A%3APluginFeature c:/ruby/share/rbbr/rd
    install Gst%3A%3AQueryType c:/ruby/share/rbbr/rd
    install Gst%3A%3ARegistry c:/ruby/share/rbbr/rd
    install Gst%3A%3ASchedulerFactory c:/ruby/share/rbbr/rd
    install Gst%3A%3ASystemClock c:/ruby/share/rbbr/rd
    install Gst%3A%3AThread c:/ruby/share/rbbr/rd
    install Gst%3A%3AType c:/ruby/share/rbbr/rd
    install Gst%3A%3ATypeFactory c:/ruby/share/rbbr/rd
    install Gst%3A%3AXML c:/ruby/share/rbbr/rd
    install Gtk c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAccelerator c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAccelGroup c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAccelLabel c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAccelMap c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAccessible c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAdjustment c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAlignment c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAllocation c:/ruby/share/rbbr/rd
    install Gtk%3A%3AArrow c:/ruby/share/rbbr/rd
    install Gtk%3A%3AAspectFrame c:/ruby/share/rbbr/rd
    install Gtk%3A%3ABin c:/ruby/share/rbbr/rd
    install Gtk%3A%3ABox c:/ruby/share/rbbr/rd
    installGtk%3A%3AButton c:/ruby/share/rbbr/rd
    install Gtk%3A%3AButtonBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACalendar c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACellEditable c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACellRenderer c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACellRendererPixbuf c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACellRendererText c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACellRendererToggle c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACheckButton c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACheckMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3AClipboard c:/ruby/share/rbbr/rd
    install Gtk%3A%3AColorSelection c:/ruby/share/rbbr/rd
    install Gtk%3A%3AColorSelectionDialog c:/ruby/share/rbbr/rd
    install Gtk%3A%3ACombo c:/ruby/share/rbbr/rd
    install Gtk%3A%3ADialog c:/ruby/share/rbbr/rd
    install Gtk%3A%3ADrag c:/ruby/share/rbbr/rd
    install Gtk%3A%3ADrawingArea c:/ruby/share/rbbr/rd
    install Gtk%3A%3AEditable c:/ruby/share/rbbr/rd
    install Gtk%3A%3AEntry c:/ruby/share/rbbr/rd
    install Gtk%3A%3AEventBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AFileSelection c:/ruby/share/rbbr/rd
    install Gtk%3A%3AFixed c:/ruby/share/rbbr/rd
    install Gtk%3A%3AFontSelection c:/ruby/share/rbbr/rd
    install Gtk%3A%3AFontSelectionDialog c:/ruby/share/rbbr/rd
    install Gtk%3A%3AFrame c:/ruby/share/rbbr/rd
    install Gtk%3A%3AGL c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHandleBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHButtonBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHPaned c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHRuler c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHScale c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHScrollbar c:/ruby/share/rbbr/rd
    install Gtk%3A%3AHSeparator c:/ruby/share/rbbr/rd
    install Gtk%3A%3AIconFactory c:/ruby/share/rbbr/rd
    install Gtk%3A%3AIconSet c:/ruby/share/rbbr/rd
    install Gtk%3A%3AIconSize c:/ruby/share/rbbr/rd
    install Gtk%3A%3AIconSource c:/ruby/share/rbbr/rd
    install Gtk%3A%3AImage c:/ruby/share/rbbr/rd
    install Gtk%3A%3AImage%3A%3APixmap c:/ruby/share/rbbr/rd
    install Gtk%3A%3AImageMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3AInputDialog c:/ruby/share/rbbr/rd
    install Gtk%3A%3AInvisible c:/ruby/share/rbbr/rd
    install Gtk%3A%3AItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3AItemFactory c:/ruby/share/rbbr/rd
    install Gtk%3A%3ALabel c:/ruby/share/rbbr/rd
    install Gtk%3A%3ALayout c:/ruby/share/rbbr/rd
    install Gtk%3A%3AListStore c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMenu c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMenuBar c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMenuShell c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMessageDialog c:/ruby/share/rbbr/rd
    install Gtk%3A%3AMisc c:/ruby/share/rbbr/rd
    install Gtk%3A%3ANotebook c:/ruby/share/rbbr/rd
    install Gtk%3A%3ANotebookPage c:/ruby/share/rbbr/rd
    install Gtk%3A%3AObject c:/ruby/share/rbbr/rd
    install Gtk%3A%3AOptionMenu c:/ruby/share/rbbr/rd
    install Gtk%3A%3APaned c:/ruby/share/rbbr/rd
    install Gtk%3A%3APlug c:/ruby/share/rbbr/rd
    install Gtk%3A%3AProgress c:/ruby/share/rbbr/rd
    install Gtk%3A%3AProgressBar c:/ruby/share/rbbr/rd
    install Gtk%3A%3ARadioButton c:/ruby/share/rbbr/rd
    install Gtk%3A%3ARadioMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3ARange c:/ruby/share/rbbr/rd
    install Gtk%3A%3AScale c:/ruby/share/rbbr/rd
    install Gtk%3A%3AScrollbar c:/ruby/share/rbbr/rd
    install Gtk%3A%3AScrolledWindow c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASelection c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASelectionData c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASeparator c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASeparatorMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASizeGroup c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASocket c:/ruby/share/rbbr/rd
    install Gtk%3A%3ASpinButton c:/ruby/share/rbbr/rd
    install Gtk%3A%3AStatusbar c:/ruby/share/rbbr/rd
    install Gtk%3A%3AStock c:/ruby/share/rbbr/rd
    install Gtk%3A%3AStyle c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATable c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATargetList c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATearoffMenuItem c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextBuffer c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextChildAnchor c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextIter c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextMark c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextTag c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextTagTable c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATextView c:/ruby/share/rbbr/rd
    install Gtk%3A%3AToggleButton c:/ruby/share/rbbr/rd
    install Gtk%3A%3AToolbar c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATooltips c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeDragDest c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeDragSource c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeIter c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeModel c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeModelSort c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreePath c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeRowReference c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeSelection c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeSortable c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeStore c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeView c:/ruby/share/rbbr/rd
    install Gtk%3A%3ATreeViewColumn c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVButtonBox c:/ruby/share/rbbr/rd
    install Gtk%3A%3AViewport c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVPaned c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVRuler c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVScale c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVScrollbar c:/ruby/share/rbbr/rd
    install Gtk%3A%3AVSeparator c:/ruby/share/rbbr/rd
    install Gtk%3A%3AWidget c:/ruby/share/rbbr/rd
    install Gtk%3A%3AWindow c:/ruby/share/rbbr/rd
    install Gtk%3A%3AWindowGroup c:/ruby/share/rbbr/rd
    install README c:/ruby/share/rbbr/rd
    <--- data/rbbr/rd
    <--- data/rbbr
    <--- data
    install.rb: install done.

    F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>cd c:
    C:\Doents and Settings\Administrator

    F:\rubyAll\rbbr-0.5.0-withapi.tar.gz\rbbr-0.5.0-withapi.tar\rbbr-0.5.0>c:

    C:\Doents and Settings\Administrator>cd ..

    C:\Doents and Settings>cd ..

    C:\>cd ruby

    C:\ruby>cd bin

    C:\ruby\bin>ruby rbbr
    C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16:in `require':
    No s
    uch file to load -- gettext (LoadError)
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39:in `require'
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:39
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35:in `require'
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35
    from rbbr:20:in `require'
    from rbbr:20

    C:\ruby\bin>


    -Rich


    ----- Original Message -----
    From: "Masao Mutoh" <ne.jp>
    To: "ruby-talk ML" <org>
    Sent: Thursday, December 11, 2003 10:06 AM
    Subject: Re: rexml, rbbr, ruby-mysql, and exerb errors (was: Re: Why can't I
    get ruby 'extras' to just plain work?!)

     [/ref]
    it... [/ref]
    `require': [/ref]
    c:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16 [/ref]
    `require' 
    >
    > 1. Re-install rbbr.
    > 2. cd c:\ruby\bin
    > 3. ruby rbbr
    >
    > Can you execute rbbr?
    > If not, what's the error messages?
    >
    > --
    > .:% Masao Mutoh<ne.jp>
    >[/ref]



    Rich Guest

  10. #10

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerberrors)

    Hi,

    Thanks for detail reporting.

    On Fri, 12 Dec 2003 06:58:02 +0900
    "Rich" <com> wrote:
     [/ref]
     

    This is a bug of rbbr when the environment doesn't have gettext.

    When you remove line 16 of stockbrowser.rb ?
    and then, does it work?

    Sorry for inconvenient.

    --- stockbrowser.rb.old 2003-12-13 16:06:25.000000000 +0900
    +++ stockbrowser.rb 2003-12-13 16:06:30.000000000 +0900
    -13,7 +13,6

    =end

    -require 'gettext'
    require 'gtk2'
    require 'observer'


    --
    :% Masao Mutoh<ne.jp>


    Masao Guest

  11. #11

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    So the first 18 lines of file 'stockbrowser.rb' at location
    'C:\ruby\lib\ruby\site_ruby\1.8\rbbr\ui\gtk'

    should look like this -

    =begin

    rbbr/ui/gtk/stockview.rb

    $Author: mutoh $
    $Date: 2003/12/06 13:56:57 $

    Copyright (C) 2002 Ruby-GNOME2 Project

    This program is free software.
    You can distribute/modify this program under
    the terms of the Ruby Distribute License.

    =end

    #require 'gettext'
    require 'gtk2'
    require 'observer'


    ... and then I run

    C:\ruby\bin>ruby rbbr
    C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:49: undefined
    method `
    +' for nil:NilClass (NoMethodError)
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:42:in `require'
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:42
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35:in `require'
    from C:/ruby/lib/ruby/site_ruby/1.8/rbbr.rb:35
    from rbbr:20:in `require'
    from rbbr:20

    Is that fixable?

    Thanks again for all of your help...

    -Rich


    ----- Original Message -----
    From: "Masao Mutoh" <ne.jp>
    To: "ruby-talk ML" <org>
    Sent: Saturday, December 13, 2003 12:08 AM
    Subject: Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb
    errors)

     [/ref]
    everything [/ref]
    > [/ref]
    `require': [/ref]
    C:/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/stockbrowser.rb:16 [/ref]
    `require' 
    >
    > This is a bug of rbbr when the environment doesn't have gettext.
    >
    > When you remove line 16 of stockbrowser.rb ?
    > and then, does it work?
    >
    > Sorry for inconvenient.
    >
    > --- stockbrowser.rb.old 2003-12-13 16:06:25.000000000 +0900
    > +++ stockbrowser.rb 2003-12-13 16:06:30.000000000 +0900
    > -13,7 +13,6
    >
    > =end
    >
    > -require 'gettext'
    > require 'gtk2'
    > require 'observer'
    >
    >
    > --
    > .:% Masao Mutoh<ne.jp>
    >[/ref]



    Rich Guest

  12. #12

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerberrors)

    Hi,

    On Sun, 14 Dec 2003 03:05:46 +0900
    "Rich" <com> wrote:
     

    Good.
     

    The errors is caused not to be set HOME environment variable.
    So the workarround is to set HOME correctly on dos prompt:

    set HOME=c:\your\own\directory

    or you can set it with Control Panel as a permanent environment variable.
     

    You're welcome ;).

    BTW,
    I intend to release rbbr-0.5.1 for MS Windows
    if your problem will be fixed.
    So keep to report your problems until you succeed to run rbbr, please ;).

    --
    .:% Masao Mutoh<ne.jp>

    Masao Guest

  13. #13

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    ----- Original Message -----
    From: "Masao Mutoh" <ne.jp>
    To: "ruby-talk ML" <org>
    Sent: Sunday, December 14, 2003 6:00 AM
    Subject: Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb
    errors)

     


    Do you mean that I have to set 'Path' Environment Variable?

    It's set to:
    "C:\GTK\2.0\bin;C:\GTK\2.0\lib;c:\ruby\bin;%System Root%\system32;%SystemRoot
    %;%SystemRoot%\System32\Wbem"

    I'm not sure if you mean for me to create a new Environment Variable - or to
    change an existing one...

    I'm also not sure what you mean when you say to set HOME to
    'c:\your\own\directory'. Is this a specific folder? The Ruby 'bin' folder or
    the GTK2 'bin' folder? I'm not sure what to set it to...

    Again - I can't tell you how nice it is to finally get someone who's willing
    to help me... thanks. I'll keep doing what you tell me to...

    -Rich

     
    >
    > You're welcome ;).
    >
    > BTW,
    > I intend to release rbbr-0.5.1 for MS Windows
    > if your problem will be fixed.
    > So keep to report your problems until you succeed to run rbbr, please ;).
    >
    > --
    > .:% Masao Mutoh<ne.jp>
    >[/ref]



    Rich Guest

  14. #14

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    il Sun, 14 Dec 2003 22:00:17 +0900, Masao Mutoh <ne.jp>
    ha scritto::

     
    >
    >You're welcome ;).
    >
    >BTW,
    >I intend to release rbbr-0.5.1 for MS Windows
    >if your problem will be fixed.
    >So keep to report your problems until you succeed to run rbbr, please ;).[/ref]

    wow, if you're going to correct such issues[1], I'd like to add dsome
    more:

    my environment is
    winxp pro
    ruby 1.8.0 (2003-08-04) [i386-mswin32]
    ruby-gtk 0.8
    gtk from dropline 2.2.4

    1)
    for some strange reason, %USERPROFILE% does'nt get setted on my box.
    so, if you try do a 'require library' you may get:

    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:
    in `initialize': No such file or directory - %USERPROFILE%/.rbbr
    (Errno::ENOENT)

    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:in
    `open'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:in
    `[]='
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:90:in
    `[]='
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:100:in
    `add_libs'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/libselectiondialog.rb:83:in
    `initialize'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:27:in`new'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:27:in
    `create_menubar'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:26:in
    `call'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from c:/programmi/ruby-1.8/ruby/bin/rbbr.rb:22






    2)
    I suppose in the rescue clause there should exist an additional
    'NameError' catching. in browser.rb:39
    if you try to load this script

    $ary=Arrayciao 3000 , 0

    you may get this error:

    C:\Doents and Settings\gabriele\bf.rb:1: undefined
    method`Arrayciao' for #<Object:0x27892d0> (NoMethodError)
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:39:in
    `load'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:39:in
    `create_menubar'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:30:in
    `call'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from c:/programmi/ruby-1.8/ruby/bin/rbbr.rb:22

    btw, every NameError will crash rbbr. What's wrong with just catching
    every exception ?


    3)
    in moduleindex.rb line 47,
    maybe this :
    if iter.get_value(0) =~ /#{target_name}/i
    should become
    if iter.get_value(0) =~ /#{Regexp.quote(target_name)}/i

    other way, if you try to search for a single "]" you'll get a huge
    number of warnings in the console. But maybe this is ok.

    [1] I mean, those were is the environment that is not working or users
    doing stupid things :)
    gabriele Guest

  15. #15

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    Hi,

    At Mon, 15 Dec 2003 04:26:58 +0900,
    Rich wrote: 

    On Unices, HOME variable points each users own directory, and
    all user specific data are stored there. On Windows, "My
    Doents", "Application Data" or "User Profile" might be it.
    Commonly, this directory is expressed as "~/", and I suspect
    ruby on Windows should expand it to one of those folders.

    --
    Nobu Nakada


    nobu.nokada@softhome.net Guest

  16. #16

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    il Sun, 14 Dec 2003 22:00:17 +0900, Masao Mutoh <ne.jp>
    ha scritto::

     

    I just sent a longer message that does not seem to have appeared here.
    My ISP has problems ATM with newsservers so I try again.

    I think there are some possible fix before 0.5.1,
    my environment is
    winxp pro
    ruby 1.8.0 (2003-08-04) [i386-mswin32]
    ruby-gtk 0.8
    gtk from dropline 2.2.4

    1)
    for some strange reason, %USERPROFILE% does'nt get setted on my box.
    so, if you try do a 'require library' you may get:

    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:
    in `initialize': No such file or directory - %USERPROFILE%/.rbbr
    (Errno::ENOENT)

    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:in
    `open'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:in
    `[]='
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:90:in
    `[]='
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:100:in
    `add_libs'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/libselectiondialog.rb:83:in
    `initialize'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:27:in`new'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:27:in
    `create_menubar'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:26:in
    `call'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from c:/programmi/ruby-1.8/ruby/bin/rbbr.rb:22



    I accpet the erro, but possibly an error dialog instead of a crash
    would be better :)


    2)
    I suppose in the rescue clause there should exist an additional
    'NameError' catching. in browser.rb:39
    if you try to load this script

    $ary=Arrayciao 3000 , 0

    you may get this error:

    C:\Doents and Settings\gabriele\bf.rb:1: undefined
    method`Arrayciao' for #<Object:0x27892d0> (NoMethodError)
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:39:in
    `load'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:39:in
    `create_menubar'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/browser.rb:30:in
    `call'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from
    C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk.rb:54:in
    `main'
    from c:/programmi/ruby-1.8/ruby/bin/rbbr.rb:22

    btw, every NameError will crash rbbr. What's wrong with just catching
    every exception in that line ? (I'm a nuby forgive me :)


    3)
    in moduleindex.rb line 47,
    maybe this :
    if iter.get_value(0) =~ /#{target_name}/i
    should become
    if iter.get_value(0) =~ /#{Regexp.quote(target_name)}/i

    other way, if you try to search for a single "]" you'll get a huge
    number of warnings in the console. But maybe this is ok.

    gabriele Guest

  17. #17

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerberrors)

    Hi,

    On Mon, 15 Dec 2003 08:47:05 +0900
    gabriele renzi <vip.ukl.> wrote:
     
    >
    > I just sent a longer message that does not seem to have appeared here.
    > My ISP has problems ATM with newsservers so I try again.
    >
    > I think there are some possible fix before 0.5.1,
    > my environment is
    > winxp pro
    > ruby 1.8.0 (2003-08-04) [i386-mswin32]
    > ruby-gtk 0.8
    > gtk from dropline 2.2.4
    >
    > 1)
    > for some strange reason, %USERPROFILE% does'nt get setted on my box.
    > so, if you try do a 'require library' you may get:
    >
    > C:/Programmi/ruby-1.8/ruby/lib/ruby/site_ruby/1.8/rbbr/ui/gtk/confmanager.rb:65:
    > in `initialize': No such file or directory - %USERPROFILE%/.rbbr
    > (Errno::ENOENT)[/ref]

    Hmm, rbbr doesn't use %USERPROFILE% directly.
    How is your environment variables?
    I think your HOME environment is set like as HOME=%USERPROFILE%.
    If so, set correct path to HOME or USERPROFILE.
     

    Sure. I'll change it in the near future.
     
     

    Thanks. Fixed.
     

    The entry box accept regexp strings.
    For example, when you find classes which start 'A', put '^a'
    to the entry box. If you find Gtk::Window itself, put 'Gtk::Window$'
    there. If you find all of Gtk and Gdk modules/classes,
    put '(Gtk|Gdk)' there.
    It's really useful for me :).

    --
    :% Masao Mutoh<ne.jp>


    Masao Guest

  18. #18

    Default Re: rbbr errors (was: Re: rexml, rbbr, ruby-mysql, and exerb errors)

    il Tue, 16 Dec 2003 03:24:46 +0900, Masao Mutoh <ne.jp>
    ha scritto::
     
    thanks for the answer.. and btw, thanks for ths suggested fix, set
    HOME=myhome did it :)
    gabriele Guest

Similar Threads

  1. rexml 2.5.8 warning
    By Kurt V. Hindenburg in forum Ruby
    Replies: 1
    Last Post: November 7th, 07:57 PM
  2. Error in REXML
    By Daniel Carrera in forum Ruby
    Replies: 2
    Last Post: October 27th, 11:41 PM
  3. Replies: 2
    Last Post: July 16th, 09:49 AM
  4. rexml warnings
    By Ronald Pijnacker in forum Ruby
    Replies: 0
    Last Post: July 11th, 08:01 AM
  5. [REXML] PExtension
    By Sean Russell in forum Ruby
    Replies: 0
    Last Post: June 26th, 02:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •