Professional Web Applications Themes

Apache compile prob in portupgrade - FreeBSD

Not sure whats going on .. but if anyone can help us, much appreciated. libtool is the latest version ================================= ===> Building for apache-2.1.4 Making all in srclib Making all in pcre /usr/local/build-1/libtool --silent --mode=compile cc -g -O2 -O -pipe -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre -I. -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/os/unix -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/server/mpm/prefork -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/http -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/filters -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/proxy -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/include -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/generators -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/mappers -I/usr/local/include/apr-1 -I/usr/local/include -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/proxy/../generators -I/usr/include -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/ssl -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/dav/main -prefer-non-pic -static -c maketables.c && touch maketables.lo libtool: compile: unable to infer tagged configuration libtool: compile: specify a tag with `--tag' *** Error code 1 Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre. *** Error code 1 Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre. *** Error code 1 Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib. *** Error ...

  1. #1

    Default Apache compile prob in portupgrade

    Not sure whats going on .. but if anyone can help us, much appreciated.
    libtool is the latest version
    =================================

    ===> Building for apache-2.1.4
    Making all in srclib
    Making all in pcre
    /usr/local/build-1/libtool --silent --mode=compile cc -g -O2 -O -pipe
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre -I.
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/os/unix
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/server/mpm/prefork
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/http
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/filters
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/proxy
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/include
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/generators
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/mappers
    -I/usr/local/include/apr-1 -I/usr/local/include
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/proxy/../generators
    -I/usr/include -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/ssl
    -I/usr/ports/www/apache21/work/httpd-2.1.4-alpha/modules/dav/main
    -prefer-non-pic -static -c maketables.c && touch maketables.lo
    libtool: compile: unable to infer tagged configuration
    libtool: compile: specify a tag with `--tag'
    *** Error code 1

    Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre.
    *** Error code 1

    Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib/pcre.
    *** Error code 1

    Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha/srclib.
    *** Error code 1

    Stop in /usr/ports/www/apache21/work/httpd-2.1.4-alpha.
    *** Error code 1

    Stop in /usr/ports/www/apache21.

    --
    Yours Sincerely
    Shinjii
    http://www.shinji.nq.nu
    Warren Guest

  2. #2

    Default Re: Apache compile prob in portupgrade

    On Wed, 23 Mar 2005 3:53 pm, Niq wrote: 

    I just finished doing a complete cvsup with all ports & src and a
    "portupgrade -aDk -m BATCH=yes" before i got this problem as it is 1 of a few
    ports that dont upgrade.
    --
    Yours Sincerely
    Shinjii
    http://www.shinji.nq.nu
    Warren Guest

  3. #3

    Default Re: Apache compile prob in portupgrade

    > On Wed, 23 Mar 2005 3:53 pm, Niq wrote: 
    >
    >
    > I just finished doing a complete cvsup with all ports & src and a
    > "portupgrade -aDk -m BATCH=yes" before i got this problem as it is 1 of a few
    > ports that dont upgrade.[/ref]

    Just wanted to throw a "me too" in here... only with portmanager. Same error message.
    Luckily this is on my home machine, so I'm not too concerned about apache. Still rather
    annoying however...

    b
    Ben Guest

  4. #4

    Default Re: Apache compile prob in portupgrade

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    On 2005-03-23, Ben Munat scribbled these
    curious markings: 

    That's odd. I've been showing FreeBSD to a friend over the past few
    days, and he just installed Apache 2.x without any issues earlier this
    morning (EST timezone).

    Best Regards,
    Christopher Nehren
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iD8DBQFCQafXk/lo7zvzJioRAnheAJ0QHieDlx7lcSBDKj/t+hHj48DmKQCgjgfN
    lho0ns3kqv2rw0G6ZxDMiuE=
    =qGih
    -----END PGP SIGNATURE-----

    --
    I abhor a system designed for the "user", if that word is a coded
    pejorative meaning "stupid and unsophisticated". -- Ken Thompson
    If you ask the wrong questions, you get answers like "42" and "God".
    Unix is user friendly. However, it isn't idiot friendly.

    Christopher Guest

  5. #5

    Default Apache compile prob in portupgrade

    I have run this upgrade on the 2 machines i have here, with 2 different errors
    but both failing to install.
    =================================
    Main Production Machine error:

    libtool: compile: unable to infer tagged configuration
    libtool: compile: specify a tag with `--tag'
    *** Error code 1

    ========
    Routing Machine error:

    Making install in prefork
    find: /usr/local/include/apr-1/apr.h: No such file or directory
    find: /usr/local/include/apr-1/apr_allocator.h: No such file or directory
    find: /usr/local/include/apr-1/apr_anylock.h: No such file or directory
    find: /usr/local/include/apr-1/apr_atomic.h: No such file or directory
    find: /usr/local/include/apr-1/apr_base64.h: No such file or directory

    etc etc etc untill it fails

    Something has gone wonky somewhere.
    --
    Yours Sincerely
    Shinjii
    http://www.shinji.nq.nu
    Warren Guest

Similar Threads

  1. #25251 [Fbk]: starting apache after compile with postgres fails!
    By sniper@php.net in forum PHP Development
    Replies: 2
    Last Post: August 28th, 03:02 PM
  2. #25251 [Com]: starting apache after compile with postgres fails!
    By necmon_ at gmx dot de in forum PHP Development
    Replies: 1
    Last Post: August 28th, 12:49 PM
  3. Replies: 0
    Last Post: August 26th, 12:37 PM
  4. Replies: 1
    Last Post: June 24th, 08:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139