Hello:

Any help that anyone can give me or if you can at least point me in the
right direction I would really appreciate it.
I installed libapache-mod-ssl last week and I haven't been able to get
it to work. I got to the section in the readme file (from the
libapache-mod-ssl doentation) that said:

" If you don't have a virtual host but just one default server, you
should call this new virtualhost <VirtualHost _default_:443>."

This is after I had made the certificate and key, and chosen a
passphrase. So I went to the httpd.conf and all I did was add this
block:

<VirtualHost _default_:443>
<IfModule mod_ssl.c>
SSLEngine on
SSLCertificateFile /etc/apache/ssl.crt/server.crt
SSLCertificateKeyFile /etc/apache/ssl.key/server.key
<Files ~ "\.(cgi|shtml)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/usr/lib/cgi-bin">
SSLOptions +StdEnvVars
</Directory>
SetEnvIf User-Agent ".*MSIE.*" nokeepalive
ssl-unclean-shutdown

</IfModule>
</VirtualHost>

So then when it was time to stop and start apache, I did it through
Webmin and this is what I got:

Failed to start apache:
Starting web server: apacheApache/1.3.26 mod_ssl/2.8.9 (Pass Phrase
Dialog)
Some of your private key files are encrypted for security reasons. In
order to read them you have to provide us with the pass phrases.

Server 192.168.1.8:443 (RSA)
Enter pass phrase:
Apache:mod_ssl:Error: Private key not found.
**Stopped
failed

So I couldn't start Apache through the Webmin module (the samething also
happens when I reboot the server and it tries to start the apache
service, it will hang in that part of the boot up process until I enter
in the passphrase then it will continue booting), so then I went to the
command line and again I got the part that says "Enter pass phrase:" and
I did, and apache started. However, when I try to access apache through
[url]https://localhost[/url] or [url]https://host-ip-address[/url] or [url]https://host.domain.com[/url]
it doesn't work it just gives me the page cannot be displayed error. It
only works if I access the server through regular "http://" and not
through "https://" so my two big questions are:

1. How can I make it so that it doesn't ask me the pass phrase every
time I start apache? And if I do disable the pass phrase feature does
that mean that SSL is not started?

2. Why are the references to any https:// address to the web server work
even after I start apache in the command line and enter in the pass
phrase as I am prompted to do so? How come only the http:// references
work?

Again I would appreciate ANY type of help, I been looking at this for a
few days now I searched on the net and I can't seem to find what the
problem is. Thanx a lot!

Francisco


--
To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]