Hi,

I have apache 2.0.47 + php 4.3.2 + mod_jk2 2.0.2 installed on a Solaris 9
box. php and mod_jk2 are both DSO modules.

Yesterday, everything worked fine. Today I tried to add some virtual hosts
to httpd.conf and when I tried to restart apache, everything blew up.
Apache would not start, and it does not log anything, even with the log
level set to debug. I was noticing some other issues (that turned out to be
unrelated), so I rebooted the machine. Upon reboot, Apache is up and
running again. I go back to the virtual host stuff, restart apache, and
again it is not starting. I've removed all the virtual host stuff from the
config file and checked the syn

apachectl -e debug shows:

[Thu Aug 07 16:30:26 2003] [debug] mod_so.c(290): loaded module php4_module
[Thu Aug 07 16:30:26 2003] [debug] mod_so.c(290): loaded module jk2_module
[Thu Aug 07 16:30:26 2003] [debug] ../../server/apache2/mod_jk2.c(344):
mod_jk Create config for default server (null)

Now, after much searching, I've discovered that after I stop apache (with
the php module), there's some shared memory that doesn't go away. Once I
remove that, apache will start one process, but it's REALLY slow to connect
to at first.

bash-2.05# ipcs -p
IPC status from <running system> as of Thu Aug 7 17:24:11 EDT 2003
T ID KEY MODE OWNER GROUP LSPID LRPID
Message Queues:
T ID KEY MODE OWNER GROUP CPID LPID
Shared Memory:
m 0 0x5e002392 --rw------- root root 301 301
m 501 0x70efb188 --rw-r----- root other 5298 5329
Semaphores:
s 0 0x1 --ra-ra-ra- root root
bash-2.05# ipcrm -m 501
bash-2.05# /etc/init.d/apache start
bash-2.05# ps -ef |grep httpd
root 5343 1 0 17:26:52 ? 0:00 /usr/local/apache2/bin/httpd
-k start
root 5347 751 0 17:27:04 pts/5 0:00 grep httpd

So, now I've got php configured with the following options and it's still
not any better:

Command './configure' '--with-oci8=/oracle/app/oracle/product/92'
'--with-oracle=/oracle/app/oracle/product/92'
'--with-zlib-dir=../zlib-1.1.4/' '--with-apxs2=/usr/local/apache2/bin/apxs'
'--with-ldap=/portalapps/openldap' '--without-mysql' '--without-pear'
'--enable-sysvshm' '--enable-sysvsem' '--enable-sysvmsg' '--enable-shmop'

If I disable the php module apache will start up without a problem, however
php is needed. I didn't have any luck with apache 1.3.27 and mod_jk2 or
mod_jk, so I'm kind of stuck with apache2.

At this point, the only thing I can think to do is write a script to remove
that shared memory after I stop apache, but that won't solve the horrendous
slowness when apache is restarted. I'd rather solve the problem without
doing something kludgy like that.

Can anyone help?

Stacey Conrad
Millersville University