Professional Web Applications Themes

apache2 + PHP + RH - PHP Development

Sorry if this was discussed earlier. I couldn't find any relevant answers from the archive. I am currently testing RH Enterprise WS with the following: httpd-2.0.46-25.ent httpd-devel-2.0.46-25.ent freetds-0.61 I uninstalled the php rpm, because I couldn't get freetds(database connection to mssql server) part working. Then, I got php-4.3.4 and installed it from scratch with following options: ../configure --with-apxs2=/usr/sbin/apxs --enable-trans-sid --with-sybase-ct=/usr/local/freetds --with-ldap --with-gd --with-freetype-dir --with-zlib-dir I think I made the necessary changes in php.ini(//usr/local/lib/php.ini) and httpd.conf. However, apache seems to not parsing the php pages. My test pages work fine in the command prompt, but it spits out the code as ...

  1. #1

    Default apache2 + PHP + RH

    Sorry if this was discussed earlier. I couldn't find any relevant
    answers from the archive.

    I am currently testing RH Enterprise WS with the following:

    httpd-2.0.46-25.ent
    httpd-devel-2.0.46-25.ent
    freetds-0.61

    I uninstalled the php rpm, because I couldn't get freetds(database
    connection to mssql server) part working. Then, I got php-4.3.4 and
    installed it from scratch with following options:

    ../configure --with-apxs2=/usr/sbin/apxs --enable-trans-sid
    --with-sybase-ct=/usr/local/freetds --with-ldap --with-gd
    --with-freetype-dir --with-zlib-dir

    I think I made the necessary changes in php.ini(//usr/local/lib/php.ini)
    and httpd.conf. However, apache seems to not parsing the php pages. My
    test pages work fine in the command prompt, but it spits out the code
    as text when I access the pages from a browser.

    One other option I can look into is to remove the httpd rpms and build
    apache from scratch. However, I would like to avoid that, if I can make
    the above work. I would appreciate any pointers. Thanks.

    Happy Turkey day.

    -Sharif


    --
    )
    ((
    |""|-.
    | :|/'
    -`--'-


    Sharif Islam Guest

  2. #2

    Default Re: apache2 + PHP + RH

    Sharif Islam wrote:
    > Sorry if this was discussed earlier. I couldn't find any relevant
    > answers from the archive.
    >
    > I am currently testing RH Enterprise WS with the following:
    >
    > httpd-2.0.46-25.ent
    > httpd-devel-2.0.46-25.ent
    > freetds-0.61
    >
    > I uninstalled the php rpm, because I couldn't get freetds(database
    > connection to mssql server) part working. Then, I got php-4.3.4 and
    > installed it from scratch with following options:
    >
    > ./configure --with-apxs2=/usr/sbin/apxs --enable-trans-sid
    > --with-sybase-ct=/usr/local/freetds --with-ldap --with-gd
    > --with-freetype-dir --with-zlib-dir
    >
    > I think I made the necessary changes in php.ini(//usr/local/lib/php.ini)
    > and httpd.conf. However, apache seems to not parsing the php pages. My
    > test pages work fine in the command prompt, but it spits out the code
    > as text when I access the pages from a browser.
    >
    > One other option I can look into is to remove the httpd rpms and build
    > apache from scratch. However, I would like to avoid that, if I can make
    > the above work. I would appreciate any pointers. Thanks.
    Make sure you have Apache configured to run the module, and serve up PHP
    pages. This is from memory, so you had better check Apache docs:

    This was _probably_ done by the apxs2 mod installer:
    LoadModule php4_module [path to mods]/libphp4.so
    AddModule mod_php4.c

    This was probably not done by any install script:
    DirectoryIndex index.html index.php
    AddType application/x-httpd-php .php .html

    You need to put these in the appropriate place in the http.conf, and/or
    an .htaccess file (if allowable). Removing the RPM probably removed
    these entries, as well.

    clvrmnky Guest

  3. #3

    Default Re: apache2 + PHP + RH

    clvrmnky wrote:
    > Sharif Islam wrote:
    >
    >> Sorry if this was discussed earlier. I couldn't find any relevant
    >> answers from the archive.
    >>
    >> I am currently testing RH Enterprise WS with the following:
    >>
    >> httpd-2.0.46-25.ent
    >> httpd-devel-2.0.46-25.ent
    >> freetds-0.61
    >>
    >> I uninstalled the php rpm, because I couldn't get freetds(database
    >> connection to mssql server) part working. Then, I got php-4.3.4 and
    >> installed it from scratch with following options:
    >>
    >> ./configure --with-apxs2=/usr/sbin/apxs --enable-trans-sid
    >> --with-sybase-ct=/usr/local/freetds --with-ldap --with-gd
    >> --with-freetype-dir --with-zlib-dir
    >>
    >> I think I made the necessary changes in php.ini(//usr/local/lib/php.ini)
    >> and httpd.conf. However, apache seems to not parsing the php pages. My
    >> test pages work fine in the command prompt, but it spits out the code
    >> as text when I access the pages from a browser.
    >>
    >> One other option I can look into is to remove the httpd rpms and build
    >> apache from scratch. However, I would like to avoid that, if I can make
    >> the above work. I would appreciate any pointers. Thanks.
    >
    >
    > Make sure you have Apache configured to run the module, and serve up PHP
    > pages. This is from memory, so you had better check Apache docs:
    >
    > This was _probably_ done by the apxs2 mod installer:
    > LoadModule php4_module [path to mods]/libphp4.so
    > AddModule mod_php4.c
    >
    > This was probably not done by any install script:
    > DirectoryIndex index.html index.php
    > AddType application/x-httpd-php .php .html
    >
    > You need to put these in the appropriate place in the http.conf, and/or
    > an .htaccess file (if allowable). Removing the RPM probably removed
    > these entries, as well.
    >
    [url]http://php.mirrors.ilisys.com.au/manual/en/install.apache.php[/url]

    clvrmnky Guest

  4. #4

    Default Re: apache2 + PHP + RH

    clvrmnky wrote:
    > Sharif Islam wrote:
    [....]
    >
    > Make sure you have Apache configured to run the module, and serve up PHP
    > pages. This is from memory, so you had better check Apache docs:
    >
    > This was _probably_ done by the apxs2 mod installer:
    > LoadModule php4_module [path to mods]/libphp4.so
    > AddModule mod_php4.c
    >
    > This was probably not done by any install script:
    > DirectoryIndex index.html index.php
    > AddType application/x-httpd-php .php .html
    Thanks.
    Ya, that was it. I had the AddType in a wrong place. Now I need to
    figure out the freetds part.

    --
    )
    ((
    |""|-.
    | :|/'
    -`--'-

    Sharif Islam Guest

Similar Threads

  1. Apache2::AuthenNTLM
    By adam in forum PERL Modules
    Replies: 0
    Last Post: June 23rd, 09:28 AM
  2. apache2
    By in forum Linux / Unix Administration
    Replies: 3
    Last Post: June 9th, 02:29 AM
  3. #16909 [Com]: apache2
    By admin at toxiq dot servehttp dot com in forum PHP Development
    Replies: 0
    Last Post: September 26th, 05:09 PM
  4. apache2 with php 432
    By Nabil in forum PHP Development
    Replies: 0
    Last Post: September 8th, 03:24 PM
  5. [PHP-DEV] Apache2
    By Marc Richards in forum PHP Development
    Replies: 3
    Last Post: August 9th, 11:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139