Professional Web Applications Themes

Application ID Bug? - IBM DB2

I have a couple of scripts that look at the output from 'list applications' to figure out where users are connecting from. From the doc, the Application ID (for TCP/IP connections) contains the IP Address in a hex encoded form. However, with V8 (including FP3), I see an error in the IP address encoding. For example: GA170807.KA0A.013440042729 'GA170807' refers to the IP address, but 'GA' is not a valid hexadecimal value. I expected to see 0A170807 (10.23.8.7). Likewise, with another IP address, I get 'NF000001' instead of '7F000001' (127.0.0.1). Sometimes it does work. For example, 'C0A80132' (192.168.1.50) appears properly. The ...

  1. #1

    Default Application ID Bug?


    I have a couple of scripts that look at the output from 'list applications'
    to figure out where users are connecting from.

    From the doc, the Application ID (for TCP/IP connections) contains the IP Address
    in a hex encoded form. However, with V8 (including FP3), I see an error in the
    IP address encoding.

    For example: GA170807.KA0A.013440042729

    'GA170807' refers to the IP address, but 'GA' is not a valid hexadecimal
    value. I expected to see 0A170807 (10.23.8.7).

    Likewise, with another IP address, I get 'NF000001' instead of '7F000001'
    (127.0.0.1).

    Sometimes it does work. For example, 'C0A80132' (192.168.1.50) appears
    properly.

    The error always occurs (from what I've seen) in the first byte - I have
    not seen any errors in the second, third or fourth bytes.


    Has anyone else run into this?



    Thanks -






    -----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
    [url]http://www.newsfeeds.com[/url] - The #1 Newsgroup Service in the World!
    -----== Over 100,000 Newsgroups - 19 Different Servers! =-----
    Ian D Bjorhovde Guest

  2. #2

    Default Re: Application ID Bug?

    Ian D Bjorhovde <ianbjormobileaudio.com> wrote:
    >
    > I have a couple of scripts that look at the output from 'list
    > applications' to figure out where users are connecting from.
    >
    > From the doc, the Application ID (for TCP/IP connections) contains the IP
    > Address
    > in a hex encoded form. However, with V8 (including FP3), I see an error
    > in the IP address encoding.
    >
    > For example: GA170807.KA0A.013440042729
    >
    > 'GA170807' refers to the IP address, but 'GA' is not a valid hexadecimal
    > value. I expected to see 0A170807 (10.23.8.7).
    >
    > Likewise, with another IP address, I get 'NF000001' instead of '7F000001'
    > (127.0.0.1).
    >
    > Sometimes it does work. For example, 'C0A80132' (192.168.1.50) appears
    > properly.
    >
    > The error always occurs (from what I've seen) in the first byte - I have
    > not seen any errors in the second, third or fourth bytes.
    >
    > Has anyone else run into this?
    That's the normal behavior. The first character of the application ID is
    mapped from '0' thru '9' to the letters 'G' thru 'P'. That's a DRDA
    requirement.

    So in your case, 'GA170807' needs to be mapped back to '0A170807' which is
    what you expected in the first place.

    --
    Knut Stolze
    Information Integration
    IBM Germany / University of Jena
    Knut Stolze Guest

  3. #3

    Default Re: Application ID Bug?

    Knut Stolze wrote:
    >>
    >>'GA170807' refers to the IP address, but 'GA' is not a valid hexadecimal
    >>value. I expected to see 0A170807 (10.23.8.7).
    >>
    >>Likewise, with another IP address, I get 'NF000001' instead of '7F000001'
    >>(127.0.0.1).
    >>
    >
    > That's the normal behavior. The first character of the application ID is
    > mapped from '0' thru '9' to the letters 'G' thru 'P'. That's a DRDA
    > requirement.
    So I guess this change in behavior was a result of the V8 common client?
    It might be good to note this in the docs.


    Thanks, Knut!





    -----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
    [url]http://www.newsfeeds.com[/url] - The #1 Newsgroup Service in the World!
    -----== Over 100,000 Newsgroups - 19 Different Servers! =-----
    Ian D Bjorhovde Guest

Similar Threads

  1. Flash Remoting Application.cfc & Application.cfm problem
    By Joćo Fernandes in forum Coldfusion Flash Integration
    Replies: 0
    Last Post: April 11th, 03:22 PM
  2. Replies: 0
    Last Post: August 9th, 11:33 AM
  3. Replies: 2
    Last Post: August 7th, 07:13 AM
  4. Replies: 0
    Last Post: August 4th, 09:08 PM
  5. Replies: 0
    Last Post: July 3rd, 08:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139