Professional Web Applications Themes

application_start in webservices - ASP.NET Web Services

Hello...since application_start is not being called when u invoke a webservice for the first time...where r u suppose to or how r u suppose to persist "application_start" global variables? My "work" around is to launch a webform1 that starts application_start...but that seems silly :-) Regards, mekim...

  1. #1

    Default application_start in webservices

    Hello...since application_start is not being called when u invoke a
    webservice for the first time...where r u suppose to or how r u suppose to
    persist "application_start" global variables?

    My "work" around is to launch a webform1 that starts application_start...but
    that seems silly :-)

    Regards,
    mekim
    mekim Guest

  2. #2

    Default RE: application_start in webservices

    Hi,

    In general, the advice is to make your web services stateless - that is not
    use any server side state to store session information. The easiest way to
    manage state across the web service bounday is to activate cookies (proxy
    must accept cookies) and use cookies to persist state across the call.

    I hope this helps

    Dan Rogers
    Microsoft Corporation
    --------------------
    >Thread-Topic: application_start in webservices
    >thread-index: AcS8PIA/+zI5+mhDRIKfmmpTSOMX1w==
    >X-WBNR-Posting-Host: 68.157.85.195
    >From: "=?Utf-8?B?bWVraW0=?=" <mekimdiscussions.microsoft.com>
    >Subject: application_start in webservices
    >Date: Wed, 27 Oct 2004 08:49:10 -0700
    >Lines: 9
    >Message-ID: <2BDBBDE6-7FBB-4797-B55F-936594CFD7DAmicrosoft.com>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > cht="Utf-8"
    >Content-Transfer-Encoding: 7bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet.webservic es
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa10.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa10.phx.gbl
    microsoft.public.dotnet.framework.aspnet.webservic es:26278
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservic es
    >
    >Hello...since application_start is not being called when u invoke a
    >webservice for the first time...where r u suppose to or how r u suppose to
    >persist "application_start" global variables?
    >
    >My "work" around is to launch a webform1 that starts
    application_start...but
    >that seems silly :-)
    >
    >Regards,
    >mekim
    >
    Dan Rogers Guest

Similar Threads

  1. Web Service throws exception during Application_Start
    By fm@newsgroups.nospam in forum ASP.NET Web Services
    Replies: 7
    Last Post: December 15th, 04:19 PM
  2. Application_Start event
    By Nissim in forum ASP.NET Web Services
    Replies: 5
    Last Post: January 15th, 03:19 AM
  3. Application_Start event does not fire on restart of IIS?
    By Morten Overgaard in forum ASP.NET
    Replies: 1
    Last Post: August 26th, 06:30 AM
  4. Application_Start fails
    By Anne Too in forum ASP.NET General
    Replies: 0
    Last Post: August 10th, 02:23 PM
  5. Application_Start not firing at all
    By Adrian in forum ASP.NET General
    Replies: 0
    Last Post: July 2nd, 03:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139